-   Linux - Hardware (
-   -   Promise Ultra133 tx2 quantum stt320000a tape drive problem (

z3r0star21 03-01-2006 10:37 AM

Promise Ultra133 tx2 quantum stt320000a tape drive problem
I have gentoo linux system with a 2.6 kernel, with a promise ultra133tx2 controller that I am trying to get to work with a Quantum STT320000A ide tape drive. I compiled support for IDE tape drive in the kernel. The drive is dectected as hde, and I am supposed to use /dev/ht0 for the device. When I try to write to the drive with 'tar cpzf /dev/ht0 /home' I get an Input/Output Error, could not open the device.

The reason I'm trying to use the IDE controller card is because for some reason I cannot get the bios to detect the tape drive on the onboard IDE controllor. I have had to motherboards both Asus P4P800 series that would not detect the drive in the bios. All other systems i put the tape drive in, recognize the drive in the bios right away. I have swapped drive cables to check for a problem there.

Any direction would be apreciated.


kilgoretrout 03-01-2006 11:48 AM

Did you compile ide-tape directly in the kernel or as a loadable module? If the latter, run:

# modprobe ide-tape

before trying to tar to the tape drive.

Other than that, I believe it may be a problem with your controller card. Most do not like anything other than hard drives attached to them. You may want to check the card documentation on that. IIRC my Promise Ultra100 card would not work properly with any optical drive connected to it; I imagine it would completely freak with an ide tape drive.

WhatsHisName 03-01-2006 02:12 PM

z3r0star21: During the BIOS startup/post, does the Promise BIOS output to the monitor show that the tape drive is being recognized?

In my case using Promise Ultra100/133 TX2 cards, optical drives and LS-120s (SuperDisk) work fine, but I have never tried anything else, other than hard drives, of course.

Also, the LS-120s are recognized and work properly, but they cannot be selected as boot drives from the system BIOS like you normally would do.

I would be surprised if you get the tape drive to work through the Promise card.

z3r0star21 03-02-2006 04:13 PM

I'm Still trying to work through this issue.
I'm Still trying to work through this issue.

ide-tape is compiled directly in the kernel. The controller does support more than just hard drives.

I tried once again to connect to tape drive to the onboard controller, and It is not detected in the bios, but my system log /var/log/dmesg has this in it.

ide-tape: hdc <-> ht0: Seagate STT20000A rev 8A51
ide-tape: hdc <-> ht0: 1000KBps, 6*54kB buffer, 9720kB pipeline, 108ms tDSC, DMA

So even though it's not detected in the bios, the krenel still detects the device, but I still cannot write to it. When i try to tar the first couple of times this is what happens.

# tar -cpzf /dev/ht0 /etc /home
tar: Removing leading `/' from member names

and then thats it. When i run that command a couple more times i eventually get this:

# tar -cpzf /dev/ht0 /etc /home
tar: Removing leading `/' from member names
tar: /dev/ht0: Cannot write: Input/output error
tar: Error is not recoverable: exiting now
Broken pipe

Am i missing something in the kernel? Not sure where i'm going wrong here?

Thanks for all your help so far.

kilgoretrout 03-02-2006 10:15 PM

See if the mt command works. Try running:

# mt /dev/ht0 rewind


# mt /dev/ht0 reten

z3r0star21 03-02-2006 11:02 PM

Fixed it
Ok, I figured it out. The tape drive works both with the promise card, and on the onboard controller, even through it wasn't detected in the bios. The tape I was using came with the drive directly from Quantum, and guess what, the brand new tape was bad. I put a new tape in and, I issued the tar command and it worked. I just assumed that the new tape that came with the drive was a good tape.

Thanks for all your help.

All times are GMT -5. The time now is 10:11 AM.