LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (https://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   promise ultra 100 tx2 (https://www.linuxquestions.org/questions/linux-hardware-18/promise-ultra-100-tx2-70110/)

ISOmorph 07-04-2003 01:08 PM

promise ultra 100 tx2
 
hi,

i buyed a promise ultra 100 tx2, so that i can use 2 more hdd i had @ home. My hdd system looks now as follows:

hdd on the mainboard:
hdd 0: partition 0:linux (mandrake 9.1) , partition 1: windows(XP pro) , part 2,3
hdd 1: part 0,1,2

the hdd on the ide controller:
hdd 2: part 0,1
hdd 3: part 0,1

the mbr is written on the hdd0, and starts lilo, to switch betwenn the 2 OS

my problem is that now that i hav the controller in my pc, linux doesnt start anymore. the following error message is displayed on booting linux:
mount:error 6 mounting ext3 flags kernel panic: No init found. Try passing init=option to kernel.
(windows does start without any problems)

i tried the following:
reinstall linux (about 10 times): which ended that even lilo didnt want to start, and after the bios of the controller finished recognising my 2 hdd, the system stayed in DOS and just displayed:
L 99 99 99 99 99 ... and so on
what was intresting is that during the installation, linux displayed the 2 hdd of the ide controller first, and linux which i used to install on the first partition of hdd0 (called hda1 under linux) called the SAME hdd "hde1".
so i hadnt any choice, i removed the controller from my pc and reinstalled linux, what went as usual. linux worked again. controller back in pc...linux didnt work.

what i suppose after this install-reinstall procedure, is that linux just recognises my controller and the 2 hdd on it as the first ide controller and not the one on the mainboard. which means that i cant install linux correctly after the controller is in my pc cuz i cant write a new mbr, and i cant use the old linux installation cuz it thinks the hdd where linux is installed, isnt the boot device.

any suggestions, im stuck. i allready tried all new drivers and BIOS for the controller, nothin worked.
thx

(ignore my bad english please ;-) )

ISOmorph 07-04-2003 05:10 PM

help please!!! :/

ISOmorph 07-05-2003 10:17 PM

k found it, just add "ide=reverse" to the OS boot parameters in the lilo.conf. that fixed the prob 4 me. maybe i can help other ppl that way.


All times are GMT -5. The time now is 11:57 AM.