LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (https://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   Promise SX6000 and making bootable raid 5 (https://www.linuxquestions.org/questions/linux-hardware-18/promise-sx6000-and-making-bootable-raid-5-a-69936/)

The Jesus 07-03-2003 06:21 PM

Promise SX6000 and making bootable raid 5
 
I am trying to install Gentoo linux to a promise SX6000 raid 5 array. Here is my problem. When I boot up Gentoo takes 20 minutes to go through the array and then the drives show up as five different drives. Performance is very slow. And I can't actally partition. I don't think the correct support is in the gentoo kernel. I know Promise has the source for the drivers. I am not sure how to implement that into the gentoo boot cd. Basically I am wondering if anyone has had a similar experience and could point me in the right direction. I am confused on how to make this work correctly. Thanks in advance.


:Pengy:

JohnLinx 02-24-2004 04:14 PM

I am having a like issue. Currently trying to install this card under Redhat Enterprise. I have contacted Promise, they do not have a driver for this version. I have compiled the source on another machine, using the correct version of the source. Now, I just need to figure out a way to install the driver during the installation process. Maybe someone out there knows how to do this? Maybe we can help each other and find the solution....


:confused:

JohnLinx 05-12-2004 12:41 PM

Okay, got mine working. I had to use RH 9.0, as the I could not get the driver from promise to install in the ES version.

You mention that your array shows up as 5 seperate drives? I think you have a problem with the confiuration of the arrary, I would start there.

4evernoob 05-23-2004 12:28 PM

I'm trying to setup a sx6000 on Fedora core 1. Is this even possible?
Seems to me if it can run on RH9 it should be able to run on core 1. But I'm way noob so what do I know.

:newbie:

opticus 06-27-2004 04:40 AM

is the sx6000 controller suppose to beep while initializing the raid when i setup a raid5 in the bios on the card?

4evernoob 06-27-2004 09:33 PM

It always beeps until initialization is complete.
Annoying at least.

henrykkp 07-12-2004 10:01 PM

Quote:

Originally posted by JohnLinx
I am having a like issue. Currently trying to install this card under Redhat Enterprise. I have contacted Promise, they do not have a driver for this version. I have compiled the source on another machine, using the correct version of the source. Now, I just need to figure out a way to install the driver during the installation process. Maybe someone out there knows how to do this? Maybe we can help each other and find the solution....


:confused:


I have the same problem with you. I have a new system that will running RedHat Enterprise 3.0, RAID 5, and also the Promise SX6000 Raid Card. I cannot find any drive on promise officical website support RedHat Enterprise 3.0. The only things I found is the linux source drive. However, I am a newbie and I really feel very confused the instruction. Could you tell me more detail of how to obtain or make the driver.

Thanks for your help.


All times are GMT -5. The time now is 08:29 PM.