LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (https://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   Promise RAID controller setup. How-to? (https://www.linuxquestions.org/questions/linux-hardware-18/promise-raid-controller-setup-how-to-157214/)

thelandrew 03-13-2004 03:09 PM

Promise RAID controller setup. How-to?
 
Greetings!

I'm a linux n00b, so go easy on me.

I have a Promise S150 SX4 SATA RAID(5) controller installed in my system. I have configured a 3-disk array via the BIOS setup utility... But I can't seem to access the array in linux.

System Spec.

Celery 2Ghz
ASUS P4S8X-X
256MB DDR (Corsair)
nVidia GF2 TI (64)
Boot Disk = WD 20GB
Current OS=Fedora(core1)

I have tried installing the card-driver both in Redhat9 (officially "supported" by Promise) and Fedora (does anyone support this?). No luck.

On Both OS's I am able to insert the driver disk on install. Both Installers seem to take the disk no-probs. Once the OS is loaded, I then install the command line utility using instructions from Promise. Once the CLU is loaded, I try to run it; I get the error "driver not found".

I then try to follow the instructions for loading a driver on an existing OS. on RH9, this appears to work (no errors at the CL), but I still cannot see the drive in disk management, and I get the same error with the Promise CLU. With Fedora 9 I get a CL error message :No drivers found for kernel Version .....

Per the readme sticky /sbin/lspci
Code:

00:00.0 Host bridge: Silicon Integrated Systems [SiS] SiS 645xx (rev 11)
00:01.0 PCI bridge: Silicon Integrated Systems [SiS]: Unknown device 0003
00:02.0 ISA bridge: Silicon Integrated Systems [SiS]: Unknown device 0963 (rev 25)
00:02.5 IDE interface: Silicon Integrated Systems [SiS] 5513 [IDE]
00:02.7 Multimedia audio controller: Silicon Integrated Systems [SiS] Sound Controller (rev a0)
00:03.0 USB Controller: Silicon Integrated Systems [SiS] USB 1.0 Controller (rev 0f)
00:03.1 USB Controller: Silicon Integrated Systems [SiS] USB 1.0 Controller (rev 0f)
00:03.2 USB Controller: Silicon Integrated Systems [SiS] USB 2.0 Controller
00:04.0 Ethernet controller: Silicon Integrated Systems [SiS] SiS900 10/100 Ethernet (rev 91)
00:09.0 RAID bus controller: Promise Technology, Inc.: Unknown device 6622 (rev 01)
01:00.0 VGA compatible controller: nVidia Corporation NV15DDR [GeForce2 Ti] (rev a4)

What am I doing wrong?

How can I tell if the driver is installed?

Do I need the CLU? (I need a clu(e) for sure. but a CLU?)

What is 5 times the square root of the number of Linux users it takes to change a light bulb?

-landrew the :newbie:

studpenguin 03-13-2004 09:45 PM

http://www.mwvlug.org/modules.php?na...wtopic&p=12#12

thelandrew 03-13-2004 09:57 PM

Err... I'm not sure what I'm supposed to get out of that? Should I install "gentoo"?

-landrew the :newbie:

studpenguin 03-13-2004 10:31 PM

Well that's what seems to be the case with me today . . . bear in mind I'm a newbie too, I generally don't know shit about Linux.


Umm . . . here's another link you might find useful.


http://www.viaarena.com/?PageID=297#VT8237

studpenguin 03-13-2004 10:34 PM

OH . . it just might be this controller too . . .


VT6306/VT6307 IEEE 1394 OHCI host controller

thelandrew 03-13-2004 10:52 PM

I think that you are on the wrong track. This is not a VIA RAID controller that I am having a problem with. It is a Promise S150 SX4 card. The controller chip is a PDC20621. Not a V- anything.

-landrew the :newbie:

d1sc0rd 03-14-2004 05:30 AM

I recent;ly got my onboard promise 20265 working. I had to use one of the 2.4 kernels and add fastrak support and also I had a look at the Linux-raid howto or something similar and added some lines to lilo. I am now having trouble because I need to have an inital ram disk to boot off the raid array but the pcramdisk or similar utility is not working. Basically I can use my raid but I cannot boot off of it.

thelandrew 03-14-2004 10:39 AM

Could you direct me to the linux-raid howto URL?

What is a lilo?


-landrew the :newbie:

thelandrew 03-14-2004 07:45 PM

bump

d1sc0rd 03-15-2004 03:44 AM

Hmm I reccomend that you pick up a book on linux like runing linux maybe if you don't have money goto the library. Anyways lilo stands for linux loader and like grub it loads the linux kernel.
I also reccomend that you use the slackware 9.1 distribution with your raid array. Now download slackware 9.1 cd iso images and put disc one into your cdrom and at the boot prompt type ataraid.i and press enter. now log in as root and type cfdisk /dev/ataraid/d0 to format your raid array. after making a linux partition and a linux swap partition on you drives make sure you choose write to save the data to the partition table. next exit cfdisk and type setup. the rest should be fairly self explanitory. Oh also all the HOWTOs are generally located at the LinuxDocumentationProject , i think the url is ldp.org and also you can always do a google search.

-d1sc0rd-

thelandrew 03-15-2004 08:09 PM

Ok then. Slackware 9.1 CDs created.

Swap and Load drives created no prob.

cfdisk /dev/ataraid/d0 produces a FATAL ERROR: Cannot open disk drive.

What now?



AFAIK, Slackware 9.1 does not support this device, and the manufacturer's drivers are a) distribution specific (redhat or suse), and b) dont seem to be working for me in any case.

I believe that kernel 2.6 is "supposed" to have native support for this card?? Does updating a kernel update drivers, or are there other things I have to get/do?

-landrew the :newbie:

d1sc0rd 03-15-2004 08:56 PM

did you type ataraid.i at the boot prompt?

thelandrew 03-15-2004 09:50 PM

yes

but I dont think slack 9.1 has the driver for this controller.

d1sc0rd 03-16-2004 12:41 AM

okay well i have got it half working. I did not use any driver but there is support for fastrak in the linux kernel and support for the controller. If you do not think that it will work than fine. The how to i was reffering to before is the Linux ata raid howto and you can do a google search and find it at the ldp. anyways If I am sucessful I will post my own instructions here on how to get it working but I am not completly sucessful right now as I need a bootdisk.

d1sc0rd 03-17-2004 07:10 AM

I forgot to mention that particularilly you may find the append line section how to helpfull. This is how I got the drive to respond when hooked up to a computer with another hardrive not on the controller booting.


Specifically to get it half working I

1. compiled a kernel in slack 9.1 on another hard drive not on the array which included support for promise 20265 and the fastrak support in the kernel

2. I edited lilo.conf and added the proper append line following the linux raid how to.

3. I was then able to partition the array and it seemed to work fine except I was still booting off another drive. After this I have so far tried but not succeded in getting it to function stand alone, here is where I'm at.

4. I was able to then run slackware setup after booting off cd with ataraid.i rand install slackware to the raid array

5. I removed the oteher drive but am unable to boot the raid array by itself. Maybe it has to do with an inital ramdisk...

6. I've found a strange bug where I use the slackware cd to boot by typing ataraid.i root=/dev/ataraid/d0p1 ro . After this it goes to the cfdisk and slack setup part but when I login as root and then type halt instead of the system shutting down it seems to load the kernel again and now load slackware on the drive in working order. If I add the append line to lilo.conf this time though I get a whole bunch of !) errors and it does not work.

Anyone who is more knowlagable about this then me feel free to give advice on how I can get this to boot off the raid array without any bootdisk/cd...

If I have any more luck I will post it here.

-d1sc0rd-


All times are GMT -5. The time now is 01:58 AM.