LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 01-22-2008, 09:18 AM   #1
stormrider_may
Member
 
Registered: Sep 2005
Distribution: Debian
Posts: 304

Rep: Reputation: 30
Problems with Sound Card on Debian ( already tried alsaconf )


Hello,

I have the following soundcard:

Code:
80:01.0 Audio device: VIA Technologies, Inc. VIA High Definition Audio Controller (rev 10)
I'm trying to use it on Debian Etch but even after using alsaconf i don't get any sound.

Alsaconf, itself, doesn't shows any erros. But if i try to run alsamixer just after running alsaconf i get this error:

Code:
# alsaconf
Unloading ALSA sound driver modules: snd-hda-intel snd-hda-codec snd-pcm-oss snd-mixer-oss snd-pcm snd-timer snd-page-alloc.
Building card database...


Running update-modules...
Loading driver...
Setting default volumes...
amixer: Mixer attach default error: No such device
Saving the mixer setup used for this in /var/lib/alsa/asound.state.
/usr/sbin/alsactl: save_state:1254: No soundcards found...


===============================================================================

 Now ALSA is ready to use.
 For adjustment of volumes, use your favorite mixer.

 Have a lot of fun!

# alsamixer

alsamixer: function snd_ctl_open failed for default: No such device
Any ideas of what should i do?
 
Old 01-23-2008, 02:18 AM   #2
Drakeo
Senior Member
 
Registered: Jan 2008
Location: Urbana IL
Distribution: Slackware, Slacko,
Posts: 3,716
Blog Entries: 3

Rep: Reputation: 481Reputation: 481Reputation: 481Reputation: 481Reputation: 481
some how it is the wrong module that is loading.
 
Old 01-23-2008, 09:39 AM   #3
stormrider_may
Member
 
Registered: Sep 2005
Distribution: Debian
Posts: 304

Original Poster
Rep: Reputation: 30
Quote:
Originally Posted by Drakeo View Post
some how it is the wrong module that is loading.
How can i load the right module?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
alsaconf not detecting sound card mattd7591 Linux - Hardware 7 10-20-2006 01:14 PM
alsaconf not finding sound card stevemalcolm Debian 1 09-22-2005 02:01 AM
alsaconf is not detecting sound card venkatd Linux - Hardware 2 08-07-2005 12:10 PM
alsaconf not recognizing my onboard sound card gonus Debian 14 08-19-2004 08:43 AM
alsaconf wont detect my sound card biophysics Linux - Hardware 22 07-22-2003 07:32 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 09:36 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration