-   Linux - Hardware (
-   -   Problems with Nforce4 and onboard ide controller (

TheDude05 01-12-2005 11:19 PM

Problems with Nforce4 and onboard ide controller
I have Mandrake 10 installed on an old 30 gig hard drive I had sitting around. That hard drive, and another 120 gig hard drive are on a pci ide controller. Linux won't recgonize anything thats connected to my onboard ide controllers. (IDE slots on the motherboard). I need to be able yo have access to that controller because my CD Roms are on it. Tried mounting them, etc. I'm a linux noob so maybe I'm doing something wrong. My motherboard is an Asus A8N-SLI.

I also had a similiar problem with this when I was trying to install Mandrake for the first time. The cd's would boot but then when the installer came up, it said it couldn't find a cd rom. I ended up installing it from the iso's on a fat32 partition. Help please.

barryman_5000 01-12-2005 11:32 PM

Here is the problem . . . if you are quoting that motherboard's model correctly then you must be using SATA and not normal IDE. Try using /dev/sda1 and /dev/sdb1, etc for your drives. Also look at this page:

Be sure to tell me if that helps.

TheDude05 01-13-2005 09:03 AM

No I'm using standard IDE. I don't have any SATA devices.

If it helps any... Its calling the my other 120gig hard drive hda and the 30gig that linux is on hdc. It must look locally on that controller card, but then its not looking at my other controllers which are on the motherboard.

TheDude05 01-13-2005 05:56 PM

Ok... finding out a little more stuff. sda sdb sdc all are my flash memory card drives. No one has any ideas?

EDIT: Maybe this will help but I don't know...

[andrew@localhost sbin]$ lspci
00:00.0 Memory controller: nVidia Corporation: Unknown device 005e (rev a3)
00:01.0 ISA bridge: nVidia Corporation: Unknown device 0050 (rev a3)
00:01.1 SMBus: nVidia Corporation: Unknown device 0052 (rev a2)
00:02.0 USB Controller: nVidia Corporation: Unknown device 005a (rev a2)
00:02.1 USB Controller: nVidia Corporation: Unknown device 005b (rev a3)
00:06.0 IDE interface: nVidia Corporation: Unknown device 0053 (rev a2)
00:07.0 IDE interface: nVidia Corporation: Unknown device 0054 (rev a3)
00:08.0 IDE interface: nVidia Corporation: Unknown device 0055 (rev a3)

00:09.0 PCI bridge: nVidia Corporation: Unknown device 005c (rev a2)
00:0a.0 Bridge: nVidia Corporation: Unknown device 0057 (rev a3)
00:0b.0 PCI bridge: nVidia Corporation: Unknown device 005d (rev a3)
00:0c.0 PCI bridge: nVidia Corporation: Unknown device 005d (rev a3)
00:0d.0 PCI bridge: nVidia Corporation: Unknown device 005d (rev a3)
00:0e.0 PCI bridge: nVidia Corporation: Unknown device 005d (rev a3)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 NorthBridge
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 NorthBridge
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 NorthBridge
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 NorthBridge
01:00.0 VGA compatible controller: nVidia Corporation: Unknown device 0140 (rev a2)
05:06.0 Multimedia audio controller: Creative Labs SB Audigy (rev 04)
05:06.1 Input device controller: Creative Labs SB Audigy MIDI/Game port (rev 04)
05:06.2 FireWire (IEEE 1394): Creative Labs SB Audigy FireWire Port (rev 04)
05:07.0 Multimedia video controller: Conexant: Unknown device 8800 (rev 05)
05:08.0 Unknown mass storage controller: Promise Technology, Inc. 20269 (rev 02)
05:0b.0 FireWire (IEEE 1394): Texas Instruments TSB43AB22/A IEEE-1394a-2000 Controller (PHY/Link)
05:0c.0 Ethernet controller: Galileo Technology Ltd.: Unknown device 4320 (rev 13

I'm no linux genius, but it appears to me that my Nvidia IDE controller is showing up. My Prmoise IDE controller is also showing up at the bottom. I'll bold them. What am I doing wrong?

barryman_5000 01-13-2005 09:13 PM

what version kernel are you using? You have alot of undetected hardware and maybe you are using an older kernel (2.4 and not 2.6)

Try uname -r on the command line.

TheDude05 01-13-2005 10:18 PM

Its 2.6 something. Hold on let me boot into Linux and i'll post it from there.

[andrew@localhost andrew]$ uname -r

barryman_5000 01-13-2005 10:31 PM

I guess I can suggest upgrading your kernel. I looked at a few changelogs (2.6.9 > 2.6.10 and 2.6.8 > 2.6.9) and I notice a few things on nvidia ide controllers . . . try to get it through mandrake and it should install it for you.

barryman_5000 01-13-2005 10:42 PM

You will find this esp. helpful!! can't believe how nice this was to find --

[PATCH] PCI: Disable mmconfig on AMD CPUs.

Disable mmconfig on AMD CPUs.

This patch fixes various problems on PCI Express boards, like the
Nforce4. They have a MCFG table in ACPI, but not all devices can be
accessed using MMCONFIG. e.g. the CPU builtin PCI devices in the A64
Northbridge can't. Linux happily uses mmconfig for all PCI devices and
that cause failures and memory corruption.

Right solution apparently is to get more information from MCFG which is
supposed to tell for which busses mmconfig is legal and for which ones
not. But that would be a much more complicated patch and I don't have
a specification of this enhanced table.

This patch just disable MMCONFIG on all AMD CPUs. This is a kludge,
but works around the problem for now.

Patch for both i386 and x86-64

Signed-off-by: Andi Kleen <>
Signed-off-by: Greg Kroah-Hartman <>

So it should work on 2.6.10 but nothing less. That is a bug for you that will hopefully be fixed with the 2.6.10 kernel.

I forgot to mention that as I looked through some 2.6.0 to 2.6.7 changelogs that they should have also fixed all the problems with your lspci saying "unknown" on all your devices.

TheDude05 01-13-2005 10:45 PM

Thanks for all your help. I think i'm just going to download the new 10.1 ISOs and try and re-install it all.I just tried running Mandrake's update control center thing and it said it couldn't get any of the packages in the list. This install is just broken. From the time the bootable disk said it couldn't find a cd rom, to running the iso's off another hard drive and essentially none of the packages installing right, its just been a headache. I'm assuming 10.1 will have a newer kernel but I'll check before I download. I do appreciate all the help you've given me. If I wasn't a poor high school student i'd send a donation.

EDIT: So its just a problem with my outdated kernel then? Sounds good. Atleast its been addressed. Still think I should go ahead with finding a 10.1 iso or should I try something else... i'm kind of a newb at this :rolleyes:

TheDude05 01-13-2005 11:28 PM

Well Mandrake 10.1 runs off 2.6.8 kernel with some fixes from 2.6.9rc. Does this mean i'm going to have the same "Can't find cd rom" error again with the install?

barryman_5000 01-13-2005 11:45 PM

maybe you should make your own kernel . . . it'll be fun :-D

Mandrake hasn't even touched anything beyond a 2.6.9rc3 kernel so I think you are gonna have to download 2.6.10 from . . . Have you ever compiled a kernel? If not reply back and I will go over the pain of it all . . . its gonna be fun XD

TheDude05 01-14-2005 03:21 PM

Well... I really don't have much expirience with Linux at all so no never compiled a new kernel or done anything with my own. My programming skills are kind of low too. I only know some visual basic javascript which won't help much. If its not too big of a problem could you explain the method of going about compiling the kernel. You've already helped me a lot and i'm anxious to learn more, but am I getting in over my head?

barryman_5000 01-14-2005 09:19 PM

Not at all. Compiling a kernel is easy if you know your hardware ;) -- click here to download the kernel.

Save it to /tmp. Open an xterm and type in the following:


su (to login as root)
cd /tmp
bunzip2 linux-2.6.10.tar.bz2 -c > /usr/src/
cd /usr/src/linux-2.6.10
cp ../linux/.config .config (copies old config)
make xconfig (or make gconfig if that doesn't work)

Now you will be in a nice gui to configure the kernel (its come a long way!). If you want you can go through and chose all the options but instead we copied your old config over so no problem, right?
Now we just need to make sure your stuff is all on there. Anything checked is compiled into the kernel and anything that's a boxed in is going to be compiled outside the kernel as a module.

If you want you can peruse all this and if you find anything that you are ABSOLUTELY sure is incorrect then you can change it otherwise you can exit that configure program(I just wanted you to be aware of how to do it).

Next you are back at the xterm. Type:


make all (compiles the kernel)
make modules_install (will put the modules in their places)

The next thing depends on your cpu. If you don't run an amd64 then type:


cp arch/i386/boot/bzImage /boot/CustImage
If you run an amd64 then type:


cp arch/x86_64/boot/bzImage /boot/CustImage
If you happened to change anything about the config then I suggest you also type this:


cp /boot/
cp /boot/map

Now everything is done except for one thing! If you use lilo then you need to edit your /etc/lilo.conf as root and add this at the end:

root=/dev/hdc5 (change this to your default drive).

then just save that and run lilo


^^ lol

If you use grub edit your /boot/grub/grub.conf (or menu.lst . . . whichever exists) as root to have this at the end:

title TestKernel
root (hd1,0) (make this the value of your root. this is the second harddrive first partition)
kernel /boot/CustImage root=/dev/hdb1 (make this your root system).
#initrd /initrd.img

Thats all there is to it. Restart and choose TestKernel. If you have any problems then post it here. Grub doesn't need you to run any commands so yay for that ;)

TheDude05 01-15-2005 05:08 PM

The syntax to unzip the file does work correctly... it says /usr/src/ is a directory and won't extract

EDIT: Didn't use that exact syntax but the archive into the correct spot using number of different methods. Going to try rest of the post now.

Problem 1:


[root@localhost linux-2.6.10]# cp /usr/src/linux/.config .config
cp: cannot stat `/usr/src/linux/.config': No such file or directory

EDIT: I fixed this error. Went through mandrakes install rpm program and installed the source code for the current kernel which also gave me the linked linux folder in /src. I'm still getting the error below

So then I think, well i'll just try and do it all manually and see how much trouble it I go on to next command which also gives me an error


[root@localhost linux-2.6.10]# make xconfig
* Unable to find the QT installation. Please make sure that the
* QT development package is correctly installed and the QTDIR
* environment variable is set to the correct location.
make[1]: *** [scripts/kconfig/.tmp_qtcheck] Error 1
make: *** [xconfig] Error 2
[root@localhost linux-2.6.10]#

This doesn't work either


[root@localhost linux-2.6.10]# make gconfig
* Unable to find the GTK+ installation. Please make sure that
* the GTK+ 2.0 development package is correctly installed...
* You need gtk+-2.0, glib-2.0 and libglade-2.0.
make[1]: *** [scripts/kconfig/.tmp_gtkcheck] Error 1
make: *** [gconfig] Error 2
[root@localhost linux-2.6.10]#

"Make config" does however work but I didn't mess with it cause I didn't know what I was getting into.

barryman_5000 01-18-2005 08:27 PM

try make menuconfig -- its a better interface. :-D

All times are GMT -5. The time now is 01:41 PM.