LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 07-19-2006, 10:27 PM   #1
stormrider_may
Member
 
Registered: Sep 2005
Distribution: Debian
Posts: 304

Rep: Reputation: 30
Problems with mount


Hello,

I'm having a strange situation, when my cdrom is not mounted, i get those permissions:

drwxr-xr-x 2 root cdrom 48 2006-06-06 11:50 cdrom1

Then when i try the cdrom, permissions change to this...

drwx------ 5 400 401 4096 2003-10-05 16:41 cdrom1

What can i do to fix this????


Here is fstab

# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
/dev/hda2 / reiserfs notail 0 1
/dev/hda1 /home/fernando/hd reiserfs defaults 0 2
/dev/hdc /media/cdrom0 iso9660 users,ro,noauto,noexec 0 0
/dev/hdd /media/cdrom1 iso9660 defaults,ro,user,noexec,noauto 0 0


thanks
 
Old 07-20-2006, 02:24 AM   #2
JZL240I-U
Senior Member
 
Registered: Apr 2003
Location: Germany
Distribution: openSuSE Tumbleweed-KDE, Mint 21, MX-21, Manjaro
Posts: 4,634

Rep: Reputation: Disabled
Try this:
Code:
dev/hdd /media/cdrom1 iso9660 users,ro,user,exec,noauto 0 0
and post the results...
 
Old 07-20-2006, 06:17 AM   #3
stormrider_may
Member
 
Registered: Sep 2005
Distribution: Debian
Posts: 304

Original Poster
Rep: Reputation: 30
Quote:
Originally Posted by JZL240I-U
Try this:
Code:
dev/hdd /media/cdrom1 iso9660 users,ro,user,exec,noauto 0 0
and post the results...
Same thing, the permissions/owner when i mount changes to:

Code:
drwx------ 5  400   401 4096 2003-10-05 16:41 cdrom1

Thanks for you answer.
 
Old 07-20-2006, 07:23 AM   #4
JZL240I-U
Senior Member
 
Registered: Apr 2003
Location: Germany
Distribution: openSuSE Tumbleweed-KDE, Mint 21, MX-21, Manjaro
Posts: 4,634

Rep: Reputation: Disabled
How do you mount (exact command)? What output do you show us when you post the permissions, "ls -l"? Did you umount before you tried my suggestion?
 
Old 07-20-2006, 07:30 AM   #5
stormrider_may
Member
 
Registered: Sep 2005
Distribution: Debian
Posts: 304

Original Poster
Rep: Reputation: 30
I'm pasting what i am exactly doing...

Code:
debian-fernando:/media# ls -l
total 0
lrwxrwxrwx 1 root cdrom  6 2006-06-06 11:50 cdrom -> cdrom0
drwxrwxrwx 2 root cdrom 48 2006-06-06 11:50 cdrom0
drwxr-xr-x 2 root cdrom 48 2006-06-06 11:50 cdrom1
debian-fernando:/media# mount /dev/hdd
debian-fernando:/media# ls -l
total 4
lrwxrwxrwx 1 root cdrom    6 2006-06-06 11:50 cdrom -> cdrom0
drwxrwxrwx 2 root cdrom   48 2006-06-06 11:50 cdrom0
drwx------ 5  400   401 4096 2003-10-05 16:41 cdrom1
debian-fernando:/media#
 
Old 07-20-2006, 07:46 AM   #6
JZL240I-U
Senior Member
 
Registered: Apr 2003
Location: Germany
Distribution: openSuSE Tumbleweed-KDE, Mint 21, MX-21, Manjaro
Posts: 4,634

Rep: Reputation: Disabled
Oh. Assuming you made the change in/etc/fstab I suggested above, try
Code:
umount -a
mount -a
and check again...
 
Old 07-20-2006, 09:04 AM   #7
stormrider_may
Member
 
Registered: Sep 2005
Distribution: Debian
Posts: 304

Original Poster
Rep: Reputation: 30
Here it is

Code:
debian-fernando:/home/fernando# umount -a
umount: /home/fernando/hd: device is busy
umount: /dev: device is busy
umount: /: device is busy
debian-fernando:/home/fernando# mount -a
debian-fernando:/home/fernando# cd /media
debian-fernando:/media# ls -l
total 0
lrwxrwxrwx 1 root cdrom  6 2006-06-06 11:50 cdrom -> cdrom0
drwxrwxrwx 2 root cdrom 48 2006-06-06 11:50 cdrom0
drwxr-xr-x 2 root cdrom 48 2006-06-06 11:50 cdrom1
debian-fernando:/media# mount /dev/hdd
debian-fernando:/media# ls -l
total 4
lrwxrwxrwx 1 root cdrom    6 2006-06-06 11:50 cdrom -> cdrom0
drwxrwxrwx 2 root cdrom   48 2006-06-06 11:50 cdrom0
drwx------ 5  400   401 4096 2003-10-05 16:41 cdrom1
debian-fernando:/media# cat /etc/fstab
# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    defaults        0       0
/dev/hda2       /               reiserfs notail          0       1
/dev/hda1       /home/fernando/hd reiserfs defaults        0       2
/dev/hdc        /media/cdrom0   iso9660 users,ro,noauto,noexec   0       0
#/dev/hdd        /media/cdrom1   iso9660 defaults,ro,user,noexec,noauto  0       0
/dev/hdd /media/cdrom1 iso9660 users,ro,user,exec,noauto 0 0
 
Old 07-20-2006, 09:21 AM   #8
JZL240I-U
Senior Member
 
Registered: Apr 2003
Location: Germany
Distribution: openSuSE Tumbleweed-KDE, Mint 21, MX-21, Manjaro
Posts: 4,634

Rep: Reputation: Disabled
Why do you want to mount something which is already mounted, namely /dev/hdd? Well, if this is what you want, try
Code:
mount -o,remount /dev/hdd
{man mount on the syntax for the -o and remount flags,
I'm not sure whether I remember that correctly... }
 
Old 07-20-2006, 09:29 AM   #9
stormrider_may
Member
 
Registered: Sep 2005
Distribution: Debian
Posts: 304

Original Poster
Rep: Reputation: 30
i'm not trying to mount something that is already mounted, take a look:

Code:
debian-fernando:/media# umount -a
umount: /home/fernando/hd: device is busy
umount: /dev: device is busy
umount: /: device is busy
debian-fernando:/media# mount -a
debian-fernando:/media# df
Sist. Arq.           1K-blocos      Usad Dispon.   Uso% Montado em
/dev/hda2             28835784  16538128  12297656  58% /
udev                     10240        76     10164   1% /dev
/dev/hda1             51197536  16625504  34572032  33% /home/fernando/hd
debian-fernando:/media# ls -l
total 0
lrwxrwxrwx 1 root cdrom  6 2006-06-06 11:50 cdrom -> cdrom0
drwxrwxrwx 2 root cdrom 48 2006-06-06 11:50 cdrom0
drwxr-xr-x 2 root cdrom 48 2006-06-06 11:50 cdrom1
debian-fernando:/media# mount /dev/hdd
debian-fernando:/media# df
Sist. Arq.           1K-blocos      Usad Dispon.   Uso% Montado em
/dev/hda2             28835784  16538128  12297656  58% /
udev                     10240        76     10164   1% /dev
/dev/hda1             51197536  16625504  34572032  33% /home/fernando/hd
/dev/hdd                639328    639328         0 100% /media/cdrom1
debian-fernando:/media# ls -l
total 4
lrwxrwxrwx 1 root cdrom    6 2006-06-06 11:50 cdrom -> cdrom0
drwxrwxrwx 2 root cdrom   48 2006-06-06 11:50 cdrom0
drwx------ 5  400   401 4096 2003-10-05 16:41 cdrom1
 
Old 07-20-2006, 09:34 AM   #10
JZL240I-U
Senior Member
 
Registered: Apr 2003
Location: Germany
Distribution: openSuSE Tumbleweed-KDE, Mint 21, MX-21, Manjaro
Posts: 4,634

Rep: Reputation: Disabled
Hm, yes you're right. Now, try it with "-o,remount" it should use the parameters from your fstab...
 
Old 07-20-2006, 09:43 AM   #11
stormrider_may
Member
 
Registered: Sep 2005
Distribution: Debian
Posts: 304

Original Poster
Rep: Reputation: 30
same things...

Code:
debian-fernando:/media# mount -o,remount /dev/hdd
debian-fernando:/media# ls -l
total 4
lrwxrwxrwx 1 root cdrom    6 2006-06-06 11:50 cdrom -> cdrom0
drwxrwxrwx 2 root cdrom   48 2006-06-06 11:50 cdrom0
drwx------ 5  400   401 4096 2003-10-05 16:41 cdrom1
 
Old 07-20-2006, 10:03 AM   #12
JZL240I-U
Senior Member
 
Registered: Apr 2003
Location: Germany
Distribution: openSuSE Tumbleweed-KDE, Mint 21, MX-21, Manjaro
Posts: 4,634

Rep: Reputation: Disabled
Grrr. What happens when you issue a "chmod 755 /media/cdrom"?

Last edited by JZL240I-U; 07-20-2006 at 10:15 AM.
 
Old 07-20-2006, 11:05 AM   #13
stormrider_may
Member
 
Registered: Sep 2005
Distribution: Debian
Posts: 304

Original Poster
Rep: Reputation: 30
Quote:
Originally Posted by JZL240I-U
Grrr. What happens when you issue a "chmod 755 /media/cdrom"?
I can't do this, because cdrom is mounted as a write-protected fs
 
Old 07-20-2006, 03:44 PM   #14
stormrider_may
Member
 
Registered: Sep 2005
Distribution: Debian
Posts: 304

Original Poster
Rep: Reputation: 30
where can i set which user cdrom will be mounted as?
 
Old 07-21-2006, 02:05 AM   #15
JZL240I-U
Senior Member
 
Registered: Apr 2003
Location: Germany
Distribution: openSuSE Tumbleweed-KDE, Mint 21, MX-21, Manjaro
Posts: 4,634

Rep: Reputation: Disabled
Quote:
Originally Posted by stormrider_may
I can't do this, because cdrom is mounted as a write-protected fs
Huh? What's that got to do with another?
Quote:
Originally Posted by stormrider_may
debian-fernando:/media# ls -l
...
drwxr-xr-x 2 root cdrom 48 2006-06-06 11:50 cdrom1
What is the error message, when you issue chmod?

Quote:
Originally Posted by stormrider_may
where can i set which user cdrom will be mounted as?
In /etc/fstab. But you allow groups to mount (in my earlier post it was the group "users"), so if you want one single user to be able to mount, you create a group like "cdmounter" or some such and add the special user to this group. root is allowed to mount, too.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
problems with smbfs mount-point in /etc/fstab - "mount -a" works, but not at boottime MarkSide Linux - Software 4 11-20-2005 03:30 PM
problems with mount binarybob0001 Linux - Newbie 5 12-05-2004 05:41 AM
mount problems zchoyt Linux - Networking 5 10-27-2004 12:30 AM
mount problems alaios Linux - Hardware 1 04-24-2003 11:15 AM
Mount Problems wyvis Linux - General 2 12-31-2001 10:06 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 08:35 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration