-   Linux - Hardware (
-   -   Problems with hardware in Redhat FC5 (

Alias_NeO 09-06-2006 10:29 AM

Problems with hardware in Redhat FC5
Hi there,
I have come here because I am fairly new to linux. I have ran FC4 on an older machine and had no problems ... however.

I have recently upgraded my machine ... significantly and tried to install RedHat FC5 and have ran into a host of problems.

First of all, my hardware configuration is as follows:

AMD X2 4600+ AM2
M2N32 Sli Deluxe (Wi-fi edition)
Nvidia Geforce 7600GT
2 x 1GB Corsair XMS DDR2 (TwinX)
2 x 250GB 16mb 7200 SATAII HDD
200GB 8mb 7200 IDE HDD (Win MCE 2005)
2 x GDI Blackgold DVB-T TV tuner cards.

First problem I ran into was that the OS would not install, it hung before reaching anaconda.

I found that hte problem was ACPI and had to disable it, OS installed and runs but no ACPI.

Once up and running i now have several problems.

USB host controller does not seem to be present.
I can not connect to the internet because hte built in wi-fi card runs through the usb controller.

My GDI Blackgold cards do not work. Although dmesg says to insmod them to card=2 (2 being my brand of card from a long list it gives) - although i don't know how to do this.

I can not connect any USB devices at all, usb storage, pen drives etc, they do not show up in the dev list at all, because no usb.

I would be grateful if someone could just help with the main problem of getting my USB set up.

when I lspci -v i get about 4 unknown devices on the PCi bridge and a further unknown device on the VGA compatible controller.

If I lsmod, the modules seem to be fine and there are some relevent ones loaded.

I can get my internet to work if I connect to the Gbit LAN, would i be able to somehow "autoupdate" from there if i tracked a network cable to this computer from my router until i get wireless?

If there is any more info you need please let me know.

P.S. kernel version is : 2.6.15-1.2054_FC5.


Alias_NeO 09-06-2006 11:45 AM

Follow up
Just as a follow up:

I went into my BIOS and disabled all the groovy power features:

Disabled AMD Cool & Quiet

Disabled AMD Live!

Disabled Nvidia Graphics eX

Enabled Midi device

Enabled Parallel Port

Now when I boot i have USB and my pen drive works, still no wificard though.

I am currently hard-wired with a 30m cable to my router :S tracing cat 5 around the house.

It's downloading every available update via "yum update" - 1.1GB worth of updates. Ill see how that affects the system. THen i'll try find a driveer for my wifi card. Apparently it runs on the RTL8187 chipset.

I shall see what happens and report back. If any one can help in any way, it would be very much appreciated.

Thank you.

All times are GMT -5. The time now is 03:30 PM.