-   Linux - Hardware (
-   -   problems with brother mfc-5440cn and canon 250i printers (

zoran119 04-26-2009 11:09 PM

problems with brother mfc-5440cn and canon 250i printers
hi everyone,

does any one have either of these printers working under linux? the brother is on a newtork and the canon is connected via usb.

the machine is running arch linux. cups finds the printers but does not have the drivers for the exact models. i have tried the 'similar' model drivers (i80 instead of i250, raw and similar options, can't find a ppd file on the net) to no avail.

canon's light just does a little flash with the power light when a document is sent to it and that's all, no paper comes out.

brother says 'recieving data' for a few seconds and that's all. no paper comes out either.

any pointers?

sadiqdm 04-27-2009 07:33 PM

Driver for the Canon i250:

Drivers for the Brother MFC-5440cn:

You will find instructions on those sites.

FredGSanford 04-28-2009 10:04 AM

Im trying to install the Brother drivers for the same model AIO setup using the USB port and when I run the install commands, I get this error while installing:


rpm -ihv --nodeps MFC5440*
error: failed to stat /media/hd7: Input/output error
But if I run it again, it show the drivers installed.


package MFC5440CNlpr-1.0.2-1.i386 is already installed
Then there is a grep command to run to check if the drivers are installed but it comes up empty.


rpm -qa | grep -e (lpr-drivername) -e (cupswrapper-drivername)
I do put the correct filenames in place.

Any ideas on what is happening?


FredGSanford 04-30-2009 08:45 AM

Mine is working, the cupsd was not starting by default.

All times are GMT -5. The time now is 08:44 PM.