-   Linux - Hardware (
-   -   problems with a VIA VT82x USB2.0 card on old Intel 440BX mobo (

mr_git 10-22-2006 01:10 PM

problems with a VIA VT82x USB2.0 card on old Intel 440BX mobo
I have a hard disk in a USB2.0 caddy plugged into my old Pii machine which I use as a server (running Ubuntu Dapper Drake with the 2.6.15-27-386 kernel).

The motherboard is pretty old (it's a 440BX-based Lucky Star 6ABX2V), so it only has USB1.1 onboard. As you can imagine, this makes for very, very slow transfers of large files to and from the external disk.

Today I've been trying to get a USB2.0 PCI card (which has a VIA chipset) working in this machine, to speed things up. The card isn't exactly new either; I think I've had it lying around for a couple of years.

I've not had much success. It's frustrating, because the card seems to be recognised, but nothing happens when I plug something into it.

The output from lspci includes this (with the card plugged into PCI slot 1):


0000:00:07.2 USB Controller: Intel Corporation 82371AB/EB/MB PIIX4 USB (rev 01)
0000:00:07.3 Bridge: Intel Corporation 82371AB/EB/MB PIIX4 ACPI (rev 02)
0000:00:08.0 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 50)
0000:00:08.1 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 50)
0000:00:08.2 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 51)

(I've included the details of the mobo's own USB1.1 controller too)

And I can see the USB2.0 card in KDE's KInfoCenter, and usbview etc...

However, as I say nothing happens when I plug USB devices (I've tried more than one) into it, although the card does seem to be supplying power.

I suppose this is not strictly a linux problem, as I've just tried booting into Windoze 2000, and I have pretty much the same problem; the card seems to be recognised okay, but nothing happens when you plug something into it.

So, my questions are these:

1) is there anything else I can try to get this card working in this machine?


2) is there any point in me buying a different card (for example with an NEC or ALi chipset, or even a newer VIA chipset) in an attempt to get USB2.0 support on this machine?

I'd really appreciate any advice or opinions; the external drive connected to this machine is a really useful setup, but the USB1.1 speed is major handicap.

Many thanks,

Brian1 10-22-2006 02:02 PM

Check to see if the USB 2.0 module is loaded. It is called ehci-hcd and can be check by checking the loaded modules with the command ' lsmod '. Now I believe it is loaded since you say usbview can see it.
Now when you plugin the USB drive does dmesg show anything new?
Post output of the following commands after drive is plugged in.
cat /proc/scsi/scsi
fdisk -l


mr_git 10-23-2006 03:25 AM

Thanks Brian,

I'll try those things when I'm in front of the machine later on; I'm pretty certain I've already tried fs though, and didn't see any sign of the usb drives I've plugged in.

...and yes, I'm pretty sure I've seen ehci in usbview and other GUIs.

I'll try all the stuff you've mentioned though, and post back here.


Brian1 10-23-2006 02:59 PM

If you can, boot up the machine with a Live CD of Knoppix and then plugin the drive and see if it sees it. If it does I would compare kernel versions and also note what lspci says it is seeing in both. Same for USBview or lsusb. I only had trouble with a MP3 sdcard device in the 2.6.9 kernel. Worked before and after but never worked in 2.6.9.


mr_git 11-07-2006 07:36 AM

Hi Brian - thanks for all your help (and sorry I took a while to post back here - I've just got back from a sorely-needed computer-free week of holiday!)

I didn't have any luck with the USB2 card in that machine; I tried it with a couple of knoppix-based live CDs, and in Windoze etc... and still the same story - the card was recognised, but the OS didn't seem to notice when you actually plugged things in.

So, I borrowed another old machine (which is Intel 810-based) and tried the card out (again with Ubuntu Dapper) and it works fine (I'm not sure I'm giving this machine back!)

It looks like the creaky old 440BX board just doesn't want to place nicely with the card. Oh well...

Thanks again for your efforts anyway Brian.


All times are GMT -5. The time now is 07:44 AM.