LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
LinkBack Search this Thread
Old 09-16-2007, 02:47 AM   #1
motomon
LQ Newbie
 
Registered: Jan 2005
Location: Monterrey, Mexico
Distribution: OpenSuse , Ubuntu, Mandriva
Posts: 14

Rep: Reputation: 0
Problems with a GigaWare USB headset - Still sound from the PC


I have read a lot about this issue and, although I have tired many things, I just cannot get it right. I have a RadioShack GigaWare USB Headset. When I do lsusb I get:

Bus 004 Device 001: ID 0000:0000
Bus 003 Device 002: ID 0d8c:000c C-Media Electronics, Inc. Audio Adapter
Bus 003 Device 001: ID 0000:0000
Bus 002 Device 001: ID 0000:0000
Bus 001 Device 001: ID 0000:0000

So it is a C-Media Electronics. According to http://www.qbik.ch/usb/devices/showdev.php?id=3973 this headset should work right away and it sort of does. It is recognized by the system and when I do aplay -l:

**** List of PLAYBACK Hardware Devices ****
card 0: ICH5 [Intel ICH5], device 0: Intel ICH [Intel ICH5]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: ICH5 [Intel ICH5], device 4: Intel ICH - IEC958 [Intel ICH5 - IEC958]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: default [C-Media USB Headphone Set ], device 0: USB Audio [USB Audio]
Subdevices: 1/1
Subdevice #0: subdevice #0

seems that everything is just fine, I even, in the Kmix have the C-Media USB Headphone Set available. I even get sound out of the headphones when doing cat /bin/bash > /dev/dsp1

However, whenever I play a song nothing comes out of the headphones but from the built-in speaker (BTW, the soundcard is an Intel one). If I just put on the headset and start talking to the mic, my voice does get out through the headphones, but not the song. Also, when I look at the sound card in the yast control I see only one card the Intel one and it is there as though it were not configured. The USB card does not show up. I can even do alsamixergui -c 1 (the USB card is recognized as card 1)

Please, I know that a lot of these questions have been around but I read all of them and tried many things but the sound of any song is still coming out of the built-in speaker. How can I make it go through the headphones? BTW, my distro is OpenSuse 10.2 and the player I use is Kaffeine.

Thank you for any hints you may provide.
 
Old 09-17-2007, 12:15 AM   #2
motomon
LQ Newbie
 
Registered: Jan 2005
Location: Monterrey, Mexico
Distribution: OpenSuse , Ubuntu, Mandriva
Posts: 14

Original Poster
Rep: Reputation: 0
OK, it sort of works...

After some turning on and off or the desktop and moving kmix I got this headset to work. However, it seems that only some applications make use of the headset. When I play a song using Amarok the sound does come out through the headphones. However, when I play the same song using VLC or Kaffeine, the sound goes through the built-in speaker. Any ideas how I could get it working in all available players? Thank you.
 
Old 06-09-2008, 09:01 AM   #3
penkwin
LQ Newbie
 
Registered: Jan 2004
Location: New England
Distribution: Slackware!
Posts: 9

Rep: Reputation: 0
I tried linking /dev/dsp to /dev/sound/dsp1, the usb device and it works for mplayer. I didn't try any others. That seems to be the source of the problem, even though the usb headphones load and are active, apps access the original device /dev/dsp.

I've seen a lot of postings around asking this question, but no answers that work or explain how to do a real fix for this that includes what actually is going wrong.
 
Old 06-02-2009, 01:41 PM   #4
TonyFordz
LQ Newbie
 
Registered: Jun 2009
Posts: 3

Rep: Reputation: 0
Question Works in testing but not other things

I have this same headset as you can see below

http://rsk.imageg.net/graphics/produ...227619w345.jpg

I do not understand all that code you two displayed so can someone tell me in simple terms what I need to do to get it working on my Ubuntu 6.04 32-Bit/64-Bit Linux? I put both bits because I use on both.

Thank you,
Tony
 
Old 06-04-2009, 07:04 AM   #5
TonyFordz
LQ Newbie
 
Registered: Jun 2009
Posts: 3

Rep: Reputation: 0
Can someone help with this?

Is there anyone that can help me get this working?

http://rsk.imageg.net/graphics/produ...227619w345.jpg
 
Old 07-01-2009, 07:19 PM   #6
austinpsycho
LQ Newbie
 
Registered: Jul 2009
Posts: 3

Rep: Reputation: 0
I couldn't find any info on this problem either, but i figured it out :)

A combination of removing pulse audio and upgrading to the latest stable release of alsa (1.0.20) did the trick. My headset works as its supposed to. It took a little effort:
I downloading the binaries from alsa project dot org (yeah its not letting me post the link because I haven't posted before)
I downloaded the utils, tools, driver and lib. Then installed them thusly:
install the following things from synaptic package manager:
gettext
libncurses5-dev
build-essential

Then unpack the binaries by dragging them to your desktop. then enter terminal and navigate to those created directories one at a time. cd ~/Desktop/alsa-driver-1.0.20/should get ya to the first one. For each directory type in ./config then wait. then make then wait then sudo make install then your password then wait. Then on to the next directory. Make sure nothing fails. Restart and violla; headphones work
 
Old 07-04-2009, 11:16 AM   #7
austinpsycho
LQ Newbie
 
Registered: Jul 2009
Posts: 3

Rep: Reputation: 0
Ok; skip all that; did a reinstall; and refined it to something much easier.. remove pulseaudio package; then if you got the same setup as I do all you'll have to do is type:
Code:
asoundconf set-default-card default
if that doesn't work then type
Code:
asoundconf list
find your usb headset in there, and replace the second default in the code above with the name of your headset
My output looked like this:
Code:
desktop:~$ asoundconf list
Names of available sound cards:
SB
default
so i figured my usb driver must be "default". I felt kinda silly setting default card to default.. but it worked
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
USB headset monkiidansu Linux - Hardware 0 06-06-2007 07:36 PM
USB headset not working. Delta_Dude12 Linux - Hardware 0 08-20-2006 09:16 PM
crude work-around for sound/mic via usb logitech 350 headset marvinudy Linux - Hardware 1 06-05-2006 10:00 PM
USB Headset Sound owdeuk Linux - Hardware 0 04-20-2005 05:24 PM
Logitech USB Headset 30 (or another USB headset) dezza Linux - Hardware 0 11-29-2004 12:21 PM


All times are GMT -5. The time now is 01:17 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration