LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 12-31-2004, 10:22 AM   #1
TISIMU
LQ Newbie
 
Registered: Dec 2004
Distribution: Suse 9.2
Posts: 5

Rep: Reputation: 0
problems sound suse 9.2


Hello!
I have a problem with my soundcard.
I have configured it, but if I play the testsound, i can't hear a sound. If I want listen to a MP3 there is no sound, and in games there is no sound, too. Only if I take a CD I can hear the music, there are no problems.

I use Suse 9.2 and have an onboard SiS SI7012 soundcard.

I have already tried some things like for example "alsaconf" but I'm a newbie to Linux and don't know what to do now. Please give me a detailled description what to do, because how I said I do not know very much about Linux.

"yast2 sound summary" gives this information:
* Sound Controller
* Configured as snd-card-0.

device manager says:
Status:
Available: YES
Configured: YES

Driver:
Driver Info #0:
Driver Status: i810_audio is not active
Driver Activation Cmd: "modprobe i810_audio"
Driver Info #1:
Driver Status: snd-intel8x0 is active
Driver Activation Cmd: "modprobe snd-intel8x0"

lspci gives me about my soundcard this information:
0000:00:02.7 Multimedia audio controller: Silicon Integrated Systems [SiS] Sound Controller (rev a0)

If you need some more information please tell me and I will try to give you the information.

Thanks for your help!

Tina
 
Old 12-31-2004, 11:24 AM   #2
Caeda
Senior Member
 
Registered: Jul 2003
Location: Indiana
Distribution: Suse 6.0+, Mandrake 5.0-10.0, Redhat 6.0-9.0, Gentoo 1.2+, Gnoppix, Knoppix, Sabayon, Ubuntu 5.04+
Posts: 1,811

Rep: Reputation: 45
What volumes do you have your mixer set to, and do you have all the channels on the mixer unmuted...

Try "alsamixer" or there should be a speaker in your taskbar in the corner...
And stop messing around with command line "alsaconf" sort of tools to configure suse, it has Yast for a reason.
 
Old 12-31-2004, 11:45 AM   #3
TISIMU
LQ Newbie
 
Registered: Dec 2004
Distribution: Suse 9.2
Posts: 5

Original Poster
Rep: Reputation: 0
I have set all to high volumes and there is nothing unmuted.
 
Old 12-31-2004, 07:39 PM   #4
macewan
Senior Member
 
Registered: Jan 2002
Distribution: Ubuntu, Debian
Posts: 1,055
Blog Entries: 1

Rep: Reputation: 45
http://www.sabi.co.uk/Notes/linuxSoundALSA.html

may or may not assist while you search for an answer
 
Old 12-31-2004, 10:22 PM   #5
Caeda
Senior Member
 
Registered: Jul 2003
Location: Indiana
Distribution: Suse 6.0+, Mandrake 5.0-10.0, Redhat 6.0-9.0, Gentoo 1.2+, Gnoppix, Knoppix, Sabayon, Ubuntu 5.04+
Posts: 1,811

Rep: Reputation: 45
and there is nothing unmuted.

so its`all muted!!!
 
Old 01-01-2005, 03:25 AM   #6
TISIMU
LQ Newbie
 
Registered: Dec 2004
Distribution: Suse 9.2
Posts: 5

Original Poster
Rep: Reputation: 0
Sorry, I mean all is unmuted.
 
Old 01-01-2005, 05:26 AM   #7
TISIMU
LQ Newbie
 
Registered: Dec 2004
Distribution: Suse 9.2
Posts: 5

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by macewan
http://www.sabi.co.uk/Notes/linuxSoundALSA.html

may or may not assist while you search for an answer
I couldn't solve the problem with this page.....
 
Old 01-02-2005, 11:16 AM   #8
TISIMU
LQ Newbie
 
Registered: Dec 2004
Distribution: Suse 9.2
Posts: 5

Original Poster
Rep: Reputation: 0
I have solved the problem.
I replaced in /etc/modprobe.d/sound all occurrences of snd_intel8x0 by i810_audio.
 
Old 06-09-2005, 08:03 AM   #9
izquierdista
Member
 
Registered: Mar 2005
Distribution: Ubuntu
Posts: 342

Rep: Reputation: 30
Hello I have SUSE linux 9.1 and I am having a similar problem with the same sound card that you have. can you tell me exactly what you did to enable what you said using the command: /etc/modprobe.d/sound all occurrences of snd_intel8x0 by i810_audio

I tried the following but I cant find the command that you used:

tlaloc@rn103188:/etc/modprobe.d> cd /etc/modprobe.d/
tlaloc@rn103188:/etc/modprobe.d> sound all occurrences of snd_intel8x0 by i810_audio
bash: sound: command not found
tlaloc@rn103188:/etc/modprobe.d>
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[Suse 9.3] Sound problems dubbeld00 SUSE / openSUSE 18 11-25-2005 02:09 PM
Sound problems Suse 10.0 micder SUSE / openSUSE 1 10-31-2005 09:39 AM
SUSE 9.1 Sound Problems denlow Linux - Hardware 1 02-19-2005 03:12 AM
Suse Sound Problems turtle_lover Linux - Hardware 1 09-15-2004 12:22 AM
Sound problems in Suse 9.1 rohde Linux - Software 2 09-10-2004 04:34 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 02:14 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration