LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 10-07-2002, 09:37 PM   #1
yvovandoorn
LQ Newbie
 
Registered: Oct 2002
Location: Renton, WA
Distribution: Debian 4, Ubuntu 8.04, RHEL 5, RHEL 4, CentOS 5
Posts: 11

Rep: Reputation: 0
Problems installing Red Hat 8.0


Hey all,

I am a n00b when it comes to linux but I really want to start getting into it.

So I figure I start out with a well known package, Red Hat. Being that they just came out with a new version I downloaded the first 3 discs... the last 2 only had SRPMs on em.

Well of course I have some issues with the installation and would love to fix them to get the "full linux experience"

Here they are!

Issue #1.
During installation my monitor Sylvania F97 isn't correctly detected and I am unable to go above 1024x768 @ 60Hz resolution. I am unable to change the refresh rate once installation is over with and for some reason if I try selecting the nv driver (instead of VESA) for my Geforce 4 Ti4200 I basically screw up my install.

Issue #2
My sound card (Soundblaster Audigy) is detected correctly during setup and setup installs drivers for the card but I am unable to hear any sound even when I select "Test sound." Since I am a tad bit of an audiophile (not an obsessive one) I would like to have some sort of sound

Issue #3.
My mouse (Intellimouse 3.0) works great, even the wheel unless I load up Hardware browser or any intensive app. This is when the mouse completely locks up and I need a hard reboot to fix this problem. This issue has been with me since Redhat 7.0 but if it froze back then the mouse remained frozen after I restarted and the only way I could possibly fix it back then was to reinstall.

System specs:
AMD Athlon XP 2000+
Epox 8K3A+ motherboard
Micron 512MB PC2100 DDR RAM
60GB Seagate 7200 RPM (20GB partition for linux)
AOpen Geforce4 Ti4200
Soundblaster Audigy
Intellimouse 3.0


Any help would be appreciated!
 
Old 10-07-2002, 10:53 PM   #2
DavidPhillips
LQ Guru
 
Registered: Jun 2001
Location: South Alabama
Distribution: Fedora / RedHat / SuSE
Posts: 7,163

Rep: Reputation: 58
For the video try Xconfigurator or xf86config.

For the audio try aumix and see if the volume is turned up.



Not sure about the mouse.

Have you tried gpm?

gpm -R -m /dev/mouse -t imps2


then use this in XF86Config-4

Option "Protocol" "MouseSystems"
Option "Device" "/dev/gpmdata"
 
Old 10-07-2002, 11:11 PM   #3
DavidPhillips
LQ Guru
 
Registered: Jun 2001
Location: South Alabama
Distribution: Fedora / RedHat / SuSE
Posts: 7,163

Rep: Reputation: 58
if your mouse is ps/2 then /dev/mouse should link to /dev/psaux if it's usb then it should link to /dev/input/mice

or use the actual device name so you know what it is.

good idea if you have more than one mouse like my slack system. like most laptops you will want to use more than one mouse.

david@ZipSlack:~# cat /etc/rc.d/rc.gpm
#!/bin/sh
# Start/stop the GPM mouse server:

if [ "$1" = "stop" ]; then
echo "Stopping gpm..."
gpm -k
else # assume $1 = start:
echo "Starting gpm..."
gpm -R -S "" -m /dev/ps2 -t ps2 -M -m /dev/input/mice -t imps2
fi


XF86Config-4 with 2 mice

Section "ServerLayout"
InputDevice "Mouse2" "AlwaysCore"
InputDevice "Mouse1" "CorePointer"
 
Old 10-08-2002, 09:08 AM   #4
bxb32001
Member
 
Registered: May 2001
Location: Beijing
Distribution: Fedora, Knoppix
Posts: 204

Rep: Reputation: 30
I'm no expert, but I hope this helps... assuming you don't boot graphically [or you can logout of X] and have the regular terminal screen in front of you... log in as root and type 'setup'

you should be able to configure your video, mouse, sound, etc. from there. Then quit, log out, log on to your regular account, type 'startx' to get back to the gui.

hope this helps...
 
Old 10-08-2002, 05:29 PM   #5
yvovandoorn
LQ Newbie
 
Registered: Oct 2002
Location: Renton, WA
Distribution: Debian 4, Ubuntu 8.04, RHEL 5, RHEL 4, CentOS 5
Posts: 11

Original Poster
Rep: Reputation: 0
How can I exit RedHat 8.0's GUI?

Also the volume is turned up.... ONLY for MIC
edit: I had a closer look and the there is only the option for the MIC... the rest is not being detected
I tried to install the audigy drivers from sourceforge.net but no luck... the make install quit on an error.

Last edited by yvovandoorn; 10-08-2002 at 07:58 PM.
 
Old 10-08-2002, 07:30 PM   #6
bxb32001
Member
 
Registered: May 2001
Location: Beijing
Distribution: Fedora, Knoppix
Posts: 204

Rep: Reputation: 30
If you pop up the panel, er, the start menu equivalent, there's a logout button/icon right there. Don't choose shutdown or reboot in the succeeding dialog box... choose logout.

That sould bring you to the terminal.... type logout, then login as root, type setup, then try your configuring from there...
 
Old 10-08-2002, 08:40 PM   #7
yvovandoorn
LQ Newbie
 
Registered: Oct 2002
Location: Renton, WA
Distribution: Debian 4, Ubuntu 8.04, RHEL 5, RHEL 4, CentOS 5
Posts: 11

Original Poster
Rep: Reputation: 0
nope it doesn't instead it brings me back to the graphical login screen... i tried to set it to standard and I get the same issues.... I feel a reinstall coming. (as you have the selection to set it to text & graphical)

Also would like to add that the only volume control that is present is the mic.

Is there just a way that I can edit some X config file that I can force my refresh rate?
 
Old 10-08-2002, 09:31 PM   #8
bxb32001
Member
 
Registered: May 2001
Location: Beijing
Distribution: Fedora, Knoppix
Posts: 204

Rep: Reputation: 30
newbie to newbie... this is getting interesting. If anyone is willing to correct me (or of course help us out), please do so.

That is probably a good idea, - a fresh reinstall... Then set login to text. No hassles really, just login and type startx.

But before you do so, try doing a control-alt-backspace. I think that's the way to kill the gui (in linux terms - X).

About the editing your xf86config file while in gui... If you can't do it from the normal config tools (probably under system settings of your menus). Then I don't think you can until you kill X.

One more thing, LQ has a nice "search" feature found at the bottom of each forum > category page. Go to "Linux Software", Linux "Newbie" or "Linux General" then at the bottom right of each table you will find a search tool. There you can type "killing x" or "stopping x" or "xf86config" or"configuring video/sound"... This may enlighten you on the particular tasks that you may have to do to correct your settings.

Last edited by bxb32001; 10-08-2002 at 09:33 PM.
 
Old 10-09-2002, 07:05 AM   #9
annehoog
Member
 
Registered: Jan 2002
Location: Nederland
Distribution: RH 8 Psyche and Debian Woody
Posts: 373

Rep: Reputation: 32
Sounds like you're booting in to run level 5 which means you automatically go to X that means that ctrl-alt-backspace takes you right back to X Try changing the run level to 3 in /etc/inittab (id:N:initdefault: ) that should get you in to text mode from where you run startx to get back to X.

Anne
 
Old 10-09-2002, 07:55 AM   #10
bxb32001
Member
 
Registered: May 2001
Location: Beijing
Distribution: Fedora, Knoppix
Posts: 204

Rep: Reputation: 30
Uhmmmm, translation Anne?
 
Old 10-09-2002, 08:21 AM   #11
annehoog
Member
 
Registered: Jan 2002
Location: Nederland
Distribution: RH 8 Psyche and Debian Woody
Posts: 373

Rep: Reputation: 32
Sorry:

In the file inittab which can be found in the directory /etc use a file manager like nautilus (comes with Gnome) or mc (simply type mc on the command line and it'll pop up and it is quite straightforward and simple to use and let's you edit files quite simply) you'll find a line id:N:initdefault: whith probably a 5 behind it. That means that every time you boot up the system goes in to runlevel 5 which boots up X (the graphical environment). If you want to boot in to text mode you'll need to change that 5 in to a 3. (mind you that you prob have to be root to edit it. so before typing mc and looking up the file typ "su" and then your root password) If you've done that crtl-alt-backspace or a reboot will take you in text mode from where you can do "startx" to boot X.

Hope that's clear enough!

Anne
 
Old 10-09-2002, 09:36 AM   #12
bxb32001
Member
 
Registered: May 2001
Location: Beijing
Distribution: Fedora, Knoppix
Posts: 204

Rep: Reputation: 30
That is [CRYSTAL]- much appreciated Anne... that was extremely good to know. You getting this yvovandoorn?

I'm printing out this page... Anne's an angel...
 
Old 10-09-2002, 09:42 AM   #13
bxb32001
Member
 
Registered: May 2001
Location: Beijing
Distribution: Fedora, Knoppix
Posts: 204

Rep: Reputation: 30
As long as your with us Anne, I've searched LQ on how to get the windows key working like it does in winwoes. But like yvovandoorn... the solutions I found seem to befuddle me even more. Can you enlighten us in this area as well? Pleeeeeeeaase?
 
Old 10-09-2002, 09:48 AM   #14
annehoog
Member
 
Registered: Jan 2002
Location: Nederland
Distribution: RH 8 Psyche and Debian Woody
Posts: 373

Rep: Reputation: 32
I'm so flattered by your apreasal of me and so sorry at the same time for I don't have an answer to your last question.

Best thing I can say on this is to try googling for it.

Anne
 
Old 10-09-2002, 04:51 PM   #15
yvovandoorn
LQ Newbie
 
Registered: Oct 2002
Location: Renton, WA
Distribution: Debian 4, Ubuntu 8.04, RHEL 5, RHEL 4, CentOS 5
Posts: 11

Original Poster
Rep: Reputation: 0
ohh i am surely getting this ;-)

I got it and then i am out in text now and I seemed to have messed up my xf86config file... i get to have fun fixing that now lol.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems Installing Red Hat 9.0 rockymtns99 Linux - Newbie 8 08-12-2004 12:32 PM
Problems with qt while installing k3b on Red Hat 9 katiABV Linux - Software 1 07-29-2004 07:19 AM
problems installing red hat 6.2 nirkristal Red Hat 1 01-31-2004 12:25 PM
Problems installing Samba 2.2.8 on Red Hat 8.0...help! tarballed Linux - Software 1 05-13-2003 02:43 PM
problems installing Nvidia drivers on Red hat 8.0 Kilahchris Linux - Hardware 1 01-26-2003 09:09 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 12:26 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration