-   Linux - Hardware (
-   -   problems installin ubuntu 7.04 on hardware raid (

nieradka 07-11-2007 10:52 AM

problems installin ubuntu 7.04 on hardware raid
First off, im a complete newbie, this is my first attempted linux install, so please excuse my ignorance.

The problem i am having is i cant create a partition to install to on any of my raid arrays. When the installer (ubuntu 7.04) gets to the "prepare disk space" screen i choose guided use entire disk /dev/i20/hda it goes through a few screens then generates "the creation of swap space in partition #5 of /dev/i2o/hda failed. Doing it manually in the menu doesnt work. using the text based installer generates the same error in a different wording. Using gparted when i try to set the disk label it gives an error: "error while setting disklabel" using parted from the command line:

ubuntu@ubuntu:~$ sudo bash
root@ubuntu:~# parted
Warning: Unable to open /dev/hda read-write (Read-only file system). /dev/hda
has been opened read-only.
GNU Parted 1.7.1
Using /dev/hda
Welcome to GNU Parted! Type 'help' to view a list of commands.
(parted) mklabel
New disk label type? msdos
Error: Can't write to /dev/hda, because it is opened read-only.
Ignore/Cancel? ignore
*** stack smashing detected ***: <unknown> terminated
Aborted (core dumped)
All the utilities see the correct sizes of the 3 arrays.

The controller is a promise supertrak 100 bios 1.00 build 13 (intel i960 chip). In its bios i set it to mode:Linux and deleted the previous arrays (and nuked windows) and defined new ones on two of the arrays, so they are unpartioned. (the other array is an ntfs partion which my data is backed up on.

Ive tried:
Disabling acpi in the system bios.
Turning off pnp os installed in the bios, and disabling a serial and a parallel port and the on board usb, removing the sound card. Shuffled the pci cards to diffrent slots. (this got the installer to see my network card and detect that there were arrays on the card at least)
Disabled apic live=no-apic noapic nolapic at the boot menu of the cd.

i tried searching google and the install guide while i found plenty about installing on fake raid, i didnt see much about hardware raid from the last 5 years, prolly i dont know what to search for.

Doesnt look like a irq problem

root@ubuntu:~# more /proc/interrupts
0: 544148 0 XT-PIC-XT timer
1: 6293 0 XT-PIC-XT i8042
2: 0 0 XT-PIC-XT cascade
6: 15 0 XT-PIC-XT floppy
8: 4 0 XT-PIC-XT rtc
10: 190610 0 XT-PIC-XT uhci_hcd:usb1, ohci1394, radeon@p
11: 857 0 XT-PIC-XT uhci_hcd:usb2, ehci_hcd:usb3, iop
14: 9417 0 XT-PIC-XT ide0
15: 4010 0 XT-PIC-XT eth0
NMI: 0 0
LOC: 543871 543878
ERR: 0
MIS: 0
Installing on a non raided drive off on the onboard ide works, but thats kind of not the point.

Any suggestions would be appriciated.

Kahless 07-12-2007 11:18 AM

are you sure this card implements full hardware raid?

I am googling around for it on linux, but i dont see anything promising

I have a "raid card" that makes windows do some of the work, and cant doesnt really implement full hardware raid.... it can work, but to make it work you I would have to use kernel raid.

That being said, Kernel raid has worked pretty well for me :)

nieradka 07-13-2007 06:12 PM

Yeah it supports full hardware raid with the i960 processor; its an old full length 6 ide100 headers card.
Couldnt get it working in ubuntu, but i installed opensuse 10.2 without a problem, so i guess ill go with that. So it must have been a driver thing. Thanks for looking though.

Kahless 07-14-2007 12:40 AM

funny thing that opensuse distro

I am a slackware fan, and will probally always use slackware on my desktops.... but i got lazy and installed opensuse on my laptops.... and im glad I did. Its amazing how well everything works out of the box with that distro :) Its so easy to use its mind numbing, but on my laptop, its nice not to have to fuss with things when im not at home

All times are GMT -5. The time now is 06:46 AM.