LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 12-21-2007, 01:21 PM   #1
knudsen83
Member
 
Registered: Dec 2007
Location: Denmark
Distribution: Ubuntu 7.10 (Gutsy Gibbon)
Posts: 39

Rep: Reputation: 15
problems in mounting vfat volume with the right user permisisons


Hi everybody

I have this problem when i mount my external harddrive-a Western Digital, 320 gigabyte.
I have configured my fstab as follows:
/dev/sdb1 /media/My_Book vfat user,auto,uid=1001,umask=000 0 0

This configuration works fine, however i want to change the user permissions to 777 for one of the directories "X" on my WD. I am not able to change the user permissions with the chmod command and as far as i have understood it is actually impossible. So how do i manage to mount me device with uid=1001 and umask=022 but at the same time i want to be able to chang e the user settings for directorei "X" to 777...

Any ideas??
 
Old 12-21-2007, 02:14 PM   #2
Acron_0248
Member
 
Registered: Feb 2006
Location: Venezuela
Distribution: Gentoo
Posts: 453

Rep: Reputation: 33
Hi,


Try with:
Code:
/dev/sdb1 /media/My_Book vfat auto,umask=0000  0 0


Regards
 
Old 12-21-2007, 03:11 PM   #3
David1357
Senior Member
 
Registered: Aug 2007
Location: South Carolina, U.S.A.
Distribution: Ubuntu, Fedora Core, Red Hat, SUSE, Gentoo, DSL, coLinux, uClinux
Posts: 1,302
Blog Entries: 1

Rep: Reputation: 107Reputation: 107
Quote:
Originally Posted by knudsen83 View Post
So how do i manage to mount me device with uid=1001 and umask=022 but at the same time i want to be able to chang e the user settings for directorei "X" to 777...
I do not think you can change permissions of files and directories on a vfat partition because the file system does not support *nix style permissions. You can probably look this up using google.
 
Old 12-21-2007, 03:30 PM   #4
Acron_0248
Member
 
Registered: Feb 2006
Location: Venezuela
Distribution: Gentoo
Posts: 453

Rep: Reputation: 33
Quote:
Originally Posted by David1357 View Post
I do not think you can change permissions of files and directories on a vfat partition because the file system does not support *nix style permissions. You can probably look this up using google.

Indeed...to elaborate a little about that

Chmod won't tell that, you can run chmod -v 644 file over vfat and it'll say that successfully changed mode to (rw-r--r--), but, that change never happen actually. The effectives permitions are setted by the options during mount on the partition.



Regards
 
Old 12-22-2007, 03:46 PM   #5
knudsen83
Member
 
Registered: Dec 2007
Location: Denmark
Distribution: Ubuntu 7.10 (Gutsy Gibbon)
Posts: 39

Original Poster
Rep: Reputation: 15
Ok..so if i get it rigth it is not possible for me to change the file permissions, since these are strictly determined by the umask command in my fstab file.

what would you recommend if you wanted the entire partition to be rwxr-xr-x except for a single directorie which should have the settings rwxrwxrwx?..should i switch file system or something like that?

By the way what is the difference between umask=000 and umask=0000?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems mounting Truecrypt volume in Suse 10 Leslie Mackeen Linux - Security 2 06-16-2006 01:23 PM
Setting Volume label on mounted vfat drive Endorpheus Linux - Newbie 2 03-03-2006 02:47 AM
Vfat Mounting Problems Altec_ Linux - Hardware 0 02-07-2005 12:54 PM
problems mounting vfat partition oDyman Slackware 6 11-11-2004 05:18 AM
vfat volume won't allow date to be set TSloth Linux - Newbie 2 10-24-2004 01:12 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 08:22 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration