-   Linux - Hardware (
-   -   Problem with X Windows (

grub 03-31-2003 02:19 AM

Problem with X Windows

For the first time if I start Xserver (startx), it works fine.
But If I change the screen using Ctrl+Alt+F1, and go back using Ctrl+Alt+F7, I cant see the Xwindows. It just shows blank screen. By seeing some of the messages in this forum, I had set the bios frame buffer to 8MB, but still the problem is the same.
It also happens when I logout.
For starting the X again, I have to reboot the system.
Please do reply with all the possible solutions.

Mother Board : Intel D845GLLY
Monitor : SyncMaster 753s
Processor : Pentium 4 1.7 GHz
Driver used : Vesa


iphoting 03-31-2003 02:41 AM

it looks as if your X server is shutdown or killed....

grub 03-31-2003 04:39 AM

Please give the possible solution to avoid the problem.

jpbarto 03-31-2003 02:29 PM

you sure that ctrl+alt+f7 is where the xserver is running? Do you have 6 gettys running? I mean if you hit (before running xserver) ctrl+alt+f6 do you still see a login prompt... if say you only have 3 gettys running then xserver would be found by hitting ctrl+alt+f4... just some thoughts.
but if the xserver had been shutdown or killed then back in the original prompt (ctrl+alt+f1) you would see an error message coming back about the server being killed, if not its still running.

grub 03-31-2003 10:40 PM

Ye, I can see all the 6 gettys before starting X, (ofcourse after that also I can see). Is there any way to start X again, without rebooting the system.

One more thing I had observed is that for lesser resolution (800x600) I can change using Ctrl+Alt+F1 and Ctrl+Alt+F7.

Is that a problem with the driver or the Monitor:mad:

jpbarto 04-01-2003 09:27 AM

This isn't on a laptop by any chance is it?

If you have no trouble with switching back and forth at a given resolution compared to another then I would say it may be a driver / configuration issue.

If one Xserver is running (even if you can't get to it by ctrl+...) you can start another one on another display with the command

<prompt># xinit <window mngr> -- :1
(or even :2 or :3 ... the :# tells xinit to start an xserver on another display beside the default of :0)

hope that helps despite looking like a long collection of smily faces.

grub 04-03-2003 07:33 AM

Thanks jpbarto,
I will give a try for what you have suggested.

jpbarto 04-03-2003 10:46 AM

grub, have you seen this thread?

it seems that perhaps using XFree86 4.3 may help to solve a lot of the problem as the 845gl chipset has fairly poor support in other versions.

debphreak 04-03-2003 02:13 PM

just to pick up a small previous question

[QUOTE]Originally posted by grub
Is there any way to start X again, without rebooting the system.

if your xserver ever stops responding you can move to the getty it was running on and press ctrl+c

grub 04-03-2003 11:51 PM

Thanks to every one,
I got it solved by upgrading the kernel to 2.4.20. and setting the frame buffer to 8 MB. I also applied XFree86-

All times are GMT -5. The time now is 04:05 PM.