LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (https://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   problem with VESA framebuffer driver (https://www.linuxquestions.org/questions/linux-hardware-18/problem-with-vesa-framebuffer-driver-260954/)

alinsoar 11-30-2004 12:11 PM

problem with VESA framebuffer driver
 
Hi,

I have just started to install X on my laptop, and evething worked well.

I use the kernel 2.6.9, (the latest alpha st ver).

I have a nvidia card, more precisely:

Bus 1, device 0, function 0:
VGA compatible controller: nVidia Corporation NV17 [GeForce4 440 Go 64M] (rev 163).
IRQ 11.
Master Capable. Latency=248. Min Gnt=5.Max Lat=1.
Non-prefetchable 32 bit memory at 0xe0000000 [0xe0ffffff].
Prefetchable 32 bit memory at 0x90000000 [0x97ffffff].
Prefetchable 32 bit memory at 0x98000000 [0x9807ffff].


in /etc/X11/xorg.conf, I set up the nv driver for video d.

The problem is that I do not know how can I set up the kernel so that framebuffer device works well
If I set up the rivafb, the ker is able to see it :

linux:~ # cat /proc/fb
0 NV17 VGA
linux:~ #

When installed so
1. if I start X server with 1024x768 in desktop sect, the laptop blocks completely, I must power off and then switch on.
2. if I start with 640x480, the computer give the error : screen found, but any of them is good.

I tried everything to install VESAFB if menuconfig , but I do know what options I must select. I I select only VESA, after reboot I will see:

linux:~ # cat /proc/fb
0 VGA
linux:~ #

If somebody has an idea, please help me.

Post Script


When I use the selection: Device Drivers ---> Graphics support ---> Virtual Frame Buffer support (ONLY FOR TESTING!)

everything worked well, the X ser worked, the 1024x768 screex display with mouse cursor appeared when I started X. But it's just for testing...

comprookie2000 11-30-2004 09:05 PM

Sounds like it passed the test,I would use it.


All times are GMT -5. The time now is 08:27 AM.