LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 12-18-2004, 10:51 PM   #1
NickC
Member
 
Registered: Nov 2003
Location: Portland, OR, USA
Posts: 111

Rep: Reputation: 15
Problem with Linux and LCD monitor??


I have been successfully dualbooting Windows XP and Mandrake 9.2 for a while now. Recently I switched my 19" CRT (set to 1280 x 1024 resolution) for a Liquid Video 17" LCD (also 1280 x 1024). All my other hardware has stayed exactly the same.

On booting to Linux for the first time, a square box was dancing around the screen saying "Input Not Supported" - this looked to be coming from the monitor - the box looked a lot like the box that pops up when you want to adjust monitor settings.

Strangely enough though - Mandrake looked just fine on the LCD - even better than the CRT! Only this stupid box kept floating around the list. I tried changing resolution, rebooting, etc. to no avail. I searched these boards and check the hardware compatibility list, but I was not able to find any answers.

What's going on?
 
Old 12-18-2004, 11:10 PM   #2
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: McCalla, AL, USA
Distribution: Arch, Gentoo
Posts: 6,939

Rep: Reputation: 129Reputation: 129
You probably need to change your monitor's vertical and horizontal
sync rates in the XFree86 or Xorg configuration file. Not sure what
Mandrake uses, or which file. In Slack-10.0 it's /etc/X11/xorg.conf,
but that's probably not what Mandy-9.2 uses. Search the Mandrake
forum here at LQ for a thread with that file if no one comes to your
rescue. And in the future, you'll get better answers (usually) in that
Mandrake forum, especially since Mandrake is a commercial distro
and uses Mandrake specific methodology.
 
Old 12-19-2004, 12:21 PM   #3
NickC
Member
 
Registered: Nov 2003
Location: Portland, OR, USA
Posts: 111

Original Poster
Rep: Reputation: 15
Thanks. I did search both Mandrake forums and the whole linuxquestions forums, but I was not able to find anything. However, I did not search for xfree86 or sync rates, so I will look into that.
 
Old 12-19-2004, 03:19 PM   #4
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: McCalla, AL, USA
Distribution: Arch, Gentoo
Posts: 6,939

Rep: Reputation: 129Reputation: 129
You'll want to search for how to change your monitor's refresh rates
in Mandrake. You should also use Google <Linux> which will give you
some really good hits. And if you become a Contributing Member of LQ
you can use the Google search feature of LQ!
 
Old 12-19-2004, 10:40 PM   #5
NickC
Member
 
Registered: Nov 2003
Location: Portland, OR, USA
Posts: 111

Original Poster
Rep: Reputation: 15
I think I solved it - thanks!
 
Old 12-20-2004, 12:06 AM   #6
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: McCalla, AL, USA
Distribution: Arch, Gentoo
Posts: 6,939

Rep: Reputation: 129Reputation: 129
Good on yah! If you did solve it, could you post how you did it
so that someone who searches and finds your thread will know
what you did?

The reason I looked at your thread is because my LCD monitor
does not look as good in Linux as a CRT, and I was just curious
as to what your problem with Linux and a LCD was...
 
Old 12-20-2004, 09:54 AM   #7
NickC
Member
 
Registered: Nov 2003
Location: Portland, OR, USA
Posts: 111

Original Poster
Rep: Reputation: 15
Oh, sorry - I thought I clarified it. I did just what you suggested: I edited the /etc/X11/XFree86-4 file and changed the horizontal and vertical settings. It listed a range - I simply dropped the upper boundary to 60 Hz. I think the upper for the horizontal was something like 90 and the vertical was something like 80.

For me, even when this "Input Not Supported" box was floating around, the display looked better than my 19" KDS CRT. I'm not sure why your Linux is not looking as good - are you using the "optimal" resolution for your LCD? I'm not sure, but I think I remember reading that LCD's are sensitive when you use a resolution that is not the optimal recommended for the size of the LCD.

It's weird though - at work I was using an SGI Unix machine with an SGI CRT monitor. When they switched us to Windows 2000 machines, I got a beautiful 20" LCD along with it (an IBM Thinkvision). It had dual inputs, so I plugged my SGI box into this screen. And I quickly realized my SGI's CRT display was far, far better. Yet the Windows 2000 display is about the best I've seen!
 
Old 12-20-2004, 10:13 AM   #8
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: McCalla, AL, USA
Distribution: Arch, Gentoo
Posts: 6,939

Rep: Reputation: 129Reputation: 129
Yes, I have a Philips 150B4 15" LCD, and am using the settings
recommended by Philips. I bought a cheap, used 15" CRT and
it looks way better. Next computer I build when I return to
China will get my LCD, and I'll buy a 19" CRT. My LCD can only
support 1024x768 also.

Works great in Windoze, but not in Linux. I've searched the net
and haven't found anything. I've tried every suggestion and the
text is display is bad. I fault the Nvidia drivers for Linux, and will
also probably check out an ATI card. They have historically been
better for text and graphics editing, but Nvidia better for games.
And I don't play games....
 
Old 12-20-2004, 04:25 PM   #9
cathectic
Member
 
Registered: Sep 2004
Location: UK, Europe
Distribution: Slackware64
Posts: 761

Rep: Reputation: 35
.fonts.conf is your friend and your worst nightmare...

My LCD drove me up the wall with Linux for some time, and all the "helpful" guides are so thoroughly outdated and next to useless, they aren't worth the effort. However, reading up on .fonts.conf, I can offer the following (which is my own configuration, and actually works quite well):

Code:
<?xml version="1.0"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<fontconfig>
<!-- Disable sub-pixel rendering. X detects it anyway, and if you set this as well, it just looks really horrible  --> 
<match target="font" >
  <edit mode="assign" name="rgba" >
   <const>none</const>
  </edit>
 </match>
 <match target="font" >
  <edit mode="assign" name="hinting" >
   <bool>true</bool>
  </edit>
 </match>
 <match target="font" >
  <edit mode="assign" name="hintstyle" >
   <const>hintfull</const>
  </edit>
 </match>
<!-- The first part of the 'magic.' This makes the fonts start to look nice, but some of the shapes will be distorted, so hinting is needed still -->
 <match target="font" >
  <edit mode="assign" name="antialias" >
   <bool>true</bool>
  </edit>
 </match>
<!-- Autohinter is not turned on automatically. Only disable this if you have recompiled Freetype with the bytecode interpreter, which is run automatically. Although to be honest, Freetype are right, there isn't much difference between the two. Note that OpenOffice is built against the bytecode interpreter, so even if you have compiled it and override it with the autohinter, OOo will still use the bytecode interpreter -->
 <match target="pattern" >
  <edit mode="assign" name="autohint" >
   <bool>true</bool>
  </edit>
 </match>
<!-- Helvetica is a non true type font, and will look bad. This replaces it with whatever is the default sans-serif font -->
 <match target="pattern" name="family" >
  <test name="family" qual="any" >
   <string>Helvetica</string>
  </test>
  <edit mode="assign" name="family" >
   <string>sans-serif</string>
  </edit>
 </match>
 <dir>~/.fonts</dir>
</fontconfig>
It's still not quite perfect, but if it's any better, let me know, as I do plan on writing this up at some point if it's of any use to anyone but me.
 
Old 12-20-2004, 04:47 PM   #10
NickC
Member
 
Registered: Nov 2003
Location: Portland, OR, USA
Posts: 111

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by Chinaman
Yes, I have a Philips 150B4 15" LCD, and am using the settings
recommended by Philips. I bought a cheap, used 15" CRT and
it looks way better. Next computer I build when I return to
China will get my LCD, and I'll buy a 19" CRT. My LCD can only
support 1024x768 also.

Works great in Windoze, but not in Linux. I've searched the net
and haven't found anything. I've tried every suggestion and the
text is display is bad. I fault the Nvidia drivers for Linux, and will
also probably check out an ATI card. They have historically been
better for text and graphics editing, but Nvidia better for games.
And I don't play games....
Hmm... interesting. I too have an nVidia video card and haven't done a thing with it for Linux - I just let Mandrake autodetect it and that was that. I didn't install drivers separately or anything like that.
 
Old 12-20-2004, 05:10 PM   #11
xbennyboy
Member
 
Registered: Jul 2004
Distribution: openSUSE 10.2
Posts: 141

Rep: Reputation: 15
You know guys, I've had my LCD monitor for 5 years. Works fine in both windows and linux. You see I don't really think its the monitors fault. It simply displays stuff. Its your computer. Changing monitors doesn't all of a sudden change your display or any configuration stuff. At least that's what I have experienced. If it works fine in Windows, its should work fine in Linux. Usually its with video drivers or anti-aliasing. Linux has better anti-aliasing but Windows has better non-aliased fonts.

Also, LCDs tend to deal badly with lower resolutions. One computer pixel at lower resolution actually takes up 2,3, or 4 LCD pixels. This tends to make font all wobbly and curvish.

Also when buying LCDs make sure you get a TFT or active matrix one, never get a passive.
 
Old 12-21-2004, 08:31 AM   #12
NickC
Member
 
Registered: Nov 2003
Location: Portland, OR, USA
Posts: 111

Original Poster
Rep: Reputation: 15
True to a point - if I understood what you are trying to say. In my case, all I did was swap monitors - but the LCD couldn't handle the refresh rate. Once I changed that (from the help of this thread), it looks great. But...

I also noticed that the Linux display is slightly "off" - that is, there is a narrow vertical band of no display on the left. Hitting the "auto" button on the LCD takes care of that nicely, but now I have a similar issue when I switch over to Windows (until I hit auto again). I never had to do this with my CRT. (Not that I'm planning to go back; I love my LCD too much already! )
 
Old 12-21-2004, 11:43 AM   #13
xbennyboy
Member
 
Registered: Jul 2004
Distribution: openSUSE 10.2
Posts: 141

Rep: Reputation: 15
About the weird black bar on the side that doesn't display anything:

That happened to me too. But that was with my old default X11 drivers. Once I got my NVIDIA drivers for my video card it didn't do that anymore. Maybe you should get an updated driver.
 
Old 12-31-2004, 03:47 PM   #14
synaptical
Senior Member
 
Registered: Jun 2003
Distribution: Mint 13/15, CentOS 6.4
Posts: 2,020

Rep: Reputation: 48
Quote:
Originally posted by cathectic
.fonts.conf is your friend and your worst nightmare...

My LCD drove me up the wall with Linux for some time, and all the "helpful" guides are so thoroughly outdated and next to useless, they aren't worth the effort. However, reading up on .fonts.conf, I can offer the following (which is my own configuration, and actually works quite well):

<snip>

It's still not quite perfect, but if it's any better, let me know, as I do plan on writing this up at some point if it's of any use to anyone but me.
dude, you're a genius. i can't thank you enough. about a year ago my fonts went bad after an upgrade, and nothing i did fixed them. i tried every configuration known to humans in /etc/fonts/local.conf, scoured the xfree/xorg/freetype lists, asked on LQ, asked on the arch board, tried different DPI values, set absolute screen geometries in xorg.conf, looked into .gconf, used different grayscale values, reinstalled freetype about a zillion times with bytecode interpreter enabled, disabled, etc. -- nothing worked, and no one knew how to fix them.

i was sure it had to do with my LCD, b/c slack 10 had perfect fonts on my mom's computer w/ CRT. but on my PC they looked like hell. the settings in xf86/xorg.conf were okay, though, and it was the same X and font config files i used when my fonts were working with slack 9. i just didn't get it. finally after months of trying i just gave up and just got used to the bad fonts.

then today i was doing the finishing touches on a reinstall on a new hard drive, and the fonts looked worse than ever. on a whim i searched LQ and came across your post. i plugged your code into ~/.fonts.conf, restarted X, and VOILA, i have beautiful, gorgeous fonts again! after almost a year!

so i would definitely encourage you to publicize your fix as widely as possible for the LCD users who are stuck with bad fonts. i will host any webpage/s you make on my server if you need it. if you don't, please post back when you have something up so i can link to it.

nothing else i tried worked, and i tried everything. you rule! i'm awarding you the "Linux GUI Tweaker of the Year" award for 2004.

Last edited by synaptical; 12-31-2004 at 10:16 PM.
 
Old 02-07-2005, 04:37 AM   #15
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: McCalla, AL, USA
Distribution: Arch, Gentoo
Posts: 6,939

Rep: Reputation: 129Reputation: 129
Quote:
Originally posted by synaptical
dude, you're a genius.

nothing else i tried worked, and i tried everything. you rule! i'm awarding you the "Linux GUI Tweaker of the Year" award for 2004.
Quote:
Originally posted by cathectic
.fonts.conf is your friend and your worst nightmare...

My LCD drove me up the wall with Linux for some time, and all the "helpful" guides are so thoroughly outdated and next to useless, they aren't worth the effort. However, reading up on .fonts.conf, I can offer the following (which is my own configuration, and actually works quite well):

It's still not quite perfect, but if it's any better, let me know, as I do plan on writing this up at some point if it's of any use to anyone but me.
Guys, I have copied this file from synaptical's website,
placed it in my ~/ directory, and restarted Fluxbox...
but it's absolutely no different.

Can you give me a push or further instructions?

Thanks!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
LCD Monitor Problem pbeckler SUSE / openSUSE 3 08-31-2005 01:39 PM
LCD Monitor Problem pbeckler Fedora - Installation 1 08-31-2005 09:32 AM
SuSE 9.2 LCD Monitor Problem NCAussie SUSE / openSUSE 2 05-17-2005 06:34 AM
Problem about my LCD monitor jpan Linux - Hardware 1 10-07-2004 08:39 PM
LCD Monitor problem thllgo Linux - Hardware 4 10-09-2003 02:29 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 08:36 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration