-   Linux - Hardware (
-   -   Problem mount USB devices. (

jonostew 08-17-2004 02:48 PM

Problem mount USB devices.
Hi everyone. I'm running Fedora Core 2.0 on a Presario 2100 laptop. At one time my USB devices worked and were detected. However, I think with some software updates the USB system software became misconfigured.

I have followed the USB card install tutorial, including trying to build a new kernel with the proper USB directives. However, this kernel will not boot for me.

When I try to mount my USB device with kernel 2.6.5-,1I get the following error message.

[root@localhost mnt]# mount /mnt/usb
mount: /dev/sda1 is not a valid block device

/etc/fstab contains the following line.
/dev/sda1 /mnt/usb vfat user,rw,noauto 0 0

and I have run
chmod 777 /mnt/usb

dmesg shows nothing about the USB device when I plug it in.

tail -s 3 -f /var/log/messages also show nothing when the USB device is plugged-in or removed.

I know the USB hardware works because my system is dual boot Fedora / Windoze, and the USB port works in Windoze.

I have tried to read various posts about loading the proper modules into the kernel, but I have not been able to get my USB devices working.

Can someone out there help me get my USB devices working again? Please?

pingu 08-18-2004 02:40 AM

This strange thing happened to me too.
I then tried mounting /dev/sda instead of /dev/sda1, this worked in some distro's!
But then I also got errors about reading filesystem etc. I checked the drive (USB memory stick) with fdisk, seems the partitioning is weird.
I think a USB-device can get corrupted if it's not unmounted properly.

rjlee 08-18-2004 08:34 AM


Originally posted by pingu
I think a USB-device can get corrupted if it's not unmounted properly.
The filesystem can get corrupted in the same way as yanking the cable on an internal drive would; the device itself will still work fine and you should be able to fix the problem with fsck as normal.

Most USB devices come with a FAT filesystem preinstalled, so you may want to make sure that you have the vfat module loaded.

The fact that the USB device isn't being detected is what's causing this problem. Make sure that you have the usb modules loaded (try mounting the /proc/bus/usb directory). Also see the USB-HOWTO from

Hope that's of some help,

Robert J Lee

jonostew 08-19-2004 12:03 PM

I fixed the problem by inserting a number of usb modules. Im not sure which ones were needed and which ones were unnecessary, but Ill just insert all of them until I can figure out which are essential.

Can anyone tell my how to insert the modules into the kernel at boot time, instead of manually doing it from a terminal window each time after I login?


rjlee 08-20-2004 12:39 PM

You can add the instructions to load the modules into your boot.local file (try

locate boot.local
to find it; it's usually in somewhere like /etc/rc.d/ or /etc/init.d).

All times are GMT -5. The time now is 12:12 AM.