-   Linux - Hardware (
-   -   Problem connecting external hard drive (

Findus 02-21-2009 07:25 AM

Problem connecting external hard drive

I don't know if this is the right forum to post this, but I have always gotten help here, so it seemed like a good choice.

I recently bought a WD Passport Essential 320GB external hard drive. This drive works perfectly on my laptop with Fedora 10 installed, but my workstation fails to recognize it. This workstation is a dual boot Win XP/Fedora 10 machine, but I usually use the Windows install. I initially thought that the drive not being recognized was a windows problem, but today I tried to connect the hard drive to Fedora 10 on the same machine. This attempt also failed, which got me thinking that perhaps the USB ports on my motherboard didn't have enough power do start the hard drive? The drive light on the hard drive turns on when it is connected, which indicates that it gets some power, but maybe not enough. The hard drive is a 2.5'' drive, which shouldn't require an external power source. The motherboard in the workstation is an AOpen AK-86L powered by a 520W power supply .

So, to recap, is it possible that this combo doesn't provide enough power to make the external drive usable?

- Findus

aus9 02-21-2009 07:41 AM


my nephew bought a y usb lead....which supplies power from 2 usb ports but data to one port

2) sometimes the back usb port may just have sufficient power

you may need to post the true power usage pls

Findus 02-21-2009 08:46 AM

I have tried just about all the USB-ports in my workstation, none of them work. Also, how do I get the needed power usage data?

- Findus

michaelk 02-21-2009 09:26 AM

Ooops, I was looking at the wrong drive. However, I agree with aus9 that some laptops might not provide enough current and that an optional power adapter cable is available.

pentode 02-21-2009 11:36 AM

Does the light on the drive come on? Have you checked dmesg | tail after you plug it in for any messages?

Findus 02-21-2009 02:02 PM

The light on the drive powers on, and the drive works perfectly on my laptop. It's the workstation that provides the problem. I have looked at dmesg | tail after connecting the drive, but nothing there seemed to relate to the drive. Unfortunately I'm not at my workstation, and won't be for another 2 weeks, so I won't be able to post any output.

- Findus

aus9 02-21-2009 05:43 PM

ahh yours is different it has a separate power lead

so it needs a separate power source

Findus 02-24-2009 12:16 PM

Correction: I have one of these, a Passport Essential. This does not require an external power source. I will update my original post accordingly.

- Findus

aus9 02-25-2009 05:29 AM

ok so back to looking a Y-usb lead but your specs may be 1000 Ma

2) of course the other issue is go back to the computer where it does work and look at the file system format...which is either fat32 or ntfs...I bet its ntfs.

so maybe your linux distro does not support it?

ntfs-3g maybe

Findus 03-01-2009 05:06 AM

Today I got my drive working on a computer runnig Vista by changing the filesystem from NTFS to fat32. For some reason the Vista machine refused to read the disk when it was NTFS-formatted, but once it was formatted as fat32 it was fine. Hopefully this will be true for my computer at home too, so I don't have to buy a special cable to use my hard drive on that one computer.

- Findus

All times are GMT -5. The time now is 03:56 AM.