LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 10-04-2005, 02:24 AM   #1
Deltabweb
LQ Newbie
 
Registered: Jul 2005
Distribution: Suse 10.0 x86_64
Posts: 21

Rep: Reputation: 15
Problem Booting Raid 0 with dmraid


Hi,
I'm trying to install Suse 10 on a raid 0 array using dmraid (I'm using nvraid)
Here is what I made so far
Installed suse 10 on an ide hard disk
Copied the installation on the raid 0 array
Made it bootable using grub
Used the dmraidinitrd script I dled somewhere (don't remember where), modified it and the linuxrc to work with me
Recompiled the kernel to have the nv sata driver


And here's the result :
I boot, no problem with grub, the linuxrc launch and it blocks at creating /dev/mapper/control
After testing stuff I found that it blocks at detecting the minor and major ID of the drive
So I got them with the command it should use in the linuxrc from the ide drive that boots (it's perhaps the error) getting me 10 major and 63 minor or somethin like that
Then i set it in the linuxrc, reboot and it blocks at mounting the device.
I get a shell and do
Code:
ls /dev/mapper
I have only config no nvidia_gd... (what i should get)
Code:
dmraid -s
Give me the right array (nvidia...)
but if I launch
Code:
dmraid -ay
nothing happens

Any idea ??

Sorry if I'm hard to understand I typed this rapidly if something is hard to understand just ask

Cordially,
Delta
 
Old 10-04-2005, 10:43 PM   #2
aus9
LQ 5k Club
 
Registered: Oct 2003
Location: Western Australia
Distribution: Sway or Xfce
Posts: 5,509

Rep: Reputation: Disabled
can't help you may find this helpful?
http://www.linuxquestions.org/questi...hreadid=241947

its the last link I am referring and then if it helps how about some feedback if you care to?
 
Old 10-06-2005, 10:30 PM   #3
Deltabweb
LQ Newbie
 
Registered: Jul 2005
Distribution: Suse 10.0 x86_64
Posts: 21

Original Poster
Rep: Reputation: 15
I fixed it by recompiling my kernel with the device mapper compiled statically instead of a module.
Thx anyway for the answer I'm going to post my working settings in this thread.
 
Old 01-23-2007, 07:50 PM   #4
The Cleaner
LQ Newbie
 
Registered: Jan 2007
Posts: 13

Rep: Reputation: 0
I am having the same problem where, after loading dmraid and instaling it, i try to execute the dmraid -ay command and nothing happens.

Could you please explain to me how you got around it?
As far as compiling a new kernel is concerned, I don't know how to do that.
Any help would be appreciated.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
dmraid - installing to a raid array? N_A_J_M Linux - General 3 01-28-2006 09:09 AM
Promise Fasttrack RAID on Mandrake 10.1 | dmraid, driver, headaches, Debian? rokkon Linux - Hardware 7 12-18-2005 07:15 AM
software raid? dmraid? N_A_J_M Slackware 1 08-17-2005 07:44 PM
Help with RAID setup (dmraid) unzari Fedora 2 07-20-2005 12:01 PM
Problem booting server with Suse 8.1 and RAID adapter. michael301080 Linux - Hardware 1 05-02-2004 05:45 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 06:35 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration