LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 01-04-2005, 09:59 AM   #1
darknails
Member
 
Registered: Jul 2004
Location: Germany
Distribution: Debian
Posts: 46

Rep: Reputation: 15
Problem accessinng mounted hard drive


Hi,
I'm using Fedora Core 3 (FC3) (kernel version 2.6.9-1.723_FC3) on Toshiba Tecra S1 laptop, and could not access my mounted hard drives properly.

My /etc/fstab is the following:

Code:
# This file is edited by fstab-sync - see 'man fstab-sync' for details
LABEL=/1                /                       ext3    defaults        1 1
LABEL=/boot1            /boot                   ext3    defaults        1 2
none                    /dev/pts                devpts  gid=5,mode=620  0 0
none                    /dev/shm                tmpfs   defaults        0 0
none                    /proc                   proc    defaults        0 0
none                    /sys                    sysfs   defaults        0 0
LABEL=SWAP-hda4         swap                    swap    defaults        0 0
/dev/hda5               /mnt/app                vfat    rw,exec         0 0
/dev/hda6               /mnt/media              vfat    rw,exec         0 0
/dev/hdc                /media/cdrecorder       auto    pamconsole,fscontext=system_u:object_r:removable_t,exec,noauto,managed 0 0
The drives I'm trying to access are /mnt/app and /mnt/media. The folders were already created. They can be accessed by earlier versions of kernel (2.4 or 2.5 I think), but not 2.6.

If I type
Code:
#cd /mnt/app/
ls
Then the shell (or shall I say Terminal) hangs up. Upon shuting down the system, while unmounting, they fail and the message is "Device busy".

Hope someone can help. Thankyou!

Last edited by darknails; 01-04-2005 at 10:06 AM.
 
Old 01-04-2005, 12:16 PM   #2
Andrew Benton
Senior Member
 
Registered: Aug 2003
Location: Birkenhead/Britain
Distribution: Linux From Scratch
Posts: 2,073

Rep: Reputation: 64
/dev/hda5 /mnt/app vfat rw,exec,umask=0 0 0
/dev/hda6 /mnt/media vfat rw,exec,umask=0 0 0
 
Old 01-04-2005, 02:58 PM   #3
darknails
Member
 
Registered: Jul 2004
Location: Germany
Distribution: Debian
Posts: 46

Original Poster
Rep: Reputation: 15
Thanks Andrew. I added in the umask option, but the problem persists. After a closer look I found that I can access /mnt/media, but not /mnt/app. And during the unmounting process of shut down, /dev/pts also failed to be unmounted for the same reason (Device or resourece is busy)

I don't know if this is because I have fragments of uncompleted torrent file in this drive. I tried to delete all the torrent files I could find, but it still didn't work. It's possible I missed some files. The ultimate test would be format this drive but backing up files and re-installing program would be a real pain.

I wonder if this is a known problem?
 
Old 01-04-2005, 10:18 PM   #4
darknails
Member
 
Registered: Jul 2004
Location: Germany
Distribution: Debian
Posts: 46

Original Poster
Rep: Reputation: 15
I found that, after removing the eMule program (including the residual files after uninstall) in /dev/hda5 (I did this under Windows). I can now access /mnt/app from FC3 without trouble. So I'm happy.

I'm still interested to know why this is the case.

Last edited by darknails; 01-04-2005 at 10:21 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Mount usb if hard drive is mounted in sda nifflerX Linux - General 1 10-05-2005 02:51 PM
mounted hard drive can only be accessed by root Flutterby Linux - Hardware 3 07-17-2004 03:52 AM
External Hard Drive Not Mounted during Install chazdg Mandriva 5 10-30-2003 11:02 AM
Hard drive mounted in read only (After long uptime...) otjervaag Linux - Laptop and Netbook 10 10-04-2003 08:34 PM
r/w permissions on a mounted ext3 hard drive harperonline Linux - Hardware 1 03-19-2003 05:22 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 06:10 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration