LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (https://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   Printer problem - Installing Lexmark All in One Printer on Fedora 16 (https://www.linuxquestions.org/questions/linux-hardware-18/printer-problem-installing-lexmark-all-in-one-printer-on-fedora-16-a-923899/)

glock356 01-15-2012 10:19 AM

Printer problem - Installing Lexmark All in One Printer on Fedora 16
 
Hello!

I am istalling Fedora 16 32 bit on computer where is previously installed Opensuse(replace Opensuse with Fedora)
Everything OK, installation, updates...
Then installed printer - Lexmark all in one X2670 - downloaded driver from Lexmark site(for Red Hat based), unpacked and run installation.
Installation go OK, printer is installed.
But when I tried to print test page, nothing happened - message appeared - the printer is not communicating or busy.
I tried Printer Maintenance from CUPS - no success - CUPS not allowed me any action, give me a message for everything - Forbidden
Also requested a Username and password, but when I enter root username and password this is not accepted.
I never set up any other password and username for CUPS

The same printer on the same coputer previously work fine under Opensuse(used the same procedure for installation)

What go wrong and what could I do to set up printer correctly on Fedora?

Thank You for answers and please for any explanation to be simple as much as possible - english is not my language and I am stil wery new in Fedora

Janus_Hyperion 01-16-2012 06:25 AM

Try adding printer using system-config-printer. You may be asked to install FirewallD (I was asked to install FirewallD before adding the printer). I do not understand FirewallD completely, but after I installed it, I was able to add printers with great ease. Also verify that port 631 is open. This is the port that cups uses (as far as I know).

Chris73 01-21-2012 07:31 PM

Hi there,

I just took a look over at Lexmark's site, and there does not seem to be a driver that supports Fedora for the X2670 printer. I see one's for OpenSUSE, Debian etc, but none for Fedora. I'm not really sure, because I had to fight with my unsupported printer recently, only I'm using Debian stable, and there was a "hack" for my printer. Maybe there is a "hack" out there for yours too, or maybe one of the other drivers will work. Wish I could be more help.


All times are GMT -5. The time now is 11:00 AM.