-   Linux - Hardware (
-   -   Printer driver Oki C810 523af2 Ubuntu12.04 kernel 3.2.0-34-generic-pae (

Tom6 12-04-2012 03:06 PM

Printer driver Oki C810 523af2 Ubuntu12.04 kernel 3.2.0-34-generic-pae
Hi :)
I am working my way through all the Oki drivers listed in the "New Printer" gui in Ubuntu 12.04 but all the ones nearest to my printer's make&model have failed to print a test-page.

The Oki is "on the network" rather than directly attached to the desktop machine i am using.

All the Windows Xp machines needed the Oems disk before they could see it. Win7 found it as a device NOT when it searched for Printers but now they are happy using the Oki as the default printer. All the other printers on the network installed fine to all other desktop machines and the dual-boot on that desktop machine (Ricoh, Brother, Kyocera) on XP, Win7 and Ubuntu (10.04, 10.10 and 12.04).

When using Ubuntu 12.04's "New Printer" it initially finds the Oki and then gives me 2 choices for type of connection. Mostly i have been going through the default choice of
1. AppSocket/JetDirect network printer via DNS-SD
the 2nd option is
2. LPD network printer via DNS-SD

I am a bit clueless about networking but usually manage to get desktops just about working even on Windows despite the usual problems with MS stuff.

So, any idea how to get the Oki C810 working? Am i likely to need to use ndiswrapper and if so then how? I'm not great on the command-line but can usually follow directions fairly well. I'm more a point&click user tbh, hence Ubuntu.

Regards from
Tom :)

markush 12-04-2012 03:52 PM

You make it much more complicated than necessary. I've some printers OKI b430n running, they are postscript printers and very well compatible with Linux.

Open the webinterface of cups in a browser

and configure a new printer, select a network printer and enter the ip-adress of the printer, this should work for you.


Tom6 12-05-2012 09:30 AM

Hi :)
Thanks for responding so fast and sorry for the delay! I had just finished work and only just got back to my desk just now!

That Cups page was magic. It had all the printers listed that i installed yday. Adding the Oki still seems problematic as it is the only printer that gives me a great long list of possible models none of which matches what it has identified my printer as being.

It identifies that the model is Oki C810 but from the list the nearest numbers are OL 810

Thanks so far but still a problem here
Regards from
Tom :)

markush 12-05-2012 09:46 AM

You can install a ppd file for the printer, download on OKI's site
In the webinterface for cups you can select a ppd file for the printer, simply choose the downloaded one.


Tom6 12-05-2012 06:35 PM

Hi :)
Thanks for the link to the nearest PPD. I tried to find the one for the 810 but they dont seem to have one on their website and the Cups website didn't seem to have it either. I just got the Oki installer Cd into the drive but got caught up in other stuff and didn't get around to searching the Cd for a PPD.

The 610 one didn't seem to do the trick.

I tried plugging the Oki directly into another desktop but i think that one is still on an unsupported version of Ubuntu now. I really should install 12.04 onto it soon and that might give me a chance to see if hardware detection picks up on the printer any better. I've got a feeling i should have changed some of the settings on the Oki itself.

Also i noticed that Cups had a forum and it's got to be worth a shot too.
Many thanks and regards from
Tom :)

Tom6 12-06-2012 12:38 PM

Hi :)
Grrr, i had a look all through Oki's Cd and couldn't find a better ppd. In fact they had no ppd at all. The one from their site for the 610 seems to be the most likely one but it doesn't work :(

I can print when i reboot into Windows and i can print to other printers in the building so i'm not hugely upset that i can't. It worries me a bit because my boss wants to buy another Oki and i would rather get a model that does make some effort to support non-Windows platforms [shrugs].

Ok, i have posted to the Cups forums
and given them a link to this thread.

Regards from
Tom :)

markush 12-06-2012 01:19 PM

You could also find out which settings you have configured on the printer. Afaik it should work when the printer is configured for postscript, then it should at least be possible to print a postscriptfile with the lpr command.


prebijak 02-07-2014 04:48 PM

OK after 2 hours I managed to make it work using drivers from foo2hiperc (just for reference).

All times are GMT -5. The time now is 12:59 AM.