LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 12-21-2004, 05:55 PM   #1
RoaCh Of DisCor
Member
 
Registered: Apr 2004
Location: Washington State
Distribution: SuSE 9.3 / Slackware-Current
Posts: 701

Rep: Reputation: 30
Port forwarding simply won't work..


I've tried everything, several times...and port forwarding just won't work. Is it possible that this is a network card problem? I've run out of ideas.

Thanks

-RoaCh
 
Old 12-21-2004, 06:01 PM   #2
sigsegv
Senior Member
 
Registered: Nov 2004
Location: Third rock from the Sun
Distribution: NetBSD-2, FreeBSD-5.4, OpenBSD-3.[67], RHEL[34], OSX 10.4.1
Posts: 1,197

Rep: Reputation: 46
Not if you get traffic at all...

What have you tried, exactly?
 
Old 12-21-2004, 06:52 PM   #3
RoaCh Of DisCor
Member
 
Registered: Apr 2004
Location: Washington State
Distribution: SuSE 9.3 / Slackware-Current
Posts: 701

Original Poster
Rep: Reputation: 30
Here is my ifconfig output:

Quote:
root@darkrealm:/home/roach/Programs/webmin-1.170# ifconfig
eth0 Link encap:Ethernet HWaddr 00:C0:A8:87:0D:7A
inet addr:192.168.1.47 Bcast:255.255.255.255 Mask:255.255.255.0
UP BROADCAST NOTRAILERS RUNNING MULTICAST MTU:1500 Metric:1
RX packets:2214 errors:0 dropped:0 overruns:0 frame:0
TX packets:1871 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:2444691 (2.3 Mb) TX bytes:229562 (224.1 Kb)
Interrupt:18 Base address:0x2800

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:20 errors:0 dropped:0 overruns:0 frame:0
TX packets:20 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:1165 (1.1 Kb) TX bytes:1165 (1.1 Kb)
Firstly, I'll say that I'm not too experienced with networking, but I think I understand the just of it.

Say I want to forward port 21 to my internal ip

I goto 192.168.1.1 and then goto port forwarding.

I forward port 21 to 192.168.1.47 (which I think is correct?)

Still...no go. I've tried forwarding ports for azureus as well *bit torrent client*...but no affect.

I've also tried creating a static ip, and forwarding ports to that...but still, nothing.

I was starting to think that maybe it was my DSL provider's problem...Qwest DSL...but we recently moved so we switched to Verizon DSL. Still...same problem. The modem I am currently using is a Westell VersaLink Model 327W. It's a router/gateway type thing, so it can connect up to 4 computers to it. Forwarding ports doesn't work in Linux.or Windows. So either I'm doing something wrong all along or there's something else wrong :S.

As of now I'm totally confused.

Last edited by RoaCh Of DisCor; 12-21-2004 at 06:53 PM.
 
Old 12-21-2004, 09:28 PM   #4
aeNeo
Member
 
Registered: Jul 2004
Distribution: Slackware 10.0
Posts: 57

Rep: Reputation: 15
I hope I understand your problem correctly =\

Port Forwarding is used for *incoming* connections (like ssh, ftp, apache, etc.), which helps your 'puter act as a server if it's behind a router. But in the case of bit-torrent clients, limewire, etc., port forwarding shouldn't be necessary since the application establishes and maintains connections on its own.

But configuring your router to port forward isn't enough to make it work. You'll have to open the respective ports on your home box as well, which allows it to listen for traffic on those ports and take action when necessary. For example, FTP uses port 21; you'll need to modify the appropriate ftp files (depending on which app you're using for it, like proftp, etc) to activate the service. Use google to find howto docs if you don't know which files are which.

Or just ignore my advice if I misunderstood your problem
 
Old 12-21-2004, 11:19 PM   #5
RoaCh Of DisCor
Member
 
Registered: Apr 2004
Location: Washington State
Distribution: SuSE 9.3 / Slackware-Current
Posts: 701

Original Poster
Rep: Reputation: 30
I'll try that..thanks...I'm not even certain of my problem...lol.

One of my problems is i've been trying to run an ftp server...but it uses my computer's ip number (192.168.1.47 or whatever)...not the public one. SO I Guess I have to have ports forwarded to that Ip number. I've tried several times and it just doesn't seem to do anything.

Also as said above..bit torrent clients. They work...but slowly. It never fully connects...as it says that it needs port 6881 open. When running azereus I get several errors that it can't connect to this port. I believe it's open...but it needs to be forwarded...or so I've been told.

Anyway, I'll do more experimenting...thanks.

-RoaCh
 
Old 12-21-2004, 11:37 PM   #6
RoaCh Of DisCor
Member
 
Registered: Apr 2004
Location: Washington State
Distribution: SuSE 9.3 / Slackware-Current
Posts: 701

Original Poster
Rep: Reputation: 30
Ohhhhhh! I was messing with port forwarding and got azureus working properly!

What ports do I need to open for someone to be able to connect to my FTP server?

I know 21...but that isn't working. Is there others?
 
Old 12-22-2004, 08:20 AM   #7
fotoguy
Senior Member
 
Registered: Mar 2003
Location: Brisbane Queensland Australia
Distribution: Custom Debian Live ISO's
Posts: 1,286

Rep: Reputation: 62
Port 20 for FTP data
 
Old 12-22-2004, 12:13 PM   #8
sigsegv
Senior Member
 
Registered: Nov 2004
Location: Third rock from the Sun
Distribution: NetBSD-2, FreeBSD-5.4, OpenBSD-3.[67], RHEL[34], OSX 10.4.1
Posts: 1,197

Rep: Reputation: 46
Quote:
Port 20 for FTP data
Unless the server is trying to talk passive to the clients, in which case it's probably handing back it's internal IP (192.168.1.47) which the client will almost certainly fail to connect to.
 
Old 12-22-2004, 06:30 PM   #9
xbennyboy
Member
 
Registered: Jul 2004
Distribution: openSUSE 10.2
Posts: 141

Rep: Reputation: 15
Make sure you also set up a static ip on your computer and disable the DHCP server on your router.

And also most p2p software need port forwarding because they can't negotiate with your router. I had to open port 6346.
 
Old 12-23-2004, 06:07 PM   #10
aeNeo
Member
 
Registered: Jul 2004
Distribution: Slackware 10.0
Posts: 57

Rep: Reputation: 15
Quote:
Originally posted by RoaCh Of DisCor
Ohhhhhh! I was messing with port forwarding and got azureus working properly!

What ports do I need to open for someone to be able to connect to my FTP server?

I know 21...but that isn't working. Is there others?
You'll need to open port 21 on your box. Like I said before, read through the ftp howtos to configure your server. Once you're finished configuring everything, restart the inet1 service. Then you should be in business.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
IPCHAINS port forwarding and IPTABLES port forwarding ediestajr Linux - Networking 26 01-14-2007 08:35 PM
Port Forwarding does NOT work! The Pentium Guy Linux - Networking 4 10-31-2004 08:40 PM
Server doesn't work with port forwarding enables Dawyea Linux - Networking 7 06-19-2004 10:57 AM
Port forwarding does not work! philipina Linux - Networking 2 03-03-2004 03:15 AM
port forwarding does not work on additional ip addresses antken Linux - Networking 1 02-10-2004 07:51 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 05:00 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration