-   Linux - Hardware (
-   -   Poor sound quality with ALSA in Mandrake 10 (

Dr_Travis 06-14-2004 11:43 PM

Poor sound quality with ALSA in Mandrake 10
Hey All,
After spending 2 days googling to no avail, I ask for your expertise.
Problem: New install of Mandrake 10 is causing poor sound quality in all sound/video applications. Soundcard C-Media Electronics on board sound card (CM8738)

Tried: Alsaconf, changing volumes in Alsamixer, installing different sound programs
Other information:
Sound seems to be less distorted in the upper frequencies.

Xmms will crash when I use the Output plugin AlSA 1.2.9 output plugin (, but will work when I use OSS Driver 1.2.7 ( When Xmms crashes it outputs the following message:

xmms: pcm.c:899: snd_pcm_delay: Assertion `pcm->setup' failed.

Sound worked fine under Redhat 9 (no ALSA)

Output from lsmod:
Module Size Used by
sg 38044 0
st 38616 0
sr_mod 17028 0
sd_mod 16832 0
scsi_mod 114648 4 sg,st,sr_mod,sd_mod
parport_pc 32832 1
lp 12200 0
parport 38952 2 parport_pc,lp
md5 3872 1
ipv6 232352 8
snd-seq-oss 31232 0
snd-seq-midi-event 7552 1 snd-seq-oss
snd-seq 51024 4 snd-seq-oss,snd-seq-midi-event
snd-pcm-oss 51812 1
snd-mixer-oss 17952 2 snd-pcm-oss
snd-cmipci 33236 2
snd-pcm 93156 2 snd-pcm-oss,snd-cmipci
snd-page-alloc 11972 1 snd-pcm
snd-opl3-lib 9984 1 snd-cmipci
snd-timer 24484 3 snd-seq,snd-pcm,snd-opl3-lib
snd-hwdep 8928 1 snd-opl3-lib
gameport 4480 1 snd-cmipci
snd-mpu401-uart 7072 1 snd-cmipci
snd-rawmidi 23616 1 snd-mpu401-uart
snd-seq-device 8008 4 snd-seq-oss,snd-seq,snd-opl3-lib,snd-rawmidi
snd 52484 13 snd-seq-oss,snd-seq-midi-event,snd-seq,snd-pcm-oss,snd-mixer-oss,snd-cmipci,snd-pcm,snd-opl3-lib,snd-timer,snd-hwdep,snd-mpu401-uart,snd-rawmidi,snd-seq-device
soundcore 9248 3 snd
af_packet 20520 2
hid 53312 0
raw 7616 1
ide-floppy 18752 0
ide-tape 34864 0
ide-cd 40548 0
cdrom 37184 2 sr_mod,ide-cd
floppy 59444 0
natsemi 23840 0
amd-k7-agp 7564 1
agpgart 31016 1 amd-k7-agp
uhci-hcd 29104 0
usbcore 99132 4 hid,uhci-hcd
rtc 11576 0
ext3 110408 2
jbd 54328 1 ext3

Output from lspci:
00:00.0 Host bridge: Advanced Micro Devices [AMD] AMD-760 [IGD4-1P] System Controller (rev 13)
00:01.0 PCI bridge: Advanced Micro Devices [AMD] AMD-760 [IGD4-1P] AGP Bridge
00:04.0 ISA bridge: VIA Technologies, Inc. VT82C686 [Apollo Super South] (rev 40)
00:04.1 IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT8233/A/C/VT8235 PIPC Bus Master IDE (rev 06)
00:04.2 USB Controller: VIA Technologies, Inc. USB (rev 16)
00:04.3 USB Controller: VIA Technologies, Inc. USB (rev 16)
00:04.4 Non-VGA unclassified device: VIA Technologies, Inc. VT82C686 [Apollo Super ACPI] (rev 40)
00:05.0 Multimedia audio controller: C-Media Electronics Inc CM8738 (rev 10)
00:0a.0 Ethernet controller: National Semiconductor Corporation DP83815 (MacPhyter) Ethernet Controller
01:05.0 VGA compatible controller: nVidia Corporation NV11DDR [GeForce2 MX 100 DDR/200 DDR] (rev b2)

Thanks for the help and keeping this forum alive and functioning. If not for the people on this message board, I may have gone back to the dark side.


indeterminate 06-15-2004 02:11 AM

Hrm, that's interesting, looks like the driver's loading all right. You might try checking your /var/log/syslog file to see if alsa says anything interesting in there when it gets loaded. Any warnings or errors in particular would be nice. I know the driver for my card doesn't support anything over 48kHz, and that caused some quality problems until I changed some settings. Perhaps your problem is something similar that the syslog would reveal.

If you can't figure out anything to fix alsa, you can edit your /etc/modules.conf file. It'll hopefully have a line something like:

alias sound-slot0 snd-cmipci

just remove the "snd-" so you just have "alias sound-slot0 cmipci" and reboot to try that. It'll try using the older OSS driver instead of the newer ALSA one; you might have better luck with that. Any modules you see that start with "snd-" are alsa modules.

Other than that, uh... check out the documentation for the cmipci and snd-cmipci drivers, see if they list any known issues. That's about all I can think of. Hope it helps.

All times are GMT -5. The time now is 12:37 AM.