-   Linux - Hardware (
-   -   Plantronics 628USB not operating correctly. (

MichaelCole 05-14-2012 11:12 PM

Plantronics 628USB not operating correctly.
I have just purchased a Plantronics 628USB headset,

The Plantronics DA45 works correctly with Linux as i have used that for a while now, but the 628USB seems to have extra requirements.

I can hear audio but the volume stays at a single level, not able to lover the volume by the buttons on the device, and if you turn down the volume on the desktop the device will increase the volume.

THe next more annoying problem is the Microphone, it appears as a iec958-stereo-input under Pluse.

After 3 seconds the microphone is muted and no longer works, interestingly the level on the pulse is displayed where it stopped.

EG: If counting and the UV level in pulse was 50% then it will stay there even though no audio is comming in..

Any ideas guys and girls.. Would like to use this headset for work.


Found in Pulse it works for a few seconds then if you open a Voip program set the mic to the IEC microphone then it will work correctly.

azche 12-12-2012 02:39 PM

Hi Michael, did you get this to work? I got Audio & Mic ok with pulse but nothing happens with the controls.

MichaelCole 12-12-2012 06:10 PM

Yes i did get it to work correctly, If the Pulse says only Analog selections you will need a restart, otherwise select the mic and the speakers, the audio i have found is low in volume, but does work.

You also have to have a program such as your VOIP program running a call to test the microphone, as it will be muted while not in use.

If you need more help tell me more.

jbroege 08-08-2014 04:45 PM

Similar Issue
I run a call center in the Philippines. The issue that I have is that on Ubuntu and Linux Mint, if I hit the Mic mute, I will not be able to unmute the headset until I restart the computer. That's whether I try to re-enable it in the audio manager or try to use the button again. Other builds I have tried, the buttons simply don't function which is actually more preferable. Volume up and down also do not function.

The ideal situation would be if it worked completely. Mic mute, Volume up/Volume Down, and maybe even the light on the mute. Please let me know if anyone has a solution.

Next operating system I will be trying is going to be Debian.

MichaelCole 08-09-2014 10:09 PM

Same bug for me I have not tried to fix trying to make some money currently.. Now Drop me a line maybe we can work together, I Know I can just not tried.. :( I'm in Makati.. If you want to meet up discuss a fix.. What you really need.

All times are GMT -5. The time now is 11:09 AM.