LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 02-18-2007, 06:51 PM   #1
FredL2
Member
 
Registered: Feb 2005
Location: Uppsala, Sweden
Distribution: Arch Linux
Posts: 30

Rep: Reputation: 15
pitched down sound with intel AC'97(ICH-4)


Hi!
I have an AC97 sound card integrated on my laptop (HP nc6000)
The distribution is arch linux v 0.8(Voodoo)
lcpci output:
Code:
--snip--
00:1f.5 Multimedia audio controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Audio Controller (rev 03)
--snip--
uname-a output:
Code:
Linux karin 2.6.19.2 #9 Sun Feb 18 16:52:23 CET 2007 i686 Intel(R) Pentium(R) M processor 1.50GHz GenuineIntel GNU/Linux
When I play movie files/music files with any application, depending on the sample rate of the clips, the sound is pitched down, almost like a tape running slow. Playing through JACK doesn't help. I suspect it's a problem with the drivers not knowing the sample rate limits of my sound chipset.
Anyone else experiencing this with this kernel release?
 
Old 02-19-2007, 02:42 PM   #2
ststroud
LQ Newbie
 
Registered: May 2006
Location: Greenville
Distribution: Slackware 11
Posts: 12

Rep: Reputation: 0
are you using the latest alsa drivers?
 
Old 02-20-2007, 07:56 AM   #3
FredL2
Member
 
Registered: Feb 2005
Location: Uppsala, Sweden
Distribution: Arch Linux
Posts: 30

Original Poster
Rep: Reputation: 15
Using the 2.6.19.2 included drivers. It's been working before while using 2.6.14.7.
 
Old 02-20-2007, 08:15 AM   #4
xflow7
Member
 
Registered: May 2004
Distribution: Slackware
Posts: 215

Rep: Reputation: 45
Are you loading the sound driver as a module? If so and you're using ALSA, I know some of the drivers have module options related to AC97 clock rate. I recommend you look at

/usr/src/linux/Documentation/sound/alsa/ALSA-Configuration.txt

and have a search for the option ac97_clock.

You'll see that it crops up in multiple drivers intended for AC97 chipsets.

The default is for the driver to auto-detect the clock rate, but supposedly you can force it with that parameter.

If you want to try playing with it and the module your hardware uses supports it, you'd want to add a line like:

Code:
options <module-name> ac97_clock=<some value>
to one of the files in /etc/modprobe.d/ or if you don't have that directory then to the file /etc/modprobe.conf
 
Old 02-24-2007, 06:10 PM   #5
FredL2
Member
 
Registered: Feb 2005
Location: Uppsala, Sweden
Distribution: Arch Linux
Posts: 30

Original Poster
Rep: Reputation: 15
OK! I'll try different values on ac97_clock and see what happens.
It's a really strange problem since autodetection has worked before without any problems. Perhaps they've replaced the codec chip with a new one which runs at a different clockrate, but identifies itself as the older chip, therefore forcing the driver maintainer to update the driver to be compatible with the newer chip rather than the old one. That's a theory...
 
Old 02-24-2007, 06:20 PM   #6
FredL2
Member
 
Registered: Feb 2005
Location: Uppsala, Sweden
Distribution: Arch Linux
Posts: 30

Original Poster
Rep: Reputation: 15
Strange... only building it as a module rather than into the boot image seems to have fixed this... perhaps a bug to report to the alsa developers.
 
Old 02-24-2007, 06:50 PM   #7
Electro
LQ Guru
 
Registered: Jan 2002
Posts: 6,042

Rep: Reputation: Disabled
I recommend do not compile ALSA from the kernel, but compile the code from ALSA site instead. Make sure soundcore is set as module. It is always recommended to compile sound as modules. Posting a bug report to ALSA about compiling their code as modules will be useless because they already know this.

Found out what clock is needed and email the ALSA developer or post a bug report about your information. You will need to be detailed because on-board sound uses PHY compatible chips.

The ALSA version can be extracted by doing "cat /proc/asound/version" but only if procfs is selected before compile time and proc is mounted. I do not know sysfs.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
No sound in Gentoo with Intel AC'97 audio lintnuts Linux - Hardware 16 12-14-2008 02:04 PM
Intel Sound Card won't work on RedHat 9 (82801BA/BAM AC'97) StaticSage Red Hat 3 06-08-2006 09:05 PM
PCI Intel AC'97 sound card and RH 9 ? kandyco Linux - General 1 09-04-2004 06:36 AM
Kernel 2.6.6 - Sound Problem - Intel 82801DB AC'97 slack_baby Linux - Hardware 2 05-25-2004 08:46 AM
Sound problems with RH8 + Intel 82801DB AC'97 Audio jaakjr Linux - Hardware 8 11-05-2002 12:28 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 09:07 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration