LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (https://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   Philips Widescreen Monitor Woes (https://www.linuxquestions.org/questions/linux-hardware-18/philips-widescreen-monitor-woes-88533/)

Jeriko 09-02-2003 03:25 PM

Philips Widescreen Monitor Woes
 
I have a Philips 170W4 widescreen 1280x768 resolution monitor that I'm having a very hard time getting to work properly under SuSE 8.2 / KDE. I should mention that I'm a total newbie to Linux, and have just learned how to open up and edit the XF86Config file so this is probably where the answer lies.

I suspect I need a Modeline for it. I tried the modeline generator at xtiming.sourceforge.net but it for the monitor's recommended mode of 1280x768 @ 60Hz I was getting a Dot rate of over 79MHz, over the monitor's maximum of 75MHz.

The full specs of my monitor are in this PDF(I'm leaving out the www and all because I'm new and can't post URL's)

consumer.philips.com/global/b2c/ce/catalog/assets/downloads/170w4p_us_lft.pdf


Ho do I get this monitor working at its full resolution? The only thing I can manage is 1024x768. There's no option of 1280x768 under the Monitors / LCD tab.

-J

Jeriko 09-02-2003 04:11 PM

One other question - can I "force" the 79.75MHz dot rate that I'm getting on the generator down by simply typing in my monitor's maximum of 75 instead? I'm not really sure what the limits of change to those generated modelines are.

For example, I'm getting:

"Modeline "1280x768@60" 79.75 1280 1312 1608 1640 768 783 791 807

Horizontal sync frequency: 48.62 kHz"

Can I just change it to:

"Modeline "1280x768@60" 75 1280 1312 1608 1640 768 783 791 807


Horizontal sync frequency: 48.62 kHz"

or would that 75 necessitate the need for the other numbers there to change somehow?


-J

Jeriko 09-02-2003 04:34 PM

All right, I got it working but the best I can do is 1280x768@56Hz. I just editted out the 79.75 and replaced it with 75.

Modeline "1280x768@60" 79.75 1280 1312 1608 1640 768 783 791 807

to

Modeline "1280x768@60" 75 1280 1312 1608 1640 768 783 791 807

Philips recommends using the monitor at 1280x768@60 though. Not knowing much about monitor rates, is this risking damage tot he monitor in any way? My only other option seems to be to exceed the dot rate of 75MHz and push it to 79.75. I don't know which is preferable.

-J

faheyd 09-05-2003 01:04 AM

Your choices are dependent on your tolerance to risk, and of course, your extended warranty.

zafod 07-05-2004 05:46 PM

Phillips Widescreen Monitor 170W4
 
I tried the xmode command like this:

$ xmode -x 1280 -y 768 -r 60
46
58
Modeline "1280x768" 77.37 1280 1344 1480 1680 768 769 772 794

Then I changed the 3rd field to 75 (the monitor's dot clock).
Everything looks superb except that the top 4 or so pixels are off the top of the screen. I know you can't just change the dot clock without adjusting the other numbers (base resolution plus back/front port) but I haven't been able to find this stuff in any documentation from Phillips.
But it's pretty close.

faheyd 07-05-2004 10:50 PM

/usr/X11/bin/xvidtune
 
Try /usr/X11/bin/xvidtune and see if you can fine tune it. Right down the settings that work after testing, and put them in your /etc/X11/XF86Config-4 file (or similar) to permanently use them.

Correct above statement: "Right down" change to "Write down"

Darn English language gets me when I'm not paying close attention to detail!

zafod 07-06-2004 12:44 PM

Many thanks, that's done the trick. I clicked the "move down" button twice. As far as I can tell the following modeline gives a perfect display:

Modeline "1280x768" 75.00 1280 1344 1480 1680 768 769 772 802


All times are GMT -5. The time now is 01:19 PM.