LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 02-11-2005, 08:05 PM   #1
Jake_da_Snake
LQ Newbie
 
Registered: Jan 2004
Posts: 23

Rep: Reputation: 15
philips 7130 pci tuner card


I got a philips 7130, but I cant load the right driver for it.
in mandrake 10.1 with kernel 2.6.8 it loads saa7134 module for it. I have /dev/vide0...but cat /dev/video0 > /tmp/test.mpg gives this error
>> input/output error.
When I run kdetv or xatv everything goes black... it doesn't lock up because I can reboot with ctrl+alt+del.
I run scantv it says no station. I am in the US and use ntsc tv.
I run into the exact same thing with fedora core 3 on kernel 2.6.10. It loads the apparent right module but when I run kdetv everything goes black.

I compiled gentoo with kernel 2.6.10. things dont go black anymore but i get no channel.
Am I missing something here, isn't the saa7134 module supposed to work with 7130 models?
Or am I missing something on the configuration....the card works fine on windows environment so I know its not the card.
 
Old 02-11-2005, 09:29 PM   #2
Electro
LQ Guru
 
Registered: Jan 2002
Posts: 6,042

Rep: Reputation: Disabled
The Philips 7130 tells us nothing except the chip model. Gives us more information like the brand and model of the video capture card, dmesg, etc.
 
Old 02-11-2005, 10:42 PM   #3
Jake_da_Snake
LQ Newbie
 
Registered: Jan 2004
Posts: 23

Original Poster
Rep: Reputation: 15
what can I say, I dont really know the manufacturer. This is where I bought it. On my box says SBT-TVFM..here is the link where I bought it from.
http://www.censuspc.com/Merchant2/me...Category_Code=

and here is dmesg

Linux video capture interface: v1.00
saa7134: Unknown parameter `radio'
saa7130/34: v4l2 driver version 0.2.12 loaded
ACPI: PCI interrupt 0000:01:08.0[A] -> GSI 18 (level, high) -> IRQ 18
saa7130[0]: found at 0000:01:08.0, rev: 1, irq: 18, latency: 32, mmio: 0xec004000
saa7134: <rant>
saa7134: Congratulations! Your TV card vendor saved a few
saa7134: cents for a eeprom, thus your pci board has no
saa7134: subsystem ID and I can't identify it automatically
saa7134: </rant>
saa7134: I feel better now. Ok, here are the good news:
saa7134: You can use the card=<nr> insmod option to specify
saa7134: which board do you have. The list:
saa7134: card=0 -> UNKNOWN/GENERIC
saa7134: card=1 -> Proteus Pro [philips reference design] 1131:2001 1131:2001
saa7134: card=2 -> LifeView FlyVIDEO3000 5168:0138 4e42:0138
saa7134: card=3 -> LifeView FlyVIDEO2000 5168:0138
saa7134: card=4 -> EMPRESS 1131:6752
saa7134: card=5 -> SKNet Monster TV 1131:4e85
saa7134: card=6 -> Tevion MD 9717
saa7134: card=7 -> KNC One TV-Station RDS / Typhoon TV Tune 1131:fe01 1894:fe01
saa7134: card=8 -> Terratec Cinergy 400 TV 153b:1142
saa7134: card=9 -> Medion 5044
saa7134: card=10 -> Kworld/KuroutoShikou SAA7130-TVPCI
saa7134: card=11 -> Terratec Cinergy 600 TV 153b:1143
saa7134: card=12 -> Medion 7134 16be:0003
saa7134: card=13 -> Typhoon TV+Radio 90031
saa7134: card=14 -> ELSA EX-VISION 300TV 1048:226b
saa7134: card=15 -> ELSA EX-VISION 500TV 1048:226b
saa7134: card=16 -> ASUS TV-FM 7134 1043:4842 1043:4830 1043:4840
saa7134: card=17 -> AOPEN VA1000 POWER 1131:7133
saa7134: card=18 -> BMK MPEX No Tuner
saa7134: card=19 -> Compro VideoMate TV 185b:c100
saa7134: card=20 -> Matrox CronosPlus 102b:48d0
saa7134: card=21 -> 10MOONS PCI TV CAPTURE CARD 1131:2001
saa7134: card=22 -> AverMedia M156 / Medion 2819 1461:a70b
saa7134: card=23 -> BMK MPEX Tuner
saa7134: card=24 -> KNC One TV-Station DVR 1894:a006
saa7134: card=25 -> ASUS TV-FM 7133 1043:4843
saa7134: card=26 -> Pinnacle PCTV Stereo (saa7134) 11bd:002b
saa7134: card=27 -> Manli MuchTV M-TV002
saa7134: card=28 -> Manli MuchTV M-TV001
saa7134: card=29 -> Nagase Sangyo TransGear 3000TV 1461:050c
saa7134: card=30 -> Elitegroup ECS TVP3XP FM1216 Tuner Card( 1019:4cb4
saa7134: card=31 -> Elitegroup ECS TVP3XP FM1236 Tuner Card 1019:4cb5
saa7134: card=32 -> AVACS SmartTV
saa7134: card=33 -> AVerMedia DVD EZMaker 1461:10ff
saa7134: card=34 -> Noval Prime TV 7133
saa7134: card=35 -> AverMedia 305 1461:2115
saa7134: card=36 -> UPMOST PURPLE TV 12ab:0800
saa7134: card=37 -> Items MuchTV Plus / IT-005
saa7130[0]: subsystem: 1131:0000, board: UNKNOWN/GENERIC [card=0,autodetected]
saa7130[0]: board init: gpio is c000
saa7130[0]: Huh, no eeprom present (err=-5)?
saa7130[0]: registered device video0 [v4l2]
saa7130[0]: registered device vbi0


I have removed the modules and readded it with card=1 and card=10, none worked.
but here is the thing when I run kdetv or xawtv everything goes blank. like there is something wrong with my output configuration or something, and even ctrl+alt+bkspace wont get u back. It's just like when u connect ur video card to ur tv..how your monitor turns itlsef off. this card has s-video out and av in, wheather it has anything to do with it or not.
thanks for the reply
 
Old 02-12-2005, 03:54 PM   #4
Jake_da_Snake
LQ Newbie
 
Registered: Jan 2004
Posts: 23

Original Poster
Rep: Reputation: 15
well it was the kernel 2.6.8
2.6.10 has support for it, I had to load modprobe saa7134 card=42
anyhow, my kdetv is in black and white now and the page is in two pieces and the top piece is at the bottom of the page. must be the configuration, because xawtv works fine. What am i supposed to use for the video plugin? x11 or xvideo...?

how do u search for channels automaticly on mythtv? anyone knows?
 
Old 02-12-2005, 05:38 PM   #5
Electro
LQ Guru
 
Registered: Jan 2002
Posts: 6,042

Rep: Reputation: Disabled
XVideo is better than X11, but use X11 if XVideo does not work.

Sorry, I do not use MythTV. I use TvTime.
 
Old 02-19-2005, 10:16 AM   #6
digitalb0y
Member
 
Registered: Mar 2003
Distribution: GenMyth
Posts: 36

Rep: Reputation: 15
Quote:
how do u search for channels automaticly on mythtv? anyone knows?
if your in N.Amercia you use DataDirect and it automaticaly downloads tv-channels and listings to sett this up check out this link-> http://www.mythtvtalk.com/forum/view...ghlight=zap2it
Then put the info in mythsetup

For other countries you'll use XMLTV
you will need to run to setup the country
mythfilldatabase --configure
many European contries are setup and ready to go, but some aren't and you will need to sett it up manualy by channel frequencies
 
Old 02-21-2005, 04:57 PM   #7
smith847be
Member
 
Registered: Jun 2003
Location: Hanover, New Hampshire, USA
Distribution: Debian Sid (Unstable)
Posts: 143

Rep: Reputation: 15
How well does the card work? I can't find many references besides this thread on here as to Linux compatibility. I'm thinking of buying it, considering that it's cheap and has gotten decent reviews. Does the remote work and such?
 
Old 02-22-2005, 06:41 PM   #8
digitalb0y
Member
 
Registered: Mar 2003
Distribution: GenMyth
Posts: 36

Rep: Reputation: 15
I wouldn't recomend any card that uses the saa7134 chipset like the above card, these cards have lots sound issues.

I would recommend haupauge cards they work great and are supported well with the linux community. i.e. WinTv PRV-350
 
Old 02-22-2005, 09:49 PM   #9
Electro
LQ Guru
 
Registered: Jan 2002
Posts: 6,042

Rep: Reputation: Disabled
digitalb0y, no the SAA713x do not have sound issues if you use kernel version 2.6.10 or higher. I used mencoder with no problems.
 
Old 02-22-2005, 11:55 PM   #10
smith847be
Member
 
Registered: Jun 2003
Location: Hanover, New Hampshire, USA
Distribution: Debian Sid (Unstable)
Posts: 143

Rep: Reputation: 15
Alright, thanks guys. The only reason I don't like the Hauppage cards is that they're double the price for the same features. I update my kernel fairly often, so that's not an issue.
 
Old 02-26-2005, 12:01 AM   #11
digitalb0y
Member
 
Registered: Mar 2003
Distribution: GenMyth
Posts: 36

Rep: Reputation: 15
Well the sound doesn't work well for the saa7134 by default most distros don't yet use 2.6.10 yet,
for example:
Fedora Core 3 : 2.6.9
Mandrake 10.1: 2.6.3
Slackware 10: 2.4.29
Ubuntu 4.10: 2.6.8.1
Suse: 2.6.8
but Electro thanks for telling us the newest stable kernel works if compiled.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
PHILIPS SAA7130 tuner card in Knoppix? drewbysan Debian 3 06-06-2009 10:18 AM
I'd like to use my Pinnacle pctv stereo/Philips SAA7134 tuner card... noware Linux - Hardware 8 09-26-2006 09:51 AM
philips 7130 tv-card greenthing Linux - Hardware 2 09-08-2005 10:15 PM
Philips 7134 based TV tuner card uses V4L interface? Thymox Linux - Hardware 7 07-16-2003 06:39 PM
How to config the philips saa7134 based tv tuner card kinhungw Linux - Hardware 0 12-21-2002 08:04 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 09:58 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration