LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (https://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   "permission denied" when I try to send raw data to the sound device. (https://www.linuxquestions.org/questions/linux-hardware-18/permission-denied-when-i-try-to-send-raw-data-to-the-sound-device-109739/)

Travis86 10-28-2003 10:57 PM

"permission denied" when I try to send raw data to the sound device.
 
Ultimately, I'd like to use the fiber optic sound output from my Playstation 2 as the outgoing network cable. I figure it might be a little strange, but with the right bunch of adapters, it ought to be really fast. Right now I'm trying to route data to the sound device from the command line. I don't really care if it sounds scratchy and harsh. I just want the data to be sent to the speakers. I looked in /dev and found "audio" and "audio1", then I tried echo "hello" > /dev/audio , but it said permission was denied. I changed the permissions, but it still wouldn't work.

Is there some way I can do this?

h/w 10-29-2003 12:46 AM

you werent allowed to do that as root either?
and u werent able to change the permissions of it as root either?

Travis86 10-29-2003 10:08 AM

I tried 'sudo "hello" > /dev/audio' and it said that the device didn't exist. I don't know why I had to use sudo, but I looked the documentation and they said that the sound device was /dev/dsp . "cat mysqlbug > /dev/dsp" makes a lot of racket.


All times are GMT -5. The time now is 03:50 PM.