LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (https://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   Pegasus: Unknown symbols on 2.6.6 kernel (https://www.linuxquestions.org/questions/linux-hardware-18/pegasus-unknown-symbols-on-2-6-6-kernel-187251/)

lrt2003 05-29-2004 04:14 AM

Pegasus: Unknown symbols on 2.6.6 kernel
 
Hello! I tried compiling the pegasus module --- 2.6.6 for a 486 CPU (but I have a PIII, it is just like that :( ... with nosmp (otherwise error))

I get this at startup (loaded with /etc/modprobe.conf - alias eth1 pegasus)

pegasus: Unknown symbol usb_alloc_urb
pegasus: Unknown symbol mii_ethtool_sset
pegasus: Unknown symbol usb_free_urb
pegasus: Unknown symbol mii_link_ok
pegasus: Unknown symbol usb_register
pegasus: Unknown symbol usb_put_dev
pegasus: Unknown symbol usb_get_dev
pegasus: Unknown symbol usb_submit_urb
pegasus: Unknown symbol usb_deregister
pegasus: Unknown symbol mii_nway_restart
pegasus: Unknown symbol usb_unlink_urb
pegasus: Unknown symbol mii_ethtool_gset

thx for any help
(my google search = http://www.google.com.au/linux?hl=en...e+Search&meta=)
john

lrt2003 05-30-2004 12:24 AM

blatent bump

I tried compiling in a lot more networking/usb/misc stuff into the kernel and now I get unknown symbols in ochi_hcd too.......

I must be compiling the modules wrongly, or something.. some ideas/help, please?

lrt2003 05-30-2004 12:36 AM

Ok, feel free to hit me.. I forgot to "lilo" to update the lilo.conf.. it was still running on the old kernel...

:D , we all make mistakes.. just look at all of our children :)

funnyG 06-14-2004 06:14 AM

Hello,

have you been able to activate your network card? I am using Slackware 9.0 and I have a USB "Teledat Fast Ethernet" card which uses the module pegasus. This network card has been detected and activated at boot time automatically by Suse, Redhat and Mandrake. However, I can't get it work under Slackware. The module 'pegasus' is loaded with no problems, also the usb modules are all correct. But when I type 'ifconfig eth0 up', nothing happens. I even recompiled the kernel with the drivers built into it. The card is detected, no problem. But the light of the card doesn't blink.

Could you please tell me how you've been able to manage to get this card up and running? Many thanks in advance.

lrt2003 06-14-2004 08:47 AM

yes, pegasus works fine.. I'm on the internet now!

no worries.. here we go!

1st: try using eth1 instead.

2nd: try editing /etc/resolv.conf - put in
search [yourdomain.com]
nameserver xxx.xxx.xxx.xxx
nameserver xxx.xxx.xxx.xxx - sub these with your nameserver values (even dynamic IPs have these) - contact your isp for these if you don't know them, or if you have a windows comp, use that to figure them out (windows has its uses)

and then /etc/rc.d/rc.inet1.conf

[leave every other option blank]

dhcp="yes" for eth0 (and maybe eth1 - try both - then figure out which it uses, then delete other)

then reboot

should work.

-john


All times are GMT -5. The time now is 04:37 AM.