-   Linux - Hardware (
-   -   PCMCIA WiFi Card that works (

vargadanis 11-25-2006 11:48 AM

PCMCIA WiFi Card that works
Hi all,

I am looking for a PCMCIA or USB Wifi card for my Ubuntu box on an Acer notebook with bcmwl4318 builtin chipset. It is not suppoerted yet so I decided not to suck with fwcutter and ndiswrapper but choose the easier sollution and buy a WiFi card that works with linux for sure. Any suggestions??

Thanx Dani

g0es 11-25-2006 11:55 AM

I have had good luck with the Proxim orinoco abg gold card model 8480-FC. It uses the atheros drivers. I have also had good luck with the Cisco abg pcmcia card, not sure on the model, but it did use the atheros chipset as well.

Lenard 11-25-2006 11:59 AM

The wireless Broadcom 4318 is supoorted but not by the broken bcm43xx module, this is known problem and they are working on it.

Blacklist the bcm43xx module and use ndiswarpper with the Windows driver as suggested by the known working card list. The fwcutter tool is not needed.
Just do a 'find' on 4318 here;

vargadanis 11-25-2006 12:10 PM

I would use the windows driver but I do not have it. And what is even more funny I could not download it from anywhere. Tried on acers website,, broardcom's website and I tried to download some other drivers and use fwcutter to get the bcmwl5.inf and sys files that are needed without any succes. If you could give me a hint how to get these files I would be very glad and I could go on trying to get my card working. If you feel like sending it to me via mail that would be also great. vargadanis @ gmail . com is my address.

Lenard 11-25-2006 01:22 PM

Direct links;



I use the 64-bit (ferrari) driver myself;

$ uname -a
Linux Aspire5000 2.6.19-rc6-git4 #2 SMP Tue Nov 21 11:55:02 EST 2006 x86_64 x86_64 x86_64 GNU/Linux

$ ndiswrapper -l
installed drivers:
bcmwl5 driver installed, hardware (14E4:4318) present

$ ndiswrapper -v
utils version: 1.9
driver version: 1.28
vermagic: 2.6.19-rc6-git4 SMP mod_unload

vargadanis 11-25-2006 02:15 PM

Thx!! No my network card is working well. When restarting the system the led of the wlan card was on and it seemed to be ok.
Eh... I know that this topic wasn't primarily created for troubleshooting but I cannot bring it on. I used this tutorial:
It should work now ok but it doesn't. I use network manager-gnome package to get the interfaes working but I cannot see it. Is it possible that the nediswrapper or bcmwl kernel modul is in blacklist or something? What shall I do now that my hardware is working with my system I just cannot configure it?

Lenard 11-25-2006 07:47 PM

Caveat, I'm not a Ubuntu user but after checking;

leads to:

Which seems a bit more detailed. And the Ubuntu forum here at is a good place to ask for help.

All times are GMT -5. The time now is 09:23 PM.