-   Linux - Hardware (
-   -   PCMCIA USB2 card with DVD USB witer -- It Works (

1kyle 02-14-2004 07:03 PM

PCMCIA USB2 card with DVD USB2 writer -- It Works
Hello everybody -- I've given up on PCMCIA Wireless for the while -- but very nice surprise that the Belkin usb2 pcmcia works STRAIGHT OUT OF THE BOX !!!! on SUSE 9.0

(Belkin 2 port USB2 CARDBUS (PCMCIA) card)

Picture of the card


I plugged in to the USB2 card an IOMEGA MULTI DVD drive -- works fine and can write / read DVD-RAM with ext2 or VFAT file systems -- haven't tried writing to DVD+RW yet -- but I'll do that tomorrow.

This means I can use this DVD writer on a laptop :)

DVD RAM was fine with mke2fs /dev/sr1

DVD+RW I'll test with DVD+RW tools -- reading is no problem.

My USB2 external MAXTOR disk drive also worked.

(for the wireless problem I might try a USB wireless card in the 2nd USB2 slot !!!!!!!!!)

One up to SUSE 9.0 for this ( I got the USB2 PCMCIA card since my laptop only had USB1.1 which was too slow for the disk drive or the DVD burner

Now my external disk is really "portable" between systems and I can share the DVD writer between laptops as well with the card.

Nice to report that something WORKS STRAIGHT OUT OF THE BOX - no drivers needed.

Edited -- lot of typos -k

Geoff_Mac 05-05-2004 02:51 PM

Ok, so how come it works for you?

Ithis is what I have:
Toshiba Satellite 2060 CDS using Carbus/16 option in BIOS
Belkin F5U222 - 2 port Cardbus
Ikebana DVD-RW

SuSE 9.0 Pro using kernel modules (not external)

I have:
usbserial loaded during the boot sequence

cat /proc/scsi/scsi
Attached devices: none

cat /proc/scsi/usb-storage-0/0 reveals:
Host scsi0: usb-storage
Vendor: In-System Design
Product: USB Storage Adapter
and so on....

If I disconnect and reconnect the usb cable and check dmesg I see
USB disconnect....
hub.c: new USB device 15:00.2-2, assigned address 5
WARNING: USB Mass Storage data integrity not assured
USB Mass Stroage device found at 5

So, I think the hardware is being detected.

But what is the device to mount? I've been pouring over others problems and see it should be sda1, sr0, scd - I've tried them all with no luck.
How does one address a USB device hanging off a cardbus USB hub?
Am I stark raving mad for trying bleeding edge hardware? (yes I am)

I've tried the Belkin card with and without the 5VDC power supply and it seems to make no difference.

Any help would be greatly appreciated - I'm not a newbie - but I'm also not a hardware guru either.

Geoff_Mac 05-05-2004 07:44 PM

Now I'm totally confused.

I needed to transfer some pictures from a camera so I plugged in my usb1.1 port to the camera - and did my usual download. BUT the device I used was sda1 which is the usual one I've used in the past. Which leads me to believe that the device for the dvd off the usb hub must be something else - anyone have a clue what it might be? Is the hub even considered a "scsi" device?

Geoff_Mac 05-05-2004 09:03 PM

I am wondering - is the Ikebana USB 2.0 DVD player supported in Linux?
Can't seem to find any mention of drivers for it on the web. Anyone know where I could find a list of supported USB DVD drives?

Geoff_Mac 05-05-2004 09:16 PM

And one final note for the day...

I tried the camera in the USB hub and it worked seamlessly. (using sda1)
So - the ikebana drive works fine (albeit too slowly) on the built in USB 1.1 connection. Why doesn't it work seamlessly on the USB 2.0 hub?

spartan263 05-14-2004 03:53 AM

Belkin PN F5U222
I am using FC1, but the same principles should apply. My experience with Belkin PN F5U222 is located under: > Hardware Compatibility List > I/O Controller Devices > Belkin

(Always a Newbie)

All times are GMT -5. The time now is 11:43 PM.