LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 01-24-2008, 11:34 PM   #16
gforceg
LQ Newbie
 
Registered: Jan 2008
Posts: 13

Original Poster
Rep: Reputation: 0
Question


root@darkstar:/home/greg# cat /proc/asound/card0/codec#* | grep Codec
Codec: Realtek ALC268
Codec: Motorola Si3054

I have /etc/modprobe.conf. but look at this,

root@darkstar:/home/greg# ls /etc/modprobe.d
blacklist isapnp modprobe.conf sound


no alsa-base, but another modprobe.conf. and whats this 'sound'?

root@darkstar:/home/greg# cat /etc/modprobe.d/sound
alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-hda-intel



I tried all 3 combinations of the, 'options snd-hda-intel model=' statement. that was in /etc/modprobe.conf. I'll try 'sound' and if that doesn't work /etc/modprobe.d/modprobe.conf.

Anyway, I can't for the life of me understand how the fix would be this simple... here's to hopin!
 
Old 01-25-2008, 01:32 AM   #17
aus9
LQ 5k Club
 
Registered: Oct 2003
Location: Australia
Distribution: Devuan
Posts: 5,476

Rep: Reputation: Disabled
um I can not see your contents of modprobe.conf...but the link says its ok not to have the alsa file.

so insert in turn the following lines into /etc/modprobe.conf there are 4 to try.

options snd-hda-intel model=3stack
options snd-hda-intel model=toshiba
options snd-hda-intel model=acer
options snd-hda-intel model=auto

2) the alias are normally ok but you have 2 and I only have in modprobe.conf
alias sound-slot-0 snd_emu10k1....so make a backup of the current file then
as its only sound that is playing up you have nothing to lose to try each new hdaintel line with a reboot but change your alias lines by deleting snd-card and keep the sound-slot


3) Can you be more explicit...are you saying you have
/etc/modprobe.conf
/etc/modprobe.d/modprobe.conf

one might be a symbolic link to the other.

ls -l /etc/....blah blah to test both pls

BTW I have /etc/modprobe.d....but it has no modprobe.conf

I wonder, if I am reading you correctly, you have 2 conf files that don't know if they are arthur or matha? ...I am suggesting....disable the read write permissions to any conf file sitting in /etc/modprobe.d/ pls

Last edited by aus9; 01-25-2008 at 01:39 AM.
 
Old 01-25-2008, 09:33 AM   #18
gforceg
LQ Newbie
 
Registered: Jan 2008
Posts: 13

Original Poster
Rep: Reputation: 0
YUP
greg@darkstar:~$ ls -l /etc/modprobe.d/
total 24
-rw-r--r-- 1 root root 6337 2007-05-19 00:11 blacklist
-rw-r--r-- 1 root root 356 2007-05-17 15:16 isapnp
lrwxrwxrwx 1 root root 16 2008-01-13 08:53 modprobe.conf -> ../modprobe.conf
-rw-r--r-- 1 root root 280 2008-01-25 08:20 modprobe.conf~
-rw-r--r-- 1 root root 99 2008-01-25 08:34 sound
-rw-r--r-- 1 root root 64 2008-01-25 08:11 sound~

root@darkstar:/home/greg# cat /etc/modprobe.conf
# /etc/modprobe.conf (old location for Linux 2.6+ config)
#
# The use of this config file is deprecated.
# Instead, create files in the /etc/modprobe.d/ directory
# containing modprobe options.
#
# For more information, see "man modprobe.conf".

"create files in the /etc/modprobe.d/ directory containing modprobe options."

So I think I should be editing /etc/modprobe.d/sound

I'll try this before doing the realtek driver thing.

Last edited by gforceg; 01-25-2008 at 09:43 AM.
 
Old 01-25-2008, 10:29 AM   #19
gforceg
LQ Newbie
 
Registered: Jan 2008
Posts: 13

Original Poster
Rep: Reputation: 0
I tried all 4 "options" statements in /etc/modprobe.d/sound. But my computer continues to silently mock me.

Next I installed the realtek driver. The driver added two more faders under alsamixer / kmix. in kmix they are listed as output's 'mic boost' and 'front mic boost'. still no sound, still no led for pcm in alsamixer or kmix.

This is frustrating. I'll read the rest of these threads after I've cooled off a bit.

http://bbs.archlinux.org/viewtopic.php?pid=275445

http://ubuntuforums.org/showthread.php?t=558069

In the mean time, thanks for your help I really do think that I'm closer to getting it, and if you have any idea's let me know. I'll post the solution on here if I ever find it.

Last edited by gforceg; 01-25-2008 at 10:36 AM.
 
Old 01-25-2008, 10:59 AM   #20
gforceg
LQ Newbie
 
Registered: Jan 2008
Posts: 13

Original Poster
Rep: Reputation: 0
okay, so I added "options snd-hda-intel model=hp" to "/etc/modprobe.d/sound " _again_ after installing the realtek driver (this file: ftp://202.65.194.212/pc/audio/realte...-4.07b.tar.bz2 , from this site: http://www.realtek.com.tw/downloads/...Audio%20Codecs )

and I can hear the moon light sonata gloriously coming through my laptops speakers.

So on my HP DV9000 w/ slackware 12, I installed the above mentioned realtek driver, and my /etc/modprobe.d/sound reads as follows:

greg@darkstar:~$ cat /etc/modprobe.d/sound
alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-hda-intel
options snd-hda-intel model=hp

Thanks for all the help aus9.
I hope this thread helps other people w/ this make / model of PC get linux running.
 
Old 01-26-2008, 07:05 AM   #21
aus9
LQ 5k Club
 
Registered: Oct 2003
Location: Australia
Distribution: Devuan
Posts: 5,476

Rep: Reputation: Disabled
if you are still following this post...thanks for showing pppl how you fixed it.

did you try to delete one of the alias lines?
 
Old 01-26-2008, 04:22 PM   #22
gforceg
LQ Newbie
 
Registered: Jan 2008
Posts: 13

Original Poster
Rep: Reputation: 0
Talking

Before installing the realtek drivers, I removed the 'options' statement from my modprobe.conf and modprobe.d/sound because I didn't think it was helping.I did not modify any of the alias statements tho.

Once I went back into modprobe.d/sound and added the options statement + rebooted, it worked like magic

It should also be noted that PCM still has no mute option, and I think thats the way it's supposed to be. I have two 'front' channels (or faders) which reflect left and right speakers that are built into the laptop, these can be muted. PCM can never be muted however... seems weird to me, but I am sorta a noob :P

Last edited by gforceg; 01-26-2008 at 04:25 PM.
 
Old 01-26-2008, 11:26 PM   #23
aus9
LQ 5k Club
 
Registered: Oct 2003
Location: Australia
Distribution: Devuan
Posts: 5,476

Rep: Reputation: Disabled
well that may be true for your specs but not mine

http://h1.ripway.com/aus9/pcm.png
 
  


Reply

Tags
audio, dv9000, hp, ich8, intel, pcm, slackware, sound


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Master Volume Control Doesn't work, only PCM does jpneron SUSE / openSUSE 3 11-11-2008 08:53 AM
Recording from PCM drauk Slackware 1 09-25-2007 03:36 PM
HP PCM 2355 , FC4, scanner wont work under sane MarkDashAbout Linux - Hardware 1 02-06-2006 11:31 AM
PCM volume control doesn't work / 5.1 Wynand1 Linux - Hardware 3 03-09-2004 06:23 PM
No PCM through ALSA wuck Linux - Software 1 11-07-2003 07:23 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 08:29 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration