LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 03-07-2004, 11:11 AM   #1
ickselglic
Member
 
Registered: Jan 2004
Posts: 90

Rep: Reputation: 15
PCI Sound Card? Last resort


I've posted here many times about how my Intel AC'97 yadda yadda onboard sound card doesn't seem to be working... It works fine in Windows. I have installed SuSE9, Redhat 9, Debian, Mandrake 9.1 and 9.2. All of them pick up the sound card and show them in Hardrake and chose the default driver but there is just simply no sound... people on here have given helpful info but nothing seems to work... Should I just break down and buy a PCI soundblaster or something and just pray that my favorite Linux (mandrake 9.1) picks it up and plays some music, or sound or something.... I want to convert fully to linux but cannot until I get this sound sitchiation under control.... Is this good advice to myself???
 
Old 03-07-2004, 11:33 AM   #2
ilikejam
Senior Member
 
Registered: Aug 2003
Location: Glasgow
Distribution: Fedora / Solaris
Posts: 3,109

Rep: Reputation: 96
Hi.

I've had a read through the thread you started trying to get your sound working.
I found this thread, where someone seems to have had the same problem, but eventually got it working. The interesting post is here:
http://www.linuxquestions.org/questi...611#post724611

If that doesn't do anything, I'd probably get a PCI card. I can recommend any Yamaha based card, as the sound quality's pretty good and support for them's excellent in Linux.

Don't forget to disable onboard sound in BIOS first.

Dave
 
Old 03-07-2004, 11:48 AM   #3
ickselglic
Member
 
Registered: Jan 2004
Posts: 90

Original Poster
Rep: Reputation: 15
Thanks for the post Dave... I tried the modprobe stuff...

[steve@localhost steve]$ insmod ac97_codec
bash: insmod: command not found
[steve@localhost steve]$ modprobe ac97
bash: modprobe: command not found
[steve@localhost steve]$
[steve@localhost steve]$ su
Password:
[root@localhost steve]# insmod ac97_codec
Using /lib/modules/2.4.21-0.13mdk/kernel/drivers/sound/ac97_codec.o.gz
[root@localhost steve]# modprobe ac97
[root@localhost steve]#

I am still a newbie and don't really understand what that is doing... One weird thing is when I go into Aumix and then to the mute menu , mute all is checked by default. And then when I uncheck it , it sets all the volume levels to 0. I then turn them all up, but it's weird that when I go into it, all the volume levels are set up but the mute all selection is checked...

I'm trying to do this without buying a new sound card... :-)
 
Old 03-07-2004, 12:15 PM   #4
ilikejam
Senior Member
 
Registered: Aug 2003
Location: Glasgow
Distribution: Fedora / Solaris
Posts: 3,109

Rep: Reputation: 96
Could you run 'lsmod' as root, and post the results (I didn't see anyone ask you to do this in the other thread - it might give some clues).

Also, could you post the output from
$ file /dev/dsp0
and
$ file /dev/mixer0

Hopefully there's something that's been missed.

Dave.
 
Old 03-07-2004, 12:19 PM   #5
ickselglic
Member
 
Registered: Jan 2004
Posts: 90

Original Poster
Rep: Reputation: 15
[steve@localhost steve]$ su
Password:
[root@localhost steve]# lsmod
Module Size Used by Not tainted
ac97 4800 0 (unused)
ac97_codec 12488 0 (unused)
sg 34636 0 (autoclean)
udf 90464 0 (autoclean)
parport_pc 25096 1 (autoclean)
lp 8096 0 (autoclean)
parport 34176 1 (autoclean) [parport_pc lp]
snd-seq-oss 31104 0 (unused)
snd-seq-midi-event 5640 0 [snd-seq-oss]
snd-seq 42608 2 [snd-seq-oss snd-seq-midi-event]
snd-pcm-oss 43556 0
snd-mixer-oss 14488 0 [snd-pcm-oss]
snd-intel8x0 21988 0
snd-ac97-codec 40160 0 [snd-intel8x0]
snd-pcm 77536 0 [snd-pcm-oss snd-intel8x0]
snd-timer 18376 0 [snd-seq snd-pcm]
snd-mpu401-uart 4396 0 [snd-intel8x0]
snd-rawmidi 17600 0 [snd-mpu401-uart]
snd-seq-device 5832 0 [snd-seq-oss snd-seq snd-rawmidi]
snd-page-alloc 7732 0 [snd-intel8x0 snd-pcm]
snd 40868 0 [snd-seq-oss snd-seq-midi-event snd-seq snd-pcm-oss snd-mixer-oss snd-intel8x0 snd-ac97-codec snd-pcm snd-timer snd-mpu401-uart snd-rawmidi snd-seq-device]
soundcore 6276 0 [snd]
nfsd 74256 0 (autoclean)
af_packet 14952 1 (autoclean)
sr_mod 16920 0 (autoclean)
floppy 55132 0
e100 56964 1 (autoclean)
nls_iso8859-1 3516 1 (autoclean)
ntfs 76812 1 (autoclean)
supermount 15296 3 (autoclean)
ide-cd 33856 0
cdrom 31648 0 [sr_mod ide-cd]
ide-scsi 11280 0
scsi_mod 103284 3 [sg sr_mod ide-scsi]
ehci-hcd 18568 0 (unused)
usb-uhci 24652 0 (unused)
usbcore 72992 1 [ehci-hcd usb-uhci]
rtc 8060 0 (autoclean)
ext3 59916 2
jbd 38972 2 [ext3]
[root@localhost steve]# /dev/dsp0
bash: /dev/dsp0: No such file or directory
[root@localhost steve]# $ file /dev/dsp0
bash: $: command not found
[root@localhost steve]# $ file /dev/mixer0
bash: $: command not found
[root@localhost steve]#



That's what I got
 
Old 03-07-2004, 12:28 PM   #6
ilikejam
Senior Member
 
Registered: Aug 2003
Location: Glasgow
Distribution: Fedora / Solaris
Posts: 3,109

Rep: Reputation: 96
Sorry, there shouldn't be '$' in front of the 'file' commands. Just run

file /dev/dsp0
and
file /dev/mixer0

You're using ALSA, so you should be using alsamixer as you volume control, not aumix.

Do

modprobe -r ac97
modprobe -r ac97_codec

then try running alsamixer

Dave
 
Old 03-07-2004, 12:35 PM   #7
ickselglic
Member
 
Registered: Jan 2004
Posts: 90

Original Poster
Rep: Reputation: 15
This is what I got so far.... Where can I find alsamixer?
 
Old 03-07-2004, 12:38 PM   #8
ilikejam
Senior Member
 
Registered: Aug 2003
Location: Glasgow
Distribution: Fedora / Solaris
Posts: 3,109

Rep: Reputation: 96
Just run

alsamixer

from a terminal
 
Old 03-07-2004, 12:42 PM   #9
ickselglic
Member
 
Registered: Jan 2004
Posts: 90

Original Poster
Rep: Reputation: 15
Everything is turned up all the way on alsamixer... Oh well... I guess i'm gonna try a new PCI card... thanks for the help.
 
Old 03-07-2004, 12:49 PM   #10
ickselglic
Member
 
Registered: Jan 2004
Posts: 90

Original Poster
Rep: Reputation: 15
I wish someone could jsut like take control over my computer...lol...
 
Old 03-07-2004, 12:50 PM   #11
ilikejam
Senior Member
 
Registered: Aug 2003
Location: Glasgow
Distribution: Fedora / Solaris
Posts: 3,109

Rep: Reputation: 96
Ah well, onboard sound cards are crap anyway......



Dave
 
Old 03-07-2004, 01:02 PM   #12
ickselglic
Member
 
Registered: Jan 2004
Posts: 90

Original Poster
Rep: Reputation: 15
Dave,

I logged out of the desktop and then logged back in and when KDE was loading it played a little sound as I was entering the desktop signaling to me that the sound was working.... Although I went to play a CD and that isn't working.... What are some ways I can test the sound?
 
Old 03-07-2004, 01:04 PM   #13
ickselglic
Member
 
Registered: Jan 2004
Posts: 90

Original Poster
Rep: Reputation: 15
Yea, it is definitely playing sounds when entering and exiting the KDE desktop.... The CD player doesn't work though and when I go to test sounds it doesn't work... interesting huh?
 
Old 03-07-2004, 01:20 PM   #14
ilikejam
Senior Member
 
Registered: Aug 2003
Location: Glasgow
Distribution: Fedora / Solaris
Posts: 3,109

Rep: Reputation: 96
Aha. Result!

OK, if you're just using the KDE CD player, then you'll have to connect the CD-ROM to the CD-IN connection on you motherboard with one of those wee cables - most CD players just tell the CD-ROM to play, and don't actually deal with the sound themselves.

If you've got xine or mplayer installed, then you should be able to play your CDs using either of them without having to bother with the CD-ROM connection.

Can you listen to .wav or .mp3 files? What program are you using to listen to audio files? There may be some configuration needed.

Also, I would take a note of the output of lsmod while your sound is working, so that when you reboot, if sound dissapears you'll have a record of the state your system was in when it did work.

Dave.
 
Old 03-07-2004, 03:12 PM   #15
ickselglic
Member
 
Registered: Jan 2004
Posts: 90

Original Poster
Rep: Reputation: 15
Well, it wasn't all working... I mean it only made sounds when entering and exiting the system. And when I go to like, events make sounds and stuff and test the wav files built in I still hear nothing... I will try playing CD through xine though.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
If you have a PCI sound card, should you disable the on-board sound card? jtp51 Linux - Newbie 1 10-06-2004 11:42 AM
Last Resort "Sound won't work! Agent_0069 Linux - Software 1 03-21-2004 03:42 PM
No Sound Solution - BUY NEW PCI Sound Card? SML Fedora 1 03-02-2004 12:12 AM
Diabling onboard sound card and enabling pci slot sound card abhatia Linux - Hardware 4 01-12-2004 03:10 AM
On board sound and PCI Sound Card certifiableone Linux - Hardware 4 06-28-2003 10:20 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 09:34 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration