LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (https://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   Paying Media-external tv- using svideo (https://www.linuxquestions.org/questions/linux-hardware-18/paying-media-external-tv-using-svideo-596988/)

flebber 11-04-2007 01:06 AM

Paying Media-external tv- using svideo
 
I am trying to play media files to my tv from my kubuntu box. I have an NVIDIA 6200 card and I am using svideo cable.

I am receiving this error.
Code:

flebber@flebber-desktop:~$ mplayer ~/Video/bourne_ultimatum.divx -vo directfb
MPlayer 2:1.0~rc1-0ubuntu13 (C) 2000-2006 MPlayer Team
CPU: Intel(R) Pentium(R) 4 CPU 2.80GHz (Family: 15, Model: 2, Stepping: 9)
CPUflags:  MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled with runtime CPU detection.
Can't open joystick device /dev/input/js0: No such file or directory
Can't init input joystick
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.

Playing /home/flebber/Video/bourne_ultimatum.divx.
AVI file format detected.
VIDEO:  [DX50]  560x240  24bpp  23.976 fps  900.2 kbps (109.9 kbyte/s)
Error opening/initializing the selected video_out (-vo) device.


Exiting... (End of file)
flebber@flebber-desktop:~$

I can get mplayer to play the file on the pc by specifying the -vo option but how can I get it to display on my tv ?

This is it with specified VO?
Code:

flebber@flebber-desktop:~$ mplayer ~/Video/bourne_ultimatum.divx -vo xv directfb
MPlayer 2:1.0~rc1-0ubuntu13 (C) 2000-2006 MPlayer Team
CPU: Intel(R) Pentium(R) 4 CPU 2.80GHz (Family: 15, Model: 2, Stepping: 9)
CPUflags:  MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled with runtime CPU detection.
Can't open joystick device /dev/input/js0: No such file or directory
Can't init input joystick
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.

Playing /home/flebber/Video/bourne_ultimatum.divx.
AVI file format detected.
VIDEO:  [DX50]  560x240  24bpp  23.976 fps  900.2 kbps (109.9 kbyte/s)
Xlib:  extension "XFree86-VidModeExtension" missing on display ":1.0".
xscreensaver_disable: Could not find XScreenSaver window.
gnome_screensaver_control()==========================================================================
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
Selected video codec: [ffodivx] vfm: ffmpeg (FFmpeg MPEG-4)

So with things still not working I added below to xorg, got content from http://gentoo-wiki.com/HOWTO_Separat...Monitor_and_TV
so from the how-to
Code:

File: /etc/X11/XF86Config or /etc/X11/xorg.conf

add a second monitor:

 Section "Monitor"
    Identifier "Monitor[0]" #CRT
    HorizSync 30-95
    VertRefresh 50-160
 EndSection
 
 Section "Monitor"
    Identifier "Monitor[1]" #TV
    HorizSync 30-95
    VertRefresh 60
 EndSection

now add your tv-out-device:

Section "Device"
  Identifier      "Device[0]"
  Driver          "nvidia"
  BusID          "PCI:01:00:00" #adjust using 'lspci' or cat /proc/pci
  Screen 0
EndSection

Section "Device"
  Driver          "nvidia"
  Identifier      "Device[1]"
  Screen 1
  Option          "TVOutFormat" "Composite" #or SVIDEO etc
  Option          "TVStandard" "PAL-G" #or NTSC, PAL-I for uk etc
  Option          "ConnectedMonitor" "TV"
  BusID          "PCI:01:00:00" #adjust using 'lspci' or cat /proc/pci
EndSection

and a second screen ..

Section "Screen"
  Identifier  "Screen[0]"
  Device      "Device[0]"
  Monitor    "Monitor[0]"
  DefaultDepth 24
  Subsection "Display"
      Depth      24
      Modes      "1600x1200"
      ViewPort    0 0
  EndSubsection
EndSection

Section "Screen"
  Device "Device[1]"
  Identifier "Screen[1]"
  Monitor "Monitor[1]"
  DefaultDepth 24
      SubSection "Display"
              Depth 24
              Modes "1024x768"
      EndSubSection   
EndSection

change your serverlayout:

Section "ServerLayout"
  Identifier  "Simple Layout"
      Screen 0 "Screen[0]"
      Screen 1 "Screen[1]" RightOf "Screen[0]"
  InputDevice "Mouse1" "CorePointer"
  InputDevice "Keyboard1" "CoreKeyboard"
EndSection

Code:

programs can be easily opened, by:

$ DISPLAY=:0.1 mplayer bla.avi

If you want it to be easier to play tvout, you can add this to your ~/.bashrc

alias tv="DISPLAY=:0.1 mplayer -fs"

This make tvout very simple to fire up. Just:

$ tv file.avi

But then the old chestnut returns
Code:

flebber@flebber-desktop:~$ DISPLAY=:0.1 mplayer ~/Video/bourne_ultimatum.divx
MPlayer 2:1.0~rc1-0ubuntu13 (C) 2000-2006 MPlayer Team
CPU: Intel(R) Pentium(R) 4 CPU 2.80GHz (Family: 15, Model: 2, Stepping: 9)
CPUflags:  MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled with runtime CPU detection.
Can't open joystick device /dev/input/js0: No such file or directory
Can't init input joystick
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.

Playing /home/flebber/Video/bourne_ultimatum.divx.
AVI file format detected.
VIDEO:  [DX50]  560x240  24bpp  23.976 fps  900.2 kbps (109.9 kbyte/s)
vo: couldn't open the X11 display (:0.1)!
Error opening/initializing the selected video_out (-vo) device.


Exiting... (End of file)

Even if i then specify the vo option its stil errors the same.

lazlow 11-04-2007 01:33 AM

In your xorg example you have it set to Composite but you say that you are using SVIDEO. They need to match.

I THINK on most of these cards you can only go with 800x600 (or below) over SVIDEO.

flebber 11-04-2007 03:59 AM

Well spotted, do you use Mplayer to play to tv out, or have you found a better way?

lazlow 11-04-2007 12:05 PM

I switch the output(desktop) over to the tv and play vids on VLC.

flebber 11-04-2007 05:59 PM

I can get a video playing in small size using mplayer commands from the command line. But if I could see my desktop on the tv I could then play video's at full resolution

I started to follow the how-to http://ubuntuforums.org/showthread.php?t=98456&page=38

On restart it does seem to work as I can see the whole boot process on both monitor and TV. However once it goes past login the screen stops displaying and goes to a grey background (where the desktop should be) I can still run the mouse on TV screen but vannot do anything.

IS it wa related to the graphics card and xorg setup or is it a user rights thing. Here is my stuff .

Also been following these how-to http://gentoo-wiki.com/TV-Out_with_GeForce
http://gentoo-wiki.com/HOWTO_Separat...Monitor_and_TV

User groups
[CODEflebber@flebber-desktop:~$ groups
flebber adm dialout cdrom floppy audio dip video plugdev scanner lpadmin admin netdev powerdev mythtv
[/CODE]

Xorg.conf

Code:

EndSection

Section "Device"
        Identifier        "Device[0]"
        Driver                "nvidia"
        BusID                "PCI:1:0:0"
        screen 0
EndSection

Section "Device"
          Driver          "nvidia"
          Identifier      "Device[1]"
          Screen 1
          Option          "TVOutFormat" "SVIDEO" #or SVIDEO etc
          Option          "TVStandard" "PAL-G" #or NTSC etc
          Option          "ConnectedMonitor" "TV"
        Option            "TVOverScan" "0.6"
          BusID          "PCI:1:0:0" #adjust using 'lspci' or cat /proc/pci
EndSection

Section "Monitor"
        Identifier        "Monitor[0]" #CRT
        Option                "DPMS"
        Horizsync        30-70
        Vertrefresh        50-160
EndSection

Section "Monitor"
            Identifier "Monitor[1]" #TV
            HorizSync 30-50
            VertRefresh 60
EndSection

Section "Screen"
        Identifier  "Screen[0]"
          Device      "Device[0]"
          Monitor    "Monitor[0]"
EndSection

Section "Screen"
          Device "Device[1]"
          Identifier "Screen[1]"
          Monitor "Monitor[1]"
          DefaultDepth 24
              SubSection "Display"
              Depth 24
              Modes "1024x768_60"
              EndSubSection   
EndSection

Section "ServerLayout"
          Identifier  "Simple Layout"
              Screen 0 "Screen[0]"
              Screen 1 "Screen[1]" RightOf "Screen[0]"
          InputDevice "Configured Mouse" "CorePointer"
          InputDevice "Generic Keyboard" "CoreKeyboard"
EndSection
       
        # Uncomment if you have a wacom tablet
        #        InputDevice    "stylus"        "SendCoreEvents"
        #        InputDevice    "cursor"        "SendCoreEvents"
        #        InputDevice    "eraser"        "SendCoreEvents"

Section "Module"
        Load                "glx"
EndSection


lazlow 11-04-2007 07:25 PM

I think you still have the resolution set beyond standard tv specs. I think Svideo tv resolution tops out at 800X600.

flebber 11-04-2007 11:51 PM

Its strange but even at 800x600 its not working I can see all the boot up but as soon kdm starts it stops but i can still put the mouse over and see it on the tv.

iF you have it working could you post the relevant part of your xorg.conf please.

lazlow 11-05-2007 01:11 AM

# Xorg configuration created by system-config-display

Section "ServerLayout"
Identifier "dual head configuration"
Screen 0 "Screen0" 0 0
Screen 1 "Screen1" 1 1
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "Files"
ModulePath "/usr/lib/xorg/modules/extensions/nvidia"
ModulePath "/usr/lib/xorg/modules/extensions"
ModulePath "/usr/lib/xorg/modules"
EndSection


Section "Module"
Load "glx"
Load "dri"
Load "bitmap"
Load "dbe"
Load "ddc"
Load "extmod"
Load "freetype"
Load "int10"
Load "record"
Load "type1"
Load "vbe"

EndSection

Section "Monitor"
Identifier "Monitor0"
ModelName "Monitor 800x600"
### Comment all HorizSync and VertSync values to use DDC:
HorizSync 31.5 - 35.1
VertRefresh 50.0 - 61.0
Option "dpms"
EndSection


Section "Monitor"
Identifier "TV" #TV
HorizSync 30-50
VertRefresh 60
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
Option "TVStandard" "NTSC-M"
Option "TVOutFormat" "SVIDEO"
Option "ConnectedMonitor" "TV"
EndSection

Section "Device"
Driver "nvidia"
Identifier "Device1"
Screen 1
Option "TVOutFormat" "SVIDEO" #or SVIDEO etc
Option "TVStandard" "NTSC" #or NTSC etc
Option "ConnectedMonitor" "TV"
Option "OverScan" "1.0"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection

Section "Screen"
Device "Device1"
Identifier "Screen1"
Monitor "TV"
DefaultDepth 24
SubSection "Display"
Depth 24

EndSubSection
EndSection


Hope this helps.
Lazlow

flebber 11-06-2007 07:07 AM

Solved
 
Thanks so much. The result no matter what I did it failed to work. I then targeted the driver itself removing it totally, reconfigured via dpkg to use vesa driver then reinstalled nvidia via envy and when that failed removed again and then tried the restricted manager again it just failed to work.

I ended reinstalling kubuntu totally and then from clean install this time used envy to do nvidia driver installation. This actually allowed me access to the nvidia settings manager, and from there after some minor scrapes the tv out worked perfectly. NB at no time did nvtv work at all.

For completion sake this is the section of the xorg.conf that got it going for me.

Code:

Section "Monitor"

    # TV fullscreen mode or DVD fullscreen output.
    # 768x576 @ 79 Hz, 50 kHz hsync
    Identifier    "monitor1"
    VendorName    "Unknown"
    ModelName      "TV-0"
    HorizSync      28.0 - 33.0
    VertRefresh    43.0 - 72.0
    ModeLine      "768x576" 50.0 768 832 846 1000 576 590 595 630
    ModeLine      "768x576" 63.1 768 800 960 1024 576 578 590 616
EndSection

Section "Monitor"
    Identifier    "Monitor0"
    VendorName    "Unknown"
    ModelName      "Chuntex"
    HorizSync      30.0 - 85.0
    VertRefresh    50.0 - 160.0
EndSection

Section "Device"
    Identifier    "device1"
    Driver        "nvidia"
    VendorName    "NVIDIA Corp."
    BoardName      "NVIDIA GeForce FX (generic)"
EndSection

Section "Device"
    Identifier    "Videocard0"
    Driver        "nvidia"
    VendorName    "NVIDIA Corporation"
    BoardName      "GeForce 6200"
    BusID          "PCI:1:0:0"
    Screen          0
EndSection

Section "Device"
    Identifier    "Videocard1"
    Driver        "nvidia"
    VendorName    "NVIDIA Corporation"
    BoardName      "GeForce 6200"
    BusID          "PCI:1:0:0"
    Screen          1
EndSection

Section "Screen"
    Identifier    "screen1"
    Device        "Videocard1"
    Monitor        "Monitor1"
    DefaultDepth    24
    Option        "DPMS"
    Option        "AddARGBGLXVisuals" "True"
    Option        "TwinView" "0"
    Option        "metamodes" "TV: nvidia-auto-select +0+0"
    SubSection    "Display"
        Depth      24
    EndSubSection
EndSection

Section "Screen"

# Removed Option "TwinView" "0"
# Removed Option "metamodes" "CRT: 1600x1200@65 +0+0; CRT: 1280x1024@60 +0+0; CRT: 1280x960@75 +0+0; CRT: 1280x960@60 +0+0; CRT: 1400x1050@60 +0+0; CRT: 1280x1024@75 +0+0; CRT: 1400x1050@75 +0+0; CRT: 1152x864@75 +0+0; CRT: 1024x768@43 +0+0; CRT: 1600x1200@60 +0+0; CRT: 1024x768@60 +0+0; CRT: 1024x768@70 +0+0; CRT: 1024x768@75 +0+0; CRT: 1024x768@85 +0+0; CRT: 832x624@75 +0+0; CRT: 800x600@60 +0+0; CRT: 800x600@85 +0+0; CRT: 800x600@75 +0+0; CRT: 800x600@72 +0+0; CRT: 800x600@56 +0+0; CRT: 640x480@85 +0+0; CRT: 640x480@75 +0+0; CRT: 640x480@72 +0+0; CRT: 640x480@60 +0+0"
# Removed Option "metamodes" "CRT: 1600x1200@65 +0+0, TV: nvidia-auto-select +1600+0; CRT: 1280x1024@60 +0+0, TV: nvidia-auto-select +1280+0; CRT: 1280x960@75 +0+0, TV: nvidia-auto-select +1280+0; CRT: 1280x960@60 +0+0, TV: nvidia-auto-select +1280+0; CRT: 1400x1050@60 +0+0, TV: nvidia-auto-select +1400+0; CRT: 1280x1024@75 +0+0, TV: nvidia-auto-select +1280+0; CRT: 1400x1050@75 +0+0, TV: nvidia-auto-select +1400+0; CRT: 1152x864@75 +0+0, TV: nvidia-auto-select +1152+0; CRT: 1024x768@43 +0+0, TV: nvidia-auto-select +1024+0; CRT: 1600x1200@60 +0+0, TV: nvidia-auto-select +1600+0; CRT: 1024x768@60 +0+0, TV: nvidia-auto-select +1024+0; CRT: 1024x768@70 +0+0, TV: nvidia-auto-select +1024+0; CRT: 1024x768@75 +0+0, TV: nvidia-auto-select +1024+0; CRT: 1024x768@85 +0+0, TV: nvidia-auto-select +1024+0; CRT: 832x624@75 +0+0, TV: nvidia-auto-select +832+0; CRT: 800x600@60 +0+0, TV: nvidia-auto-select +800+0"
# Removed Option "TwinView" "1"
# Removed Option "metamodes" "CRT: 1024x768@43 +0+0, TV: nvidia-auto-select +1024+0; CRT: 1024x768@60 +0+0, TV: nvidia-auto-select +1024+0; CRT: 1024x768@70 +0+0, TV: nvidia-auto-select +1024+0; CRT: 1024x768@75 +0+0, TV: nvidia-auto-select +1024+0; CRT: 1024x768@85 +0+0, TV: nvidia-auto-select +1024+0; CRT: 832x624@75 +0+0, TV: nvidia-auto-select +832+0; CRT: 800x600@60 +0+0, TV: nvidia-auto-select +800+0; CRT: 800x600@85 +0+0, TV: nvidia-auto-select +800+0; CRT: 800x600@75 +0+0, TV: nvidia-auto-select +800+0; CRT: 800x600@72 +0+0, TV: nvidia-auto-select +800+0; CRT: 800x600@56 +0+0, TV: nvidia-auto-select +800+0; CRT: 640x480@85 +0+0, TV: nvidia-auto-select +640+0; CRT: 640x480@75 +0+0, TV: nvidia-auto-select +640+0; CRT: 640x480@72 +0+0, TV: nvidia-auto-select +640+0; CRT: 640x480@60 +0+0, TV: nvidia-auto-select +640+0"
    Identifier    "Screen0"
    Device        "Videocard0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option        "TwinView" "0"
    Option        "metamodes" "CRT: nvidia-auto-select +0+0"
EndSection

Section "Extensions"
    Option        "Composite" "Enable"
EndSection

Lazlow thanks again for your time and effort very much appreciated.


All times are GMT -5. The time now is 02:52 PM.