-   Linux - Hardware (
-   -   Palm Zire 71 (

John_Who 05-27-2003 07:31 PM

Palm Zire 71

I have a Palm Zire 71. Can i use Linux to upload apps from pc to pda, and download photos from pda to pc?
I tried loading visor module. Then i created a new configuration from Network Setting (there's "Unix" listed among types of service) but when i try to connect i get (in /var/log/messages):

kernel: hub.c: new USB device 00:04.2-1, assigned address 4
/etc/hotplug/usb.agent: ... no modules for USB product 830/60/100
kernel: usb.c: USB disconnect on device 00:04.2-1 address 4

So there is not a module to connect this model of Palm device?


killi 05-28-2003 02:29 AM

i think kde has some kinda app and maybe gnome has one

jpohara 06-06-2003 12:23 PM

I don't know what flavor of Linux you use...I use Redhat 9 and have a Zire 71 as well.

There is a utility program called pilot-link that comes with Redhat and allows you to sync your Zire with a linux system. I use Ximian evolution for mail/address/to-do/memos. You can configure conduits from within the program to allow synchronization of all of the above, and there is also a file transfer option--I don't recall if you can use it in both directions (my assumption is that it was designed for upload to the PDA).

Hope that helps...

ramowl 06-28-2003 05:21 PM

I am not able to get my Zire 71 to work.

I am running Mandrake 9.0. I am using a USB connection. The Zire Hotsync config is set for Local, Cradle/Cable, Local HotSync, all conduits active. JPilot is the desktop I am using and is set for /dev/pilot (/dev/pilot -> /dev/ttyS0), Serial Rate = 9600. Pilot-link is installed and it is version 0.99.2.

I had a Palm 500 before and it worked just fine. Is there something that needs to be upgraded or switched to get my system to work with the Zire 71?

darin3200 06-28-2003 05:50 PM

Try Jpilot or Kpilot. The reason your isn't working ramowl is becaue /dev/ttyS0 is for serial, your using usb, it is listed as something else.

jchristman 07-01-2003 09:47 AM

I have a palm zire, and I am wondering how due I get the /dev/pilot to be a usb connection. What I have read shows setting this up and then kpilot will work fine, but no one says on how to setup a usb device (palm pilot).

jpohara 07-01-2003 09:01 PM

You have to create a symbolic link between /dev/ttyUSB1 and your Zire

If you look in the /dev directory you will probably find a ttyUSB1 device

do the following:

chmod 666 /dev/ttyUSB*
cd /dev
ln -s /dev/ttyUSB1 pilot

that will create the link for you

hopefully your distro comes with software called pilot-link...if not you may have to download and compile it

i have been using Ximian Evolution as my Linux PIM--works well and if pilot-link is on your system there will be options on the Evolution menu to help you configure your Zire and your conduits

n.b. -- evolution does not handle installation of programs on the handheld or movement of pictures to and from the Zire

jchristman 07-08-2003 08:34 AM

How do I find out which USB it is plugged into. I have 4 in back and 2 in front I am plugging it into the front ports. my keyboard and mouse are plugged in in 2 of the back ones.

jchristman 07-08-2003 09:55 AM

I have it connecting to kpilot but halfway throught the sync it stops
and says hotsync operation interrrupted. and if I use evolution it starts and then errors.

jchristman 07-08-2003 10:37 AM

I now have it connecting completely with kpilot but since I dont use it there is nothing todo. But when i try to sync with evolution it says unable to connec to desktop.

BelleDog 07-18-2003 04:10 PM

SO Close but yet so far
If I can jump into this thread.

Somewhat of a newbie to Redhat, but fairly up on computers, dev., etc.

Trying to linkup my new Zire 71 and Ximian Evolution 1.4 using the USB cradle (will try IrDA later once I get this working). This thread and its mates was helpful -- got the Zire to /dev/ttyUSB1 and can read and back up using pilot-xfer, so everything seems to work at the utility level.

My problem is the next to last one to be listed, but not answered -- I can initiate a synch under evolution, but the address exchange hangs with only 2 records coming across.

If I eliminate all other conduits, the synch goes to completion. EAddress brings up the progress dialogue and the shutttle flys back and forth, but eventually the Zire times out with a dropped connection message.

Anyone got a great ideas? Been trying to reinstall Evolution to see if that cleans up a problem, but the Duke mirror now seems to not authenticate the fancy, shamansy installer.

Getting real close, but I need all 867 contacts, not the first two. Thanks in advance.

jchristman 07-23-2003 09:32 AM

I have mine connecting correctly now. I had to sync with kpilot and then
when i went into evolution and used the pilot link to get the username from the palm and then close evolution and just use the hotsync on the palm and it uploaded all the data for me. Now it works just fine.

gpenguin 07-28-2003 02:37 PM

Palm Zire 71...not working yet. HELP!
Ok, I know lots of information has been given, but still not enough for me I guess. I am not a newbie, but perhaps you guys can give more details to help me out.

I have a Palm Zire 71 purchased 7/2003 and it does not communicate with my Linux box. Here are some preliminary stats:

Kernel 2.4.20
Visor.c v1.6
pilot-link 0.11.8
Palm Zire 71 w/PalmOS 5.2.1
- configured: Local w/cradle,cable

No modules loaded...everything is compiled into the kernel.

I have 100% success with a Handspring Visor, so I know my USB is working fine. However, when I push the HotSync button on the cradle, my messages file shows :
hub.c: new USB device 00:07.2-1.3, assigned address 4
usb.c: USB device 4 (vend/prod 0x830/0x60) is not claimed by any active driver.
usb.c: USB disconnect on device 00:07.2-1.3 address 4

As a result, when I try and communicate via pilot-link, I get an error stating there is no port. According to pilot-link docs, the "not claimed by any active driver" means it is the visor.c driver that can't handle it.

I have checked *everything* I can think of:

- Permissions on /dev/ttyUSB*
- /dev/pilot points to /dev/ttyUSB1
- I've tried all USB ports 0-whatever dmesg stated (5,6,7, etc)

Those of you who have it working, can you verify your versions of kernel, visor.c, PalmOS and pilot-link please? As far as I can tell, I have everything up to date and it should be working...just like the rest of you.

If you need help knowing how to check version numbers:

Kernel: % uname -a
visor.c : dmesg | grep -i visor
pilot-link: pilot-xfer --version
PalmOS: From home screen, go to menu and Info I think


Depressed David

GoofMan 08-05-2003 07:31 AM


here is a link that may help you:



GoofMan 08-05-2003 07:33 AM

Sorry forgot to mention: See bottom of given page, there is the Zire 71 with kernel 2.4.20 info

All times are GMT -5. The time now is 03:28 AM.