LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 02-10-2007, 07:43 AM   #1
kiyiya
LQ Newbie
 
Registered: Feb 2007
Posts: 7

Rep: Reputation: 0
Over-Current on Port..... USB Error


I have a Dell Inspiron 8500 on which I installed Fedora Core 6 (2.6.18-1.2798.fc6). The installation went without a hitch and everything appears to be working except USB. I get the following error:

hub 2-0:1.0: over-current change on port 1
hub 4-0:1.0: over-current change on port 3
This just goes and on in the logs and is the output of dmesg.

lspci output for USB is:

00:1d.0 USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #1 (rev 03)
00:1d.1 USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #2 (rev 03)
00:1d.2 USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #3 (rev 03)

My hdd is constantly writing to the log file with this error and the system seems to run slow. I must point out that this error (or a similar one) was present in Windows XP as well but I was able to disable the offending ports and go on without issue.

I know this type of error usually indicates a short or something else wrong with the hardware but I have completely taken this laptop apart and see nothing "obviously" wrong like a piece of metal touching the motherboard or anything.

I guess my question is this: how can I disable the offending ports so Linux does not want to use them?

I appreciate your help.

Kiyiya
-
 
Old 02-11-2007, 04:18 PM   #2
macemoneta
Senior Member
 
Registered: Jan 2005
Location: Manalapan, NJ
Distribution: Fedora x86 and x86_64, Debian PPC and ARM, Android
Posts: 4,593
Blog Entries: 2

Rep: Reputation: 335Reputation: 335Reputation: 335Reputation: 335
Apply maintenance:

yum -y update

Reboot to use the newly installed kernel. Do you still get the messages?
 
Old 02-11-2007, 04:34 PM   #3
macemoneta
Senior Member
 
Registered: Jan 2005
Location: Manalapan, NJ
Distribution: Fedora x86 and x86_64, Debian PPC and ARM, Android
Posts: 4,593
Blog Entries: 2

Rep: Reputation: 335Reputation: 335Reputation: 335Reputation: 335
If the update doesn't resolve the problem, you are likely seeing a hardware problem. You can look at this bug report for details. You can suppress the messages with the workarounds in this bug report, but the situation is not ideal.
 
Old 02-13-2007, 12:37 AM   #4
kiyiya
LQ Newbie
 
Registered: Feb 2007
Posts: 7

Original Poster
Rep: Reputation: 0
Thanks for your reply. The updates (all 268 of them) did not work. The workaround I am still working with but I was hoping there was some way to "turn off" the offending hub like I have been able to do in Windows. I figured I had a hardware problem but I am not just quite sure how it went bad. Any other suggestions?

Kiyiya
 
Old 02-13-2007, 01:01 AM   #5
Electro
LQ Guru
 
Registered: Jan 2002
Posts: 6,042

Rep: Reputation: Disabled
Probably a paper clip, stapler, graphite fillings, or anything that is metal is shorting out USB. A good cleaning with compress air should fix the problem unless your notebook contains a defective component.
 
Old 02-13-2007, 06:24 AM   #6
kiyiya
LQ Newbie
 
Registered: Feb 2007
Posts: 7

Original Poster
Rep: Reputation: 0
I did a good cleaning on it with compressed air right after I got these messages. I took the entire laptop apart and cleaned the motherboard, inspected for any sign of metal contact and/or damage but could not find anything. This port used to work fine and all of a sudden it started to give this same type of message in Windows after an update I performed. I think I may have a bad controller,however, the other port seems to work fine. At least in Windows I could stop the annoying messages.

Kiyiya
 
Old 02-13-2007, 09:35 AM   #7
macemoneta
Senior Member
 
Registered: Jan 2005
Location: Manalapan, NJ
Distribution: Fedora x86 and x86_64, Debian PPC and ARM, Android
Posts: 4,593
Blog Entries: 2

Rep: Reputation: 335Reputation: 335Reputation: 335Reputation: 335
The workarounds in the bug reports didn't work? You tried blacklisting uhci-hcd and ohci-hcd?
 
Old 02-13-2007, 05:19 PM   #8
kiyiya
LQ Newbie
 
Registered: Feb 2007
Posts: 7

Original Poster
Rep: Reputation: 0
The workarounds listed below are not available on my system. I do not have a hotplug directory (do I need to create it?) and the KLOGD daemon is not where it is supposed to be. I would rather not turn off logging of the kernel and hope the first solution is achieveable.

How do I know if Hotplug is being used?

From the bug report:

This can be circumvented (if using hotplug) by adding uhci_hcd to
/etc/hotplug/blacklist. Of course, if the module is loaded, problem will appears
again.

It is possible to filter the messages by adding switch "-c 2" to kernel logging
daemon. Just edit /etc/init.d/klogd:

Change

KLOGD=""

to

KLOGD="-c 2"

Unfortunately this filters also many other useful kernel messages.
 
Old 02-13-2007, 05:32 PM   #9
macemoneta
Senior Member
 
Registered: Jan 2005
Location: Manalapan, NJ
Distribution: Fedora x86 and x86_64, Debian PPC and ARM, Android
Posts: 4,593
Blog Entries: 2

Rep: Reputation: 335Reputation: 335Reputation: 335Reputation: 335
If you are not using hotplug, you can just:

/sbin/modprobe -r uhci_hcd
/sbin/modprobe -r ohci_hcd

If this works, add the commands to your /etc/rc.local (or the equivalent on your distribution).
 
Old 02-13-2007, 11:09 PM   #10
kiyiya
LQ Newbie
 
Registered: Feb 2007
Posts: 7

Original Poster
Rep: Reputation: 0
I ran modprobe and was able to stop the constant thrashing of my HDD and I modified the rc.local file so hopefully it will survive a reboot. However, when I checked the log it was only able to stop the messages for the port 1 error not the port 3.

Here is a sample of the log file:

Feb 13 22:03:22 kiyiya kernel: hub 4-0:1.0: over-current change on port 3
Feb 13 22:03:53 kiyiya last message repeated 121 times
Feb 13 22:04:54 kiyiya last message repeated 244 times
Feb 13 22:05:55 kiyiya last message repeated 244 times
Feb 13 22:06:56 kiyiya last message repeated 244 times
Feb 13 22:07:57 kiyiya last message repeated 244 times
Feb 13 22:08:58 kiyiya last message repeated 244 times
Feb 13 22:09:59 kiyiya last message repeated 245 times
(sample)

It now appears to write the message every minute instead of multiple times a second. This is definitely a step in the right direction.

Last edited by kiyiya; 02-14-2007 at 06:45 AM.
 
Old 02-16-2007, 11:37 PM   #11
kiyiya
LQ Newbie
 
Registered: Feb 2007
Posts: 7

Original Poster
Rep: Reputation: 0
Running the commands also took out my CD Drive.
 
Old 02-17-2007, 03:51 PM   #12
Electro
LQ Guru
 
Registered: Jan 2002
Posts: 6,042

Rep: Reputation: Disabled
Try specifying nousb at the bootloader.

Disabling USB is only a software workaround. If your notebook computer is still under warranty, it is best to see if Dell can replace it. If it is not, get a new notebook.
 
Old 02-17-2007, 07:57 PM   #13
UhhMaybe
Member
 
Registered: Jul 2004
Location: Salt Lake City, Utah
Distribution: Absolute 12.0 Studio 64 1.3.0
Posts: 470

Rep: Reputation: 30
IF it is possible, go to BIOS and disable USB. Do you need both USB and USB legacy to run your laptop? This at least offers you two more options.
 
Old 02-19-2007, 10:08 PM   #14
kiyiya
LQ Newbie
 
Registered: Feb 2007
Posts: 7

Original Poster
Rep: Reputation: 0
This notebook is a little over 3 years old so the warranty is out. I can not find out what the problems are with the ports but Windows at least has functionality for one of them. I know that this would be a "workaround" but it beats giving up on the machine entirely. This thing has been a real work horse! I guess I could go back to Windows where I can manage the bad port and still use the other one and my CD/DVD combo drive. I just thought there was a way in Linux to have more manageability of the hardware.

Thanks for your responses.
 
Old 09-13-2008, 07:32 AM   #15
mesfet
LQ Newbie
 
Registered: May 2004
Location: Treviso - Italy
Distribution: debian
Posts: 3

Rep: Reputation: 0
I got the same problem with my Intel mainboard with ATOM cpu, and fixed this trouble setting, in the BIOS menu, USB legacy mode.

So, try to setup USB LEGACY MODE in you BIOS : hope you fix the over-current USB problem.
Best regards. Paolo
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
hub 1-0:1-0: over-current change on port 2 PROBLEM peji Linux - Hardware 4 11-13-2008 05:44 PM
USB over-current change killing USB ports Fluxxdog Linux - Hardware 4 09-13-2008 06:09 AM
hub 1-0:1-0: over-current change on port 2 ERROR peji Debian 0 01-05-2006 05:29 AM
Using an USB port as a standard DB9 Serial Port Lsteele Linux - Newbie 1 10-22-2005 09:48 AM
Current List of Port Trojans robeb Linux - Security 1 02-14-2003 06:27 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 11:47 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration