-   Linux - Hardware (
-   -   Other problem with the sound in Mandrake - onboard sound card (

Swetko 11-05-2004 09:11 AM

Other problem with the sound in Mandrake - onboard sound card
I have Mandrake 10.0 and an onboard sound card (Intel 915 PERL is my motherboard - I don't know the model of the sound card) and my linux installs it but when I start playing sth.
the progress bar of the song is moving but there is no sound

I have dual boot and under XP there is sound
so I have not mistaken the cables and my sound card is working properly

I soon changed my PC and my old PC had onboard sound card again (intel again, but
mandrake installed it and it worked properly

vharishankar 11-05-2004 09:39 AM

If the progress bar is moving, then there is probably output (otherwise there should be an error message). Have you tried setting your mixer levels? And what driver does it use (OSS or Alsa).

Go to KDE Control Center and check the sound system. That should help to give more details.

Swetko 11-05-2004 03:42 PM

Manufacturer: ‎Intel Corp.

Alternative drivers : ‎ali5455:i810_audio:nvaudio


BUS ID: ‎8086:24d5:8086:a000

Location on the bus: ‎0:1f:5

Description: ‎82801EB AC'97 Audio

MODULE: ‎snd-intel8x0


that's what mandrake says about my sound card
I used KDE control center and there was an option
'Enable sound system' and it was not turned on and I turned it on
but it did not help

Should I seek for drivers for my sound card in I'net

Swetko 11-06-2004 09:40 AM

Is there any way I can hear a sound from linux

I'm using ALSA driver

allforcarrie 11-06-2004 11:03 AM

Same problem here!! can anyone help? I have a soyo k8 MOBO with onboard sound, i can hear sound in XP but not mandrake... :confused:


J.W. 11-06-2004 03:59 PM

Volume levels in ALSA are typically muted - have you run alsamixer and raised all of them to reasonable levels? Additionally, make sure that the speakers are powered on and the volume knobs are turned up, and make sure that volume slider bar of the sound app (XMMS, KsCD, etc) is turned up too. Finally, be certain that in your BIOS settings, that you have onboard sound enabled. Hope that helps -- J.W.

allforcarrie 11-07-2004 12:50 AM

i tryed every possible volume adjustment i could.... i did get a realy annoing feedback..

J.W. 11-07-2004 01:59 AM

That could be a good sign. Turn down the PCM setting to single digits, but make sure the others are relatively high. See if that makes a difference -- J.W.

allforcarrie 11-07-2004 02:18 AM

this may help:

jschiwal 11-07-2004 05:31 PM

There is a program you can run as root called alsaconf.
The last step of the program will play a sample sound.
One quick test is to cat a file to /dev/dsp. If you hear a burst of noise, the sound system should work.

Now what might happen is if as root you can hear sounds, but as a normal user you can't.

In that case, you want to make sure that you are a member of the 'audio' group.

I've had to add myself to this group using Mandrake and SuSE linux.
Also, check that the owner:group of /dev/dsp is root:audio

As a last resort, you could change the permissions of /dev/dsp.
I believe that the permissions should be 0662.

Changing it to 0666 may fix the problem, but may pose a security risk if you have a microphone.

allforcarrie 11-08-2004 12:27 PM

you completly lost me.... i'm in file:/dev/ there is nothing called dsp, there is a folder called sound with nothing in it.

How do i change permissions for groups?

Swetko 11-08-2004 03:07 PM

I have a /dev/dsp
and in /dev/sound/ i have dsp and some other
I downloaded drivers (from for redhead9 - I think they will be fine for Mandrake 10
and the drivers request that I install linux kernel source
and I'm going to do it
I'll tell the result after that
I hope this will solve my problem

faheyd 11-08-2004 03:11 PM

I'm not a professional, but there are steps to take to get sound to work: .

Also, take a look in your /proc file system for any sound stuff for some clues as to what is really active.
I've found this to be helpful: and its parent: .

These documents, although sometimes complicated, should get you on your way, especially the T/S doc above.

Swetko 11-11-2004 04:45 PM

I tried again to play a sound with XMMS and Totem player and they both played the song for few seconds and then crashed
So, I installed the drivers form but I did no help
Just the same happened.

I use KDE control center / Sound system
and I try to use ALSA and then click on the button apply
Here is the message:

Sound server informational message:
Error while initializing the sound driver:
device: default can't be opened for playback (Permission denied)
The sound server will continue, using the null output device.

I found /dev/dsp - it's owner is root and its group is audio. But also there are same other dsp#(1,2,3...) files.
there is nothing in the folder sound. And I am sure the last time I viewed its content it wasn't empty
there was the original file dsp and int /dev/dsp was only a link.

Then I installed sndconfig
It says:

You don't seem to be running a kernel with modular sound
enabled. (soundcore.o was not found in the module search path).
To use sndconfig, you must be running a kernel with modular
sound, such as the kernel shipped with Red Hat Linux or a 2.2
or greater kernel.

So , are there any modules I have to load and how to do it

I just could not understand why is it happening so.
One time I install Mandrake I have sound
The other time I do not have sound.

Swetko 11-12-2004 11:52 AM

Oh come on

I just want to use Linux for simple things like listening to music
and I want it to be a little easier. I'm wondering why things should be so complicated in Linux

help me

All times are GMT -5. The time now is 03:17 PM.