-   Linux - Hardware (
-   -   Only 2GB our of 4GB RAM detected (

tamoneya 01-19-2008 01:34 PM

Only 2GB our of 4GB RAM detected
I have just installed a fresh version of Ubuntu 7.10 and I checked in the system monitor and it said that I was using ~225 MB out of 2GB. The thing is that my computer has 4GB of RAM. I checked to make sure that my motherboard was detecting it right because when I built the system I had a similar problem with vista and it ended up that my mother was having trouble seeing it. This time the motherboard detects all 4 GB so that isn't my problem.

Not sure if it matters but my RAM is 2x2GB not 1x4GB.
kernel: 2.6.22-14-generic

pakus 01-19-2008 02:21 PM


The problem is you kernel has not been compiled to support 4GB.

You must to recompile your kernel configuring CONFIG_HIGHMEM option.

See this article

syg00 01-19-2008 03:56 PM

Not likely; if that were the case, he wouldn't see 2 Gig either.
Check the BIOS messages, then dmesg for memory size detected. Might be something as simple as a seating problem.

Electro 01-19-2008 06:27 PM

If the BIOS shows 4096 GB of RAM and Linux only shows 2048 MB of memory, the kernel is compiled with high mem support and 4 GB memory support is off. You will have to recompile the kernel with 4 GB memory support.

A 32-bit OS will use only 3.2 GB of memory while the rest is for addressing even though a 32-bit OS can handle 4 GB memory with out any trouble. It is stupid software magic named PAE not letting you to use all 4 GB of memory. I suggest use a 64-bit kernel version if you want to use all 4 GB of memory.

lazlow 01-19-2008 07:17 PM

I will second Electro's suggestion of using a 64 bit version of Linux for any system with more than 2GB of ram. The recent 64bit version have very few (essentially none)of the limitations (compatibility) that the older versions did.

jay73 01-19-2008 08:23 PM

As I understand it, your BIOS has memory mapping enabled. This is what allows a 64 bit system - as well as BIOS - to see 4GB or more. It also implies that 32 bit systems won't be able to access more than 2GB since anything over 2GB is mapped outside 32 bit memory space. The solution, as suggested by others, is to run 64 bit. Even 32 bit with PAE should work but why bother when you can have it so easy?

tamoneya 01-19-2008 10:15 PM

Wow. Thanks for the many quick responses. I forgot about the 64bit 32 bit issue. However I don't feel like recompiling my kernel or reinstalling again. Maybe when Hardy comes out I will switch to 64 bit.

All times are GMT -5. The time now is 10:38 AM.