-   Linux - Hardware (
-   -   old HDD to new machine RHEL/centos 4.0 (

nanlogan2 01-07-2014 08:20 AM

old HDD to new machine RHEL/centos 4.0
I've been trying to move my old disk to a new machine. The old one ran RHEL4.0 & I want to be able to invoke that again. I get the message

Uncompressing Linux... Ok, booting the kernel.
Red Hat nash version starting
mount: error 6 mounting ext3
mount: error 2 mounting none
switchroot: mount failed: 22
Kernel panic - not syncing: Attempted to kill init!

plugged disk to PC running Centos 6.4 and mounted root & boot
did a mount -t proc none /mnt/root/proc
when I ran mkinitrd --with=sata_via /initrd-new2.img 2.6.9-42.0.10.EL & successfully created it.then copied it to boot. Changed grub.conf & modprobe.conf Yet I have the same problem
Most grateful if someone can help

jefro 01-07-2014 09:30 PM

Might work.

nanlogan2 01-08-2014 09:17 AM


Originally Posted by jefro (Post 5093936)

The above was based on this article & it has not worked...

Shadow_7 01-08-2014 09:45 AM

Most times there's two obstacles when migrating machines. The bootloader and the /etc/fstab with regards to device locations. If you're not using UUIDs (partition specific) to specify it's location, chances are that the /dev/ names are not the same so it fails to find things. The bootloader passes root= and /etc/fstab connects / with a device. Which is unlikely to match on new hardware.

There's also issues with differing BusID and Driver for xorg.conf if you get to the gui portion. If there is a gui portion.

John VV 01-08-2014 03:00 PM

also keep in mind that redhat no longer even supports rhel4.0
4.0 is ancient

only 4.9 is still supported ( in the 4 series ) under the newly added "EXTRA" extended life support
and for only one more year

what format is that ancient rhel4.0 drive
ext2 or something else

was it in a raid set up ?
or what

from the first post i take it you want to boot the ancient RHEL4.0 in a what dual boot with CentOS 6.5

i would try to use the grub in cent6.5 to point to the very old ryhel4.0 boot partition on that drive ,using a chainload .

nanlogan2 01-09-2014 08:43 PM

[QUOTE=Shadow_7;5094288]Most times....
shadow 7 -thanks ...
can you please be more specific with all your points.. I have hardware background (ie soldering iron) ... fstab for me is to permanently mount can I run fdisk to check this ..what & where is this /dev/ names & where is BusID and Driver for xorg.conf..... I'd be most grateful if you could kindly what & where need to look & do.

Jonh W is ext3 sata i installed a program on this machine an old version of a program i use for work.. lost my job a year ago so I thought I'd try get some practise...any help would be greatly appreciated

Shadow_7 01-10-2014 10:54 PM

# blkid /dev/???

To get the UUID of a partition. Where ??? is the /dev/ name of the appropriate device (partition). /dev/sda1 or whatever applies. It should show up to some degree in /proc/partitions if you're unsure of the naming conventions.

In the bootloader, instead of root=/dev/??? use root=UUID=12345678-1234-1234-1234-0123456789abcdef where the UUID is what "your" UUID actually is.

In /etc/fstab, also replace /dev/??? with UUID=??? for the UUID in question. They are roughly equivalent for all modern purposes. Although that is an older version of things and may not support UUIDs. So you may end up guessing appropriate /dev/??? names depending on your device tree. You could also swap the hardware around to make things play well with the original software expectations. I.E. pulls all drives except that one so it might default to /dev/sdaX.

ProfWEB 01-17-2014 11:59 AM

old HDD to new machine RHEL/centos 4 0
Looking for an updated repo that will keep up with the community squeeze releases that does not require me to switch over to Fedora for my media server. Is there one out there? If not I suppose I could make the switch, although I would much rather not as I have been enjoying the stability of centos

The slimdevices repo seems to have not gotten an updated since 7.7.2, which was in march.

Thanks and hopefully someone can point me in the correct direction. =

All times are GMT -5. The time now is 03:00 PM.