LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 06-06-2004, 12:39 AM   #46
headclark
LQ Newbie
 
Registered: Jun 2004
Posts: 20

Rep: Reputation: 0

--After much searching I have found that the ATI drivers do not play nice with xinerama or XV.

Last edited by headclark; 06-06-2004 at 09:53 PM.
 
Old 06-08-2004, 06:08 PM   #47
Wodeh
LQ Newbie
 
Registered: Apr 2004
Posts: 19

Rep: Reputation: 0
I have reinstall, recompiled (twice) and reinstalled fglrx.
It works, but it always has, the question is will it stay working.

On a side note Unreal 2k4 plays like crap, despite what I have heard of double FPS in linux.

I get more FPS in XP with higher overall detail and 4x anti aliasing + 16x anisotropic than I get in linux with normal everything and no FSAA or AF. Both at 1024*768.
 
Old 06-08-2004, 09:00 PM   #48
headclark
LQ Newbie
 
Registered: Jun 2004
Posts: 20

Rep: Reputation: 0
when you recompiled...what settings did you use?
i have recompiled a few times..but always left in agpgart and radeon drivers...just in case.
Also, left in DRM support.
 
Old 06-08-2004, 09:20 PM   #49
motub
Senior Member
 
Registered: Sep 2003
Location: The Netherlands
Distribution: Gentoo (main); SuSE 9.3 (fallback)
Posts: 1,607

Rep: Reputation: 46
The radeon drivers do not work for cards above the 9200, iirc (it might be the 9000). If your card uses the R350 chipset, there is no point in having the old radeon drivers installed at all, and it might actually be a bad idea, insofar as it may conflict with the driver that actually works.

Kernel agpgart conflicts with the one installed with the driver, but you can leave it if you want to use it (you have to turn off the driver agpgart in the fglrxconfig and also make sure the kernel agpgart loads before the fglrx module if you want it to work).

I believe that DRM (kernel DRI) flatly conflicts with the driver and must be turned off in the kernel for the driver to work for 3D acceleration.

Again, I refer everyone to the ATI Radeon Linux How-To for kernel configuration instructions for all distros and installation instructions by distro.
 
Old 06-11-2004, 01:28 PM   #50
motub
Senior Member
 
Registered: Sep 2003
Location: The Netherlands
Distribution: Gentoo (main); SuSE 9.3 (fallback)
Posts: 1,607

Rep: Reputation: 46
OK, for everyone who's wondering how to enable OpenGL Overlay, and for those who have installed the fglrx drivers but are still seeing MESA in the fglrxinfo string, I found out how to fix it, because it just happened to me for the first time.

Long story of what happened; I won't bore you with it, but anyway it resulted in me looking at fglrxinfo and seeing the MESA string, and Neverwinter Nights suddenly reporting that it could not initialize the video device (!!!).

The driver was, however, loaded, according to lsmod.

Restarting the X server did not fix it, so I reran fglrxconfig. After going through all the various settings of my mouse and keyboard, etc, I came to "Application Profiles".

The default setting for this is "default"... but if you use the default, OpenGL Overlay will not be enabled (don't ask me; it seems stupid to me as well).

Anyway, when you get to this, you have to choose choice 2, "Individual Configuration of Capabilities". There's only one choice there... to turn on OpenGL Overlay.

Do so, then go ahead and take the defaults for everything else (except set the compatibility mode for Wine/WineX if you use them), unless your configuration needs something else (you use Dual-Head, for example).

Save it (I saved it over the previous file), then reboot.

That restored the ATI string to fglrxinfo, my XF86Config-4 looks like this

Code:
# === Video Overlay for the Xv extension ===
    Option "VideoOverlay"               "on"
# === OpenGL Overlay ===
# Note: When OpenGL Overlay is enabled, Video Overlay
#       will be disabled automatically
    Option "OpenGLOverlay"              "on"
and NWN runs again (somewhat better, actually, than it had been doing of late).

Hope this helps somebody.
 
Old 06-13-2004, 10:19 PM   #51
ttilt
Member
 
Registered: Dec 2003
Location: Campinas, Brasil
Distribution: slackware 10
Posts: 150

Rep: Reputation: 15
Hi motub,

I was using version 3.7.6 of the driver without problems, but then I tried installing this latest version and ran into this same problem,
the driver seems to install without problems but after I reboot and run fglrxinfo it says Mesa and the glxgears runs very slowly, clearly in
software mode.

So I tried this overlay thing that you suggested and it still didn't fix the problem after a reboot... I still get the Mesa on fglrxinfo.
I'm using kernel 2.6 on mandrake 9.2. Any further suggestions?

Thanks, this is not the first time i run into this problem, actually with every version of the driver that I installed I ran into this same problem and
had to fix it somehow everytime.

Thanks for the help
 
Old 06-13-2004, 10:26 PM   #52
Reagger
LQ Newbie
 
Registered: Jun 2004
Posts: 3

Rep: Reputation: 0
I was wondering if there is something different that has to be done for a PCI (no AGP) card?

I have a VisionTek 9200 256MB PCI video card running on a Dell 1600sc machine with Redhat Linux 9. Its a server machine so it doesn't have an AGP slot, but it does have the PCI-X slots. I bought the 9200 as a stop gap until the PCI-X video cards start coming out.

I rebuilt my kernel taking making sure to specify an intel based chip (i686), and included agpgart as a module. It can't compile into the kernel as the system doesn't actually have an agp slot. MTRR is also enabled. I DISABLED XFree86 DRI support and kernel debugging.

With the newly compiled kernel and modules installed I installed the fglrx-4.3.0-3.9.0.i386.rpm. This was done at runlevel 3 so no X yet.

[root@monster drivers]# rpm -ihv --force fglrx-4.3.0-3.9.0.i386.rpm

It had the warnings so I even rebuilt the module just to be sure:

[root@monster drivers]# cd /lib/modules/fglrx/build_mod/
[root@monster build_mod]# sh make.sh
[root@monster build_mod]# cd ..
[root@monster fglrx]# sh ./make_install.sh

The make_install.sh had the warning about tainting the kernel

I ran fglrxconfig and took all the defaults, except for those that fit my keyboard, mouse, monitor, etc.

Made sure the fglrx module was loaded:

----Screen Capture Begin ----
[root@monster fglrx]# modprobe fglrx
Warning: loading /lib/modules/2.4.20-8-SMP-ATI/kernel/drivers/char/drm/fglrx.o will taint the kernel: non-GPL license - Proprietary. (C) 2002 - ATI Technologies, Starnberg, GERMANY
See http://www.tux.org/lkml/#export-tainted for information about tainted modules
Module fglrx loaded, with warnings
[root@monster fglrx]# lsmod
Module Size Used by Tainted: P
fglrx 195944 0 (unused)
a bunch of other modules that probably aren't relavent (again no agpgart because I dont' have one)
----Screen Capture End ----

I start up X and get into the desktop fine. But running fglrxinfo gives me the old Mesa driver routine.

I can't run fgl_glxgears, it gives me this message

"Error: couldn't get fbconfig"

and regular glxgears gives me about 120 fps.

Any help or suggestions would be really appreciated.

Thanks.
 
Old 07-09-2004, 07:01 PM   #53
shorty_boy
Member
 
Registered: Oct 2003
Location: Oak Harbor, WA
Distribution: Debian Unstable
Posts: 94

Rep: Reputation: 16
Question is this weird?

ohk guys, i am using linux 7.3 (used apt-get and yum to put me up to date with the most recent 7.3 packages) and i am using XFree86 ver. 4.2.0 (i don't get how to update that) and the ati 3.9.x drivers for my X ver. So it is not like i am complaining but when i run glxgears, my fps is about 85!? But when i play games like america's army and ut, and armagetron, i don't have ne slowdown or lag of any sort.
I did have a problem with mesa when trying to install the drivers so i recompiles my kernel without dri support and then installed the ati drivers. So is this weird or what, has ne 1 else experienced this?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
tvtime does not work with official ATI drivers!! mrosati Linux - Software 0 09-30-2005 03:35 AM
ATi Radeon 9000 Pro and Radeon(flgrx) driver included on Mandrake 10.1 Official St3althcAt Linux - Hardware 1 05-07-2005 08:30 PM
ATI Drivers in MDK10 Official Borka Mandriva 3 07-19-2004 01:39 PM
Mandrake 10 Official ISO's availible felicehome Mandriva 0 05-26-2004 05:01 AM
Trouble with Official ATI driver for Radeon amp Linux - Hardware 2 07-24-2003 07:34 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 06:51 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration