-   Linux - Hardware (
-   -   OfficeJet G85, CUPS Web based Admin test print works, lpr/lp dose not. ptal-print OK. (

NLR 09-19-2004 04:57 PM

OfficeJet G85, CUPS Web based Admin test print works, lpr/lp dose not. ptal-print OK.

Problem Simple:
HP OfficeJet G85 print drivers are installed and CUPS web based admin allows me to add a printer, the button "print test page" in the CUPS web based admin is able to print a page. lpr/lp can not connect to printer, thus can not print.

Problem In detail:
I run Slackware 10.0 with the default kernel (2.4.26). I am trying to get my HP OfficeJet G85 print to work with it. Searching around on the Internet led me to a few things, one the HP linux drivers (hpinkjet (, but after installing that I quickly found at that I need the OfficeJet Drivers and I had the InkJet Drivers. So I went to: (hpoj (HP OfficeJet Driver)) and compiled and installed that...

After I installed that driver I ran:
ptal-init setup
Which found and set up up my printer at: /dev/usb/lp0

I than ran:
which gave me:

MFG:Hewlett-Packard;MDL:OfficeJet G85;CMD:MLC,PCL,PML,SCL;CLASS:PRINTER;DESCRIPTION:Hewlett-Packard OfficeJet G Series;1284.3M:f7f,f7f;1284.4DL:4d,4e,1;SERN:SGG27E15K2VL;VSTATUS:$HB0$NC0,ff,DN,IDLE,CUT,K0,C0,SM,NR,KP078,CP087;AiO:0;DW-PCL;
Meaning that everything went OK but just for kicks I also ran:
which gave:

ptal-print: connecting to device "mlc:usb:OJG85"...  successful.
I than typed in 'test' and hit ctrl-c, my printer printed a page with the word 'test' on it. Meaning I have connected to my printer sent it raw data and it printed it out.

Moving on I restarted CUPS with: /etc/rc.d/rc.cups restart
and than went to localhost:631 with my web browser and configure CUPS with my printer. I added the printer with the options that the README file hpoj told me to do and named it OJG85. And than I click print test page. Which than printed out a test page correctly. I though I was set.

So I went into firefox and tried to print out a page, that didn't work, the printer never printed any thing. So I saved it to a PostScript file and than tried to print it out with the lpr command my self which gave me the error:

Status Information, attempt 1 of 3:
sending job 'nothinglikeroot@localhost+715' to OFG85@localhost
 connecting to 'localhost', attempt 1
 cannot open connection to localhost - No such file or directory
Make sure the remote host supports the LPD protocol
and accepts connections from this host and from non-privileged (>1023) ports
Waiting 10 seconds before retry

I have been researching the Internet and any place that I can and am not really able to pull anything up on HP OfficeJet G85 printers. I don't like to be fed answers, but I cant be dangling on this for too long. I hope that you may be able to point me in the correct direction or provied a solution.

[ This is some information that I though might help ]
Bus 003 Device 001: ID 0000:0000
Bus 003 Device 002: ID 04fc:0561 Sunplus Technology Co., Ltd
Bus 002 Device 001: ID 0000:0000
Bus 002 Device 002: ID 03f0:0211 Hewlett-Packard
Bus 001 Device 001: ID 0000:0000

[dmesg (some lines that relate to the printer)]
usb-uhci.c: $Revision: 1.275 $ time 17:55:05 Jun 13 2004
usb-uhci.c: High bandwidth mode enabled
usb-uhci.c: v1.275:USB Universal Host Controller Interface driver
usb.c: registered new driver usblp
printer.c: v0.13: USB Printer Device Class driver
hub.c: new USB device 00:02.0-3, assigned address 2
printer.c: usblp0: USB Bidirectional printer dev 2 if 0 alt 0 proto 3 vid 0x03F0 pid 0x0211

Thank You! Andrew

schatoor 09-20-2004 04:25 AM

Hi, read this thread;

NLR 09-20-2004 02:59 PM

Thank you very much. The sim links were the problem. I did a search and didnt see that thread, sorry about posting it again....

First time I have used cups, so I did not know this.

Thanks again for the help!


All times are GMT -5. The time now is 01:41 PM.