LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 03-27-2006, 03:20 PM   #1
bretcurry
LQ Newbie
 
Registered: Sep 2003
Location: 24291 San Juan Drive, Tehachapi, CA 93561
Distribution: debian-woody
Posts: 21

Rep: Reputation: 15
Angry Nvidia Tnt2


Is there anyway to get the sax2 -m 0=nvidia going? Its the only way for 3d acceleration. I'm running Suse 10.0. I've tried the 6111 and 7174 drivers as they are the only ones that work with the TNT2 card. I've installed the kernel-sources and kernel-devel. It never works!
 
Old 03-27-2006, 03:30 PM   #2
Mega Man X
LQ Guru
 
Registered: Apr 2003
Location: ~
Distribution: Ubuntu, FreeBSD, Solaris, DSL
Posts: 5,339

Rep: Reputation: 64
You could try to manually edit your /etc/X11/xorg.conf file (or whatever it's called in SuSE 10), find the line where it stands "driver = nv" (or something similar to that) and change nv to "nvidia". I remember installing Nvidia drivers in SuSE 9.1 through YOU. It was a brezzy and you didn't need kernel-sources and devel to get it to run.
 
Old 03-27-2006, 04:45 PM   #3
bretcurry
LQ Newbie
 
Registered: Sep 2003
Location: 24291 San Juan Drive, Tehachapi, CA 93561
Distribution: debian-woody
Posts: 21

Original Poster
Rep: Reputation: 15
YOU doesn't have nvidia drivers

YOU doesn't have NVIDIA drivers and changing the xorg.conf file didn't work
 
Old 03-27-2006, 05:02 PM   #4
jens
Senior Member
 
Registered: May 2004
Location: Belgium
Distribution: Debian, Slackware, Fedora
Posts: 1,406

Rep: Reputation: 246Reputation: 246Reputation: 246
YOU works simular as Apt so whatever it has depends on the repos you configure.
As Mega Man X said, try it manually.
So I take the nVidia installer gave no errors?
Did you make sure its module is running (force it by running "modprobe nvidia")?
Apart from changing the driver, also add Load "glx" and remove Load GLcore and Load Dri(unless you used some rpms that don't conflict with it).
If that still doesn't work, post your full /etc/X11/xorg.conf file.
 
Old 03-27-2006, 05:17 PM   #5
bretcurry
LQ Newbie
 
Registered: Sep 2003
Location: 24291 San Juan Drive, Tehachapi, CA 93561
Distribution: debian-woody
Posts: 21

Original Poster
Rep: Reputation: 15
The 7174 installation gave no error, but changing the driver to nvidia doesn't work.
modprobe nvidia says:
FATAL: Error inserting nvidia (/lib/modules/2.6.13-15-default/kernel/drivers/video/nvidia.ko): Unknown symbol in module, or unknown parameter (see dmesg)

This is my xorg.conf file:
# /.../
# SaX generated X11 config file
# Created on: 2006-03-26T10:06:32-0800.
#
# Version: 7.1
# Contact: Marcus Schaefer <sax@suse.de>, 2002
#
# Automatically generated by [SaX2] (7.1)
# PLEASE DO NOT EDIT THIS FILE!
#

Section "Files"
FontPath "/usr/X11R6/lib/X11/fonts/misc:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/local"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/Type1"
FontPath "/usr/X11R6/lib/X11/fonts/URW"
FontPath "/usr/X11R6/lib/X11/fonts/Speedo"
FontPath "/usr/X11R6/lib/X11/fonts/PEX"
FontPath "/usr/X11R6/lib/X11/fonts/cyrillic"
FontPath "/usr/X11R6/lib/X11/fonts/latin2/misc:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/latin2/75dpi:unscaled"
linux:/home/bcurry # cat /etc/X11/xorg.conf
# /.../
# SaX generated X11 config file
# Created on: 2006-03-26T10:06:32-0800.
#
# Version: 7.1
# Contact: Marcus Schaefer <sax@suse.de>, 2002
#
# Automatically generated by [SaX2] (7.1)
# PLEASE DO NOT EDIT THIS FILE!
#

Section "Files"
FontPath "/usr/X11R6/lib/X11/fonts/misc:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/local"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/Type1"
FontPath "/usr/X11R6/lib/X11/fonts/URW"
FontPath "/usr/X11R6/lib/X11/fonts/Speedo"
FontPath "/usr/X11R6/lib/X11/fonts/PEX"
FontPath "/usr/X11R6/lib/X11/fonts/cyrillic"
FontPath "/usr/X11R6/lib/X11/fonts/latin2/misc:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/latin2/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/latin2/100dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/latin2/Type1"
FontPath "/usr/X11R6/lib/X11/fonts/latin7/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/baekmuk:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/japanese:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/kwintv"
FontPath "/usr/X11R6/lib/X11/fonts/truetype"
FontPath "/usr/X11R6/lib/X11/fonts/uni:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/CID"
FontPath "/usr/X11R6/lib/X11/fonts/ucs/misc:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/ucs/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/ucs/100dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/hellas/misc:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/hellas/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/hellas/100dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/hellas/Type1"
FontPath "/usr/X11R6/lib/X11/fonts/misc/sgi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/xtest"
FontPath "/opt/kde3/share/fonts"
InputDevices "/dev/ttyS0"
InputDevices "/dev/ttyS1"
InputDevices "/dev/ttyS2"
InputDevices "/dev/ttyS3"
InputDevices "/dev/ttyS4"
InputDevices "/dev/ttyS5"
InputDevices "/dev/ttyS6"
InputDevices "/dev/ttyS7"
InputDevices "/dev/ttyS8"
InputDevices "/dev/psaux"
InputDevices "/dev/logibm"
InputDevices "/dev/sunmouse"
InputDevices "/dev/atibm"
InputDevices "/dev/amigamouse"
InputDevices "/dev/atarimouse"
InputDevices "/dev/inportbm"
InputDevices "/dev/gpmdata"
InputDevices "/dev/mouse"
InputDevices "/dev/usbmouse"
InputDevices "/dev/adbmouse"
InputDevices "/dev/input/mice"
InputDevices "/dev/input/event0"
InputDevices "/dev/pointer0"
InputDevices "/dev/pointer1"
InputDevices "/dev/pointer2"
InputDevices "/dev/pointer3"
EndSection

Section "Module"
Load "dbe"
Load "type1"
Load "freetype"
Load "extmod"
Load "glx"
Load "v4l"
EndSection

Section "ServerFlags"
Option "AllowMouseOpenFail"
EndSection

Section "InputDevice"
Driver "kbd"
Identifier "Keyboard[0]"
Option "Protocol" "Standard"
Option "XkbLayout" "us"
Option "XkbModel" "pc104"
Option "XkbRules" "xfree86"
EndSection

Section "InputDevice"
Driver "mouse"
Identifier "Mouse[1]"
Option "Buttons" "5"
Option "Device" "/dev/input/mice"
Option "Name" "Logitech Optical Wheel Mouse"
Option "Protocol" "explorerps/2"
Option "Vendor" "Sysp"
Option "ZAxisMapping" "4 5"
EndSection


Section "Monitor"
DisplaySize 320 240
HorizSync 30-71
Identifier "Monitor[0]"
ModelName "SYNCMASTER 753DF(T) 783DF(T) MAGICSYNCMASTER AQ17DF"
Option "DPMS"
VendorName "SAMSUNG"
VertRefresh 50-160
UseModes "Modes[0]"
EndSection


Section "Modes"
Identifier "Modes[0]"
Modeline "1024x768" 95.50 1024 1088 1200 1376 768 769 772 807
Modeline "1024x768" 86.18 1024 1088 1200 1376 768 769 772 803
Modeline "1024x768" 73.89 1024 1080 1192 1360 768 769 772 799
Modeline "800x600" 74.67 800 848 936 1072 600 601 604 639
Modeline "800x600" 73.98 800 848 936 1072 600 601 604 639
Modeline "800x600" 66.71 800 848 936 1072 600 601 604 635
Modeline "800x600" 58.73 800 840 928 1056 600 601 604 632
Modeline "800x600" 51.73 800 840 928 1056 600 601 604 628
Modeline "800x600" 44.13 800 840 920 1040 600 601 604 624
Modeline "640x480" 60.09 640 680 752 864 480 481 484 519
Modeline "640x480" 57.18 640 680 752 864 480 481 484 517
Modeline "640x480" 51.43 640 680 744 848 480 481 484 514
Modeline "640x480" 46.80 640 680 744 848 480 481 484 511
Modeline "640x480" 42.22 640 680 744 848 480 481 484 508
Modeline "640x480" 36.97 640 672 736 832 480 481 484 505
Modeline "640x480" 32.64 640 672 736 832 480 481 484 503
Modeline "640x480" 27.74 640 664 728 816 480 481 484 500
EndSection


Section "Device"
BoardName "RIVA TNT2 Model 64/Model 64 Pro"
BusID "0:16:0"
Driver "nv"
Identifier "Device[0]"
VendorName "NVidia"
EndSection


Section "Screen"
DefaultDepth 24
SubSection "Display"
Depth 15
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 32
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1024x768" "800x600" "640x480"
EndSubSection
Device "Device[0]"
Identifier "Screen[0]"
Monitor "Monitor[0]"
EndSection


Section "ServerLayout"
Identifier "Layout[all]"
InputDevice "Keyboard[0]" "CoreKeyboard"
InputDevice "Mouse[1]" "CorePointer"
Screen "Screen[0]"
EndSection

Section "DRI"
Group "video"
Mode 0660
EndSection
 
Old 03-29-2006, 01:42 AM   #6
Mega Man X
LQ Guru
 
Registered: Apr 2003
Location: ~
Distribution: Ubuntu, FreeBSD, Solaris, DSL
Posts: 5,339

Rep: Reputation: 64
Well, I'm afraid I can't help much then. However, I found this that may help you out:

http://www.suse.de/~sndirsch/nvidia-...ler-HOWTO.html
 
Old 03-29-2006, 07:24 AM   #7
bretcurry
LQ Newbie
 
Registered: Sep 2003
Location: 24291 San Juan Drive, Tehachapi, CA 93561
Distribution: debian-woody
Posts: 21

Original Poster
Rep: Reputation: 15
NVIDIA Drivers

I've tried the SUSE instructions with 6111, which is suppose to work with TNT2. But I get the error: "ERROR: cannot compile kernel".
 
Old 03-29-2006, 12:47 PM   #8
cferron
Member
 
Registered: Jan 2006
Location: Trois-Rivières, Québec, Canada
Distribution: Slackware, Ubuntu
Posts: 74

Rep: Reputation: 15
maybe this could help

Code:
Section "Device"
BoardName "RIVA TNT2 Model 64/Model 64 Pro"
BusID "0:16:0"
Driver "nv"
Identifier "Device[0]"
VendorName "NVidia"
EndSection
instead of driver nv try nvidia

Code:
Section "Device"
BoardName "RIVA TNT2 Model 64/Model 64 Pro"
BusID "0:16:0"
Driver "nvidia"
Identifier "Device[0]"
VendorName "NVidia"
EndSection

oups... just realize that this solution was already suggested... sorry
claude

Last edited by cferron; 03-29-2006 at 12:49 PM.
 
Old 03-29-2006, 01:35 PM   #9
jens
Senior Member
 
Registered: May 2004
Location: Belgium
Distribution: Debian, Slackware, Fedora
Posts: 1,406

Rep: Reputation: 246Reputation: 246Reputation: 246
Quote:
Originally Posted by bretcurry
The 7174 installation gave no error, but changing the driver to nvidia doesn't work.
modprobe nvidia says:
FATAL: Error inserting nvidia (/lib/modules/2.6.13-15-default/kernel/drivers/video/nvidia.ko): Unknown symbol in module, or unknown parameter (see dmesg)
'k so your nvidia module isn't working(meaning you don't have to look for X related problems)

Could you post the output from both:
less /dev/nvidia* and
less /etc/udev/devices/

Last edited by jens; 03-29-2006 at 01:45 PM.
 
Old 03-29-2006, 01:47 PM   #10
mushk45
LQ Newbie
 
Registered: Sep 2005
Distribution: Slackware 10.0 , Fedora 3, SUSE 9.2, Knoppix 5.0.1 (Live CD)
Posts: 25

Rep: Reputation: 15
did you check the Nvidia-OpenGL-Configuration Howto?
http://www.tldp.org/HOWTO/Nvidia-Ope...ion/index.html

be prepared for a lot of reading!

also see the readme that came with the Nvidia driver if you got the driver from Nvidia's website.

P.S. I have an NVIDIA graphics^n sticker on my door
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
NVIDIA TNT2 problems. I already scanned all the NVIDIA stuff I could find on here. Crashlander42 Linux - Newbie 5 03-24-2004 03:49 PM
nvidia drivers / nv vs nvidia & TNT2 trekk Fedora 0 01-26-2004 01:11 PM
Tv-out with nvidia tnt2 ultra andjo960 Linux - Hardware 3 11-05-2003 01:55 AM
Nvidia TNT2 problems Darkfire Linux - Hardware 10 05-31-2003 02:36 PM
NVidia TNT2 Christo Linux - Software 2 10-10-2001 10:09 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 03:03 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration