-   Linux - Hardware (
-   -   nvidia optimus problem (

amalgamas 08-24-2011 01:04 AM

nvidia optimus problem
I recently bought a ASUS N73S laptop with GeForce 540M videocard that has the optimus technology. Now I cannot get composite video and my beloved compiz cube. I use ubuntu 11.04 with gnome desktop (not unity).

I don't care about the optimus memory switching to save energy, this PC is almost always connected. I bought it because it has a decent built in sound system and speakers. I also don't game. I just want that cube working.

I have installed the nvidia extra driver. That stalls the boot process and I have to use ctrl-alt-F1, log in and delete /etc/X11/xorg.conf. Then the machine boots but without composite video.

I have tried to install bumblebee, but haven't found a understandable guide on how to install and use it. So I am not able to get this working.

Is there anyone out there that can guide me through the process of getting composite video in a way that a newbe can understand?

EDDY1 08-24-2011 10:18 PM

Change subsitute the driver for your machine.

amalgamas 08-25-2011 04:34 AM

Thank you for your reply, and great guide to Compiz. But the problem is missing support for nvidia Optimus cards, or that I am not able to get this right.

If someone knows how to set up Bumblebee and the nVidia GeForce 540M drivers correctly, please guide me through the process.

cascade9 08-25-2011 04:38 AM


Compiz is disabled by default if you're using classic desktop.

First you need to disable Ubuntu Unity Plugin from CompizConfigSettings-manager.

Then you can run compiz with:

compiz --replace

You may also want to make a startup task to run compiz every time you boot Ubuntu.

You can do this from Preferences -> Startup Applications

I'd also suggest disabling the nVidia GPU. Or seeing if you have a BIOS option to 'force' the nVidia GPU.

H_TeXMeX_H 08-25-2011 06:00 AM

I don't have any experience with newer Ubuntus. However, I have a netbook with optimus, and it works with the nvidia card if I disable / blacklist the intel drivers and maybe agpgart (not really necessary), and install the nvidia drivers. You should check your BIOS settings tho, because there may be an option for it there.

amalgamas 08-25-2011 05:06 PM

That looked promising, so I blacklisted the i915- (Intel-) driver and activated tha nVidia extra driver. I ran <sudo gedit /etc/modprobe.d/blacklist.conf> and added "blacklist i915". I also ran nvidia-xconfig as root. After this the bootprocess stalled at something called Plymuth (I am a newbee with linux). This is the same thing that happened with my tries with bumblebee/nVidia.

I deleted /etc/X11/xorg.conf, rebooted and had working video again, but without composite video and the compiz cube, as before.

I still hope for some solution to this. I have seen some people on the net that claim that they havce working composite video with ASUS n53 and n73.

H_TeXMeX_H 08-26-2011 09:37 AM

For xorg.conf use:


Section "Module"
        SubSection  "extmod"
                Option    "omit xfree86-dga"  # don't initialise the DGA extension

Section "Device"
    Identifier    "nvidia"
    Driver        "nvidia"
    VendorName    "NVIDIA Corporation"
    Option "UseEvents" "1"
    Option "Coolbits" "4"

amalgamas 08-27-2011 06:16 AM

Thank you for this answer. I am travelling at the moment, but I will try this when I get home sunday night.

amalgamas 08-29-2011 11:48 AM

Finally I found the time to try H_TeXMeX_H's suggestion. The boot process stalls at the same place.

I need more help!

H_TeXMeX_H 08-29-2011 12:28 PM

Can you post the output of these commands:


lspci -k

amalgamas 08-29-2011 06:01 PM

PHP Code:

Module                  Size  Used by
md4                    12595  0 
binfmt_misc            17565  1 
sco                    18187  2 
bnep                   18308  2 
l2cap                  53570  3 bnep
vboxnetadp             13382  0 
vboxnetflt             28297  0 
vboxdrv               268268  2 vboxnetadp
parport_pc             36959  0 
ppdev                  17113  0 
nls_utf8               12557  3 
cifs                  272463  6 
dm_crypt               22993  0 
snd_hda_codec_hdmi     28167  1 
snd_hda_codec_realtek   336771  1 
i915                  515121  2 
drm_kms_helper         42136  1 i915
arc4                   12529  2 
snd_hda_intel          33176  1 
nvidia              11705367  0 
snd_hda_codec         103804  3 snd_hda_codec_hdmi
snd_hwdep              13604  1 snd_hda_codec
snd_pcm                96391  3 snd_hda_codec_hdmi
snd_seq_midi           13324  0 
snd_rawmidi            30486  1 snd_seq_midi
uvcvideo               72195  0 
ath9k                 118238  0 
joydev                 17606  0 
snd_seq_midi_event     14899  1 snd_seq_midi
videodev               82052  1 uvcvideo
asus_nb_wmi            12517  0 
asus_wmi               24204  1 asus_nb_wmi
sparse_keymap          13898  1 asus_wmi
snd_seq                61621  2 snd_seq_midi
v4l2_compat_ioctl32    17078  1 videodev
btusb                  18600  1 
snd_timer              29602  2 snd_pcm
snd_seq_device         14462  3 snd_seq_midi
bluetooth              72320  8 sco
mac80211              294370  1 ath9k
drm                   227534  3 i915
snd                    67382  12 snd_hda_codec_hdmi
i2c_algo_bit           13400  1 i915
ath9k_common           13851  1 ath9k
ath9k_hw              323077  2 ath9k
ath                    23773  2 ath9k
psmouse                73535  0 
cfg80211              178528  3 ath9k
soundcore              12680  1 snd
snd_page_alloc         18529  2 snd_hda_intel
serio_raw              13166  0 
lp                     17825  0 
parport                46458  3 parport_pc
usbhid                 46956  0 
hid                    91020  1 usbhid
dm_raid45              77827  0 
xor                    12890  1 dm_raid45
btrfs                 550457  0 
zlib_deflate           27074  1 btrfs
libcrc32c              12644  1 btrfs
vesafb                 13761  0 
ahci                   25951  4 
libahci                26642  1 ahci
atl1c                  41171  0 
xhci_hcd               77643  0 
video                  19438  1 i915
ramzswap               13408  0 
xvmalloc               13767  1 ramzswap 

lspci -k:
PHP Code:

00:00.0 Host bridgeIntel Corporation 2nd Generation Core Processor Family DRAM Controller (rev 09)
SubsystemASUSTeK Computer IncDevice 11d7
    Kernel driver in 
use: agpgart-intel
:01.0 PCI bridgeIntel Corporation 2nd Generation Core Processor Family PCI Express Root Port (rev 09)
Kernel driver in use: pcieport
    Kernel modules
:02.0 VGA compatible controllerIntel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
SubsystemASUSTeK Computer IncDevice 15e2
    Kernel driver in 
use: i915
    Kernel modules
:16.0 Communication controllerIntel Corporation 6 Series Chipset Family MEI Controller #1 (rev 04)
SubsystemASUSTeK Computer IncDevice 11d7
:1a.0 USB ControllerIntel Corporation 6 Series Chipset Family USB Enhanced Host Controller #2 (rev 05)
SubsystemASUSTeK Computer IncDevice 11d7
    Kernel driver in 
use: ehci_hcd
:1b.0 Audio deviceIntel Corporation 6 Series Chipset Family High Definition Audio Controller (rev 05)
SubsystemASUSTeK Computer IncDevice 1a33
    Kernel driver in 
use: HDA Intel
    Kernel modules
:1c.0 PCI bridgeIntel Corporation 6 Series Chipset Family PCI Express Root Port 1 (rev b5)
Kernel driver in use: pcieport
    Kernel modules
:1c.1 PCI bridgeIntel Corporation 6 Series Chipset Family PCI Express Root Port 2 (rev b5)
Kernel driver in use: pcieport
    Kernel modules
:1c.3 PCI bridgeIntel Corporation 6 Series Chipset Family PCI Express Root Port 4 (rev b5)
Kernel driver in use: pcieport
    Kernel modules
:1c.5 PCI bridgeIntel Corporation 6 Series Chipset Family PCI Express Root Port 6 (rev b5)
Kernel driver in use: pcieport
    Kernel modules
:1d.0 USB ControllerIntel Corporation 6 Series Chipset Family USB Enhanced Host Controller #1 (rev 05)
SubsystemASUSTeK Computer IncDevice 11d7
    Kernel driver in 
use: ehci_hcd
:1f.0 ISA bridgeIntel Corporation HM65 Express Chipset Family LPC Controller (rev 05)
SubsystemASUSTeK Computer IncDevice 11d7
    Kernel modules
:1f.2 SATA controllerIntel Corporation 6 Series Chipset Family 6 port SATA AHCI Controller (rev 05)
SubsystemASUSTeK Computer IncDevice 11d7
    Kernel driver in 
use: ahci
    Kernel modules
:1f.3 SMBusIntel Corporation 6 Series Chipset Family SMBus Controller (rev 05)
SubsystemASUSTeK Computer IncDevice 11d7
    Kernel modules
:00.0 VGA compatible controllernVidia Corporation Device 0df4 (rev a1)
SubsystemASUSTeK Computer IncDevice 15e2
    Kernel driver in 
use: nvidia
    Kernel modules
:00.0 Network controllerAtheros Communications IncAR9285 Wireless Network Adapter (PCI-Express) (rev 01)
SubsystemAzureWave Device 2c37
    Kernel driver in 
use: ath9k
    Kernel modules
:00.0 USB ControllerFresco Logic FL1000G USB 3.0 Host Controller (rev 04)
SubsystemASUSTeK Computer IncDevice 1039
    Kernel driver in 
use: xhci_hcd
    Kernel modules
:00.0 Ethernet controllerAtheros Communications Device 1083 (rev c0)
SubsystemASUSTeK Computer IncDevice 1851
    Kernel driver in 
use: atl1c
    Kernel modules

H_TeXMeX_H 08-30-2011 05:37 AM

I cannot be sure of the exact way to fix it, you'll just have to mess with it until it works.

I would blacklist:

If some of these are not built as modules, you may need to compile a new kernel and disable them.

amalgamas 08-30-2011 10:31 AM

Ok, and thanks anyway. The search for the solution continues....

EDIT: and by the way, this is what sucks with linux. The OP and the software works perfectly if the hardware complies. I have 5 computers running different versions of ubuntu at home, one has this display problem, two have network problems (random glitches) that I haven't been able to solve. Two work perfectly. I love it when it works!

cascade9 08-31-2011 05:13 AM

I really dont think you will get the nVidia GPU going with a 'optimus' setup by just blacklisting intel video modules.

Have you seen this page?


Originally Posted by amalgamas (Post 4457114)
EDIT: and by the way, this is what sucks with linux. The OP and the software works perfectly if the hardware complies.

I'd actually say 'this is what sucks when nVidia tries to compete with intel for video hardware, then make a really cheap and nasty solution with no linux support'.

As much as I dont like intel in the video game, they have NEVER made a video chip that could compete with nVidia or AMD (+ 3DFX, matrox etc 'back in the day'), I'd rather have intel video that works over nVidia video that doesnt work.

H_TeXMeX_H 08-31-2011 01:36 PM

Ubuntu is not Linux.

I've never gotten "optimus" to run on Linux, even with the useless bumblebee. However, I have been able to get the nvidia card working, which is all I really care about, because the Intel card is absolute s***.

I did compile my own kernel.

All times are GMT -5. The time now is 12:40 PM.