Visit Jeremy's Blog.
Go Back > Forums > Linux Forums > Linux - Hardware
User Name
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?


  Search this Thread
Old 01-18-2004, 01:10 AM   #1
LQ Newbie
Registered: Jan 2004
Location: DC area
Distribution: varies
Posts: 9

Rep: Reputation: 0
(Solved) Nvidia onboard ethernet problem - installed drivers, still does not work

EDIT: Problem solved - it was the cable modem - had to unplug it from its power because it locks onto MAC addresses - see my post down below.

Hi all,

First let me say that I've searched and searched, I've spent 2 days trying to find an answer to this. I've learned a lot about it, but not enough to fix my problem. I've now tried this first in Debian, then in Fedora. So I know the problem is not just one distro. I'll describe it mostly in Fedora since that's what I'm currently using.

The short summary (before my long explanation) is that I installed Nvidia's drivers, but still the ethernet does not work.

I have an Asus A7N8X-X motherboard which uses on-board Nvidia nforce ethernet and sound. I can't get the ethernet to work. There are 2 options: install drivers from Asus, or install drivers from Nvidia. Asus only makes Linux drivers for Redhat and Slackware; plus I've read it's better to go with Nvidia. (By the way, I've tried the Redhat install on Fedora, it's no good, just a ton of parse-type errors).

I went to Nvidia's website and downloaded their drivers for the board. (was going to post the URL here, but I have under 5 posts so I can't). I got the tar.gz from the bottom of the page, followed the instructions. I had some problems about include files, so I got the source package for my kernel (2.4.22-1.2115.nptl currently; the Debian version was something like 2.4.18-bf). After setting the appropriate pointers, and adding in a Tab before a period at the end of a make file that was giving me a "*** Missing separator" error message, the drivers installed just fine.

I added the following line to modules.conf:
alias eth0 nvnet

Then I added it also to modprobe.conf when the first didn't fix the problem, but still no success.

What happens now is that when I boot the computer, the bootup pauses for a long time when it tries to get to the network (using DHCP as is required for my cable modem), then fails and moves on. The computer recognizes eth0 but it's as if eth0 is talking to a void. It's also interesting to note that if I remove the ethernet cable before booting the computer, the network setup on bootup fails much faster and suggests that the cord is unplugged.

I don't know what else to do. When I had Debian, I also added the following to /etc/network/interfaces:
auto eth0
iface eth0 inet dhcp

which told Debian that I wanted to have DHCP. But Fedora seems to know that I want DHCP - it did ask me on my first bootup after installing the Nvidia drivers if it should configure the card, and I told it yes. I'm pretty sure the problem is not DHCP. I know that when I had Debian I installed dhcp-client, and I saw it sending requests and getting nothing back.

Anyway, I think that's about all I know. So I'll leave you with some files.

Output from /sbin/ifconfig:
eth0 Link encap:Ethernet HWaddr 00:0C:6E:B7:89:9E
RX packets:9950 errors:0 dropped:0 overruns:0 frame:0
TX packets:6 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:603435 (589.2 Kb) TX bytes:2052 (2.0 Kb)
Interrupt:11 Base address:0x1000

Plus info about the loopback interface which I assume is not relevant. When the ethernet cable is unplugged, eth0 doesn't show up under ifconfig.

lspci -v (the ethernet part):
00:04.0 Ethernet controller: nVidia Corporation nForce2 Ethernet Controller (rev a1)
Subsystem: Asustek Computer, Inc.: Unknown device 80a7
Flags: bus master, 66Mhz, fast devsel, latency 0, IRQ 11
Memory at e2001000 (32-bit, non-prefetchable) [size=4K]
I/O ports at d400 [size=8]
Capabilities: [44] Power Management version 2

I would be willing to go buy a cheap network card, but I'm not sure I won't have the same exact problem I'm having now. I've gotta be missing something fairly simple. I did come across a thread that suggested disabling ACPI helped, but I tried putting "option acpi=off" in grub.conf (something like that; don't remember exactly) but it didn't make any difference. I have seen mentions of ACPI in some log files, so if that's possibly the cause, please tell me how to disable it. I haven't been able to find how to disable it (with grub) short of recompiling the kernel.

I'll be glad to provide any more info that might be relevant, just ask. Thanks in advance for the help. This is very frustrating and tiring.

Last edited by SilverGator; 01-19-2004 at 02:25 PM.
Old 01-18-2004, 03:28 AM   #2
Registered: Aug 2003
Location: England
Distribution: SuSE 9.3 pro
Posts: 332

Rep: Reputation: 30
I had exactly the same problem. My reply is not in the spirit of this board etc, but it got rid of all my frustrations in 5 seconds:

I looked at the list of supported network cards in my distribution & went and bought one. It worked immediately, and the whole network is faster than it was before

(I had the nvnet drivers working with suse 8,2 but never got them working with suse 9.0 after a kernel upgrade...........)
Old 01-18-2004, 06:09 AM   #3
Senior Member
Registered: Dec 2002
Location: Atlantic City, NJ
Distribution: Ubuntu & Arch
Posts: 3,503

Rep: Reputation: 57
I have that same motherboard and I use the forcedeth patch. It works good. Give it a shot.
Old 01-18-2004, 03:48 PM   #4
LQ Newbie
Registered: Jan 2004
Location: DC area
Distribution: varies
Posts: 9

Original Poster
Rep: Reputation: 0
forcedeth didn't work, I downloaded it and entered the patch command, and it just hung there. I gave it about 20 minutes, cancelled it, and tried again. After about 30 more minutes I cancelled it.

Ok, so I went out and bought a cheap NIC (Netgear). Fedora recognized it and auto-configured it. And I have the exact same problem - I still can't get out to the internet. eth1 (the new card) fails on bootup just like eth0 (on-board lan) did.
Old 01-19-2004, 11:15 AM   #5
LQ Newbie
Registered: Jan 2004
Location: West Hartford, CT
Distribution: Ubuntu
Posts: 24

Rep: Reputation: 15
I'm having the same problem with my Abit NF7 in Mandrake 9.2.
Old 01-19-2004, 11:41 AM   #6
LQ Newbie
Registered: Jan 2004
Distribution: Redhat 9
Posts: 4

Rep: Reputation: 0
Hey, I have the A7n8x-x and had the same problem, running Redhat9. As far as I can recall, I simply followed all the instructions on the Nvidia readme and it worked OK....
Old 01-19-2004, 02:23 PM   #7
LQ Newbie
Registered: Jan 2004
Location: DC area
Distribution: varies
Posts: 9

Original Poster
Rep: Reputation: 0
Turns out it was the cable modem - I wasn't aware that cable modems lock onto one MAC address and then can't work with any other until you unplug the power from the cable modem. Isn't that something the cable company should have told me? I think I'm going to write a letter.

So basically, after plugging the cable modem into my new computer - the one that had the problems - I just had to unplug the power from the cable modem for a few seconds then plug it back in, then reactivate the network connection on the computer, then it worked.

Thanks a lot to everyone who helped, I really appreciate it.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Onboard Nvidia Ethernet in Suse 9.1 64bit puppy Linux - Hardware 7 05-02-2006 05:58 PM
Proprietary nvidia drivers vs. generic intel sound and ethernet drivers vharishankar Linux - Hardware 2 02-22-2005 05:32 AM
Nvidia nForce Ethernet Drivers boardinglaxplr Linux - Networking 2 02-10-2004 07:01 AM
Display Problem exiting X with Nvidia drivers installed basemodel Slackware 4 10-25-2003 10:48 AM
Just installed Debian can't get ethernet to work ARL002 Linux - Networking 1 09-14-2002 09:13 AM > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 02:34 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration