LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (https://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   nvidia nforce network adapter has different MAC adress every boot (https://www.linuxquestions.org/questions/linux-hardware-18/nvidia-nforce-network-adapter-has-different-mac-adress-every-boot-569576/)

bartrouw 07-15-2007 04:50 PM

nvidia nforce network adapter has different MAC adress every boot
 
Hello everyone

I have an A7N8X-X mobo and i'm using suse 10.0 with 2.6 kernel.

I can't get my nvidia onboard NIC working properly. When i boot it is recognised properly. When i configure it using YAST it works properly using DHCP. But when i reboot my pc it gets another mac adress and another interface name. if the previous interface name was eth40, the new interface gets eth41. So i configure the new interface, it works, I reboot, it does not work, and so on.

I tried the newest forcedeth driver but that didn't make a difference. can anyone point me in the right direction? Why does my networkcard has a different mac adress every time i boot?

ifconfig gives:
eth45 Link encap:Ethernet HWaddr 00:00:6C:9F:04:72
BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
Interrupt:11 Base address:0xe000


thanks in advance
Bart

ps. I bought the A7N8X-X a couple of years ago. Till now i used another NIC. But now i want to use the onboard one because of the WakeupOnLan feature.

bartrouw 07-15-2007 05:15 PM

Why does my networkcard has a different mac adress every time i boot?
I found in /var/log/warn the following:
Jul 15 21:22:15 linux kernel: 0000:00:04.0: Invalid Mac address detected: 00:00:00:00:00:00
Jul 15 21:22:15 linux kernel: Please complain to your hardware vendor. Switching to a random MAC.

bartrouw 07-21-2007 05:53 PM

Hello,

Let me explain my question more clearly.

I can't figure out where to start. I mean both the interface name and the mac address change, so i can't just edit the ifcfg-eth40 or edit ifcfg-eth-id-00:00:6c:66:0a:e4. Many websites suggest that as a solution by setting the LLADDR flag. But that doesn't work in the case of random MAC addresses.

Does anyone now how to disable random mac address and suply a static one. I mean supply one to the device directly, in my case /sys/devices/pci0000:00/0000:00:00.4 (the id of my NIC). Can this be done in some startup script? I read something about hwup on: http://en.opensuse.org/SDB:SUSE_Linu..._Configuration

I'm still new to linux, please help

bartrouw 07-22-2007 09:21 AM

persistent name
 
Hello,

I found out how to make the name of the interface persistant. I did read the section about udev in:
/usr/share/doc/manual/suselinux-manual_en/manual/sec.udev.keys.html

So i changed the rule in:
/etc/udev/rules.d/30-net_persistent_names.rules
from:
#SUBSYSTEM=="net", ACTION=="add", SYSFS{address}=="00:00:6c:66:0a:e4", IMPORT="/sbin/rename_netiface %k eth1"
to:
SUBSYSTEM=="net", ACTION=="add", ID=="0000:00:04.0", IMPORT="/sbin/rename_netiface %k eth1"

So now i'm sure my nic always gets the same interface name because the rule is based on pci bus id instead of the random choosen MAC address.

I thought now i can rename my ifcfg file in /etc/sysconfig/network to ifcfg-eth1 and set LLADDR. Till now that doesn't work. I still have a random MAC (and get a different ip).

I'm gettin better in monologues :)

Anyone?

Hern_28 07-23-2007 11:18 AM

Try using the serial number.
 
You can write a new udev rule specifying the network card specifically by serial number. There are lots of resources available, just google writing udev rules.

A link that might give you a few more options:

http://www.reactivated.net/writing_udev_rules.html
http://www.linuxquestions.org/questi...d.php?t=563356

These links should help you write a udev rule that over-rides the normal musical udev startup. The second one can be used as an exaple of an alternative method of specifying and naming devices.

mann3r 10-25-2007 05:19 AM

dont know if this issue was solved and sorry if i bring up this old thread, just got it on google search with the same problem I have, but now trying to solve the issue and googling end up on another thread
http://www.debianhelp.org/node/9481,
setting check on CMOS setup. might worth a try at your end.

PKR951 10-25-2007 08:25 PM

Sadly, it appears I'm having the same problem :(
From what I've gathered thus far it looks like a bug in forcedeth.c.
My SuSe 10.2 AMD64 installation has version 0.56 and the problem is said to be resolved in version 0.59 (or 0.60), which of course doesn't seem to be available for my environment.
If I'm way off and the cause/solution is different, by all means, please let me know. Good luck!


All times are GMT -5. The time now is 07:19 AM.