-   Linux - Hardware (
-   -   Nvidia GF4 MX440 running really slow (

liljim 03-27-2004 10:53 AM

Nvidia GF4 MX440 running really slow
I have a inno 3d 128 meg ddr nvidia GeForce 4 4x agp card that runs super slow on mandrake 10.Screensavers are impossible to run,i can literally count the frames in the animation.This is with any 3d graphics,any ideas how to speed it up?

DrOzz 03-27-2004 11:22 AM

you have to install the nvidia drivers which you get from the website ... by default when you install a distro you will be using the generic drivers that do not have 3d acceleration ..

liljim 03-27-2004 01:07 PM

Thanks...going dl them now

vi0lat0r 03-27-2004 02:18 PM

There are 2 requirements:

1) The NVidia Drivers
2) Your kernel's source

To find out your kernel make, type this in the terminal:

uname -r

To get your kernel's source package, simply type this in the terminal:


(it will ask for your root password, type it in)

urpmi kernel
It will come up with about 18 packages. Whatever kernel you are using, choose the corresponding src package. For example, I am using 2.6.4-1.tmb.5mdk, so the source I chose was 2.6.4-1.src.tmb (something like that...)

After you have done the above, you are set to begin the NVidia installation. Press CTRL + ALT + F1 to exit X. Then type


init 1
This will stop all of your system processes that are running. Then type


init 2
Now you are in the run level where you can install the driver. CD to the folder where the is located.

For example:


Then type:


It will show you all the files in the directory, including the one you need,

Now type:


If that is not the name of your file, you probably have an older version and just replace it with your NVIDIA-Linux-BLAH package name.

It will start the installation. Choose Accept and press Enter. Go through the installation, pretty much answering "Yes" to anything that will get it installed. Meaning, if it says it can't find the module for the kernel and it asks to build a module, tell it yes. This is where your kernel's source comes into play ;-)

After it is done installing it will say Installation Successful (or something like that). You will still be in run level 2, so type the following to get back to your X enviroment:


init 5
It will load up to the login screen, unless you set it to automatically login, in which case you will start KDE or Gnome, whichever is your default. Now open KEdit. Choose to open a file, and browse to:

/etc/X11/XF86Config-4 (if XF86Config-4 exists, choose it. If not, choose XF86Config)

Now find where it says

Section "Module"
Here is what mine looks like (I am also using GeForce4 MMX 440 128MB DDR):


Section "Module"
    Load "dbe" # Double-Buffering Extension
    Load "v4l" # Video for Linux
    Load "extmod"
    Load "type1"
    Load "freetype"
    Load "glx" # 3D layer

All you should have to do is delete the ## in front of Load 'glx'

Find where it says Driver 'nv' or whatever for your graphics card, and replace it with:


    Driver "nvidia"
Save it, and you have now successfully installed and configured NVidia drivers. You should now restart your computer for the changes to take affect (you can restart X, but just go ahead and restart your computer... its easier)

liljim 03-27-2004 03:32 PM

Im running kernel 2.6.3-4mdk.When i ran urpmi kernel i only got 3 options to choose from,none of them had .src in the extension.I choose 2.6
.3-4 mdk and followed the rest of your instructions but im getting an error that the instalation couldnt find my kernel source or it wasnt installed.So now im back to square do i install the kernel source into the default directory that everything looks for (im having the same trouble with a pctel modem finding source)?I "thought" i had installed the source by checking avaliable packages and doing a search for kernel source.I selected everything on the list but still nothing sees that there installed.

vi0lat0r 03-27-2004 05:02 PM

I suggest you remove your main, contrib, plf, and update sources. You can do this through GUI by going to the Menu -> System -> Configuration -> Packaging -> Software Media Manager

Now go to:

Choose the servers you want, and click proceed. It will show you 4 lines of script.

Open a terminal and type:


Now type your password

You are now Super User. Copy 1 line of the script and paste it into the terminal. Do this for each of the 4 lines of script the site gave you.

If it says it could not connect, just look and see what the corresponding server was for (whether it was Update, Main, Contrib, or PLF), and choose a different server for it. Once you have entered a source you don't have to enter it again.

Once all 4 of the urpmi sources have been added, type this:


It might take anywhere from 10 seconds to 2 minutes. Once its complete, type:


urpmi kernel
And continue where that leaves off in my last post.

liljim 03-27-2004 06:42 PM

I dont have internet access in linux...currently fighting with a pctel amr modem.

vi0lat0r 03-27-2004 06:52 PM

Ok, what exactly is wrong with your modem? Is it not detecting it? Have you downloaded the drivers (in, I suppose, a seperate OS) but they are not working?

Can't really do much until we fix that problem :-)

Pwnz3r 03-27-2004 07:05 PM

Just a tip, dir is okay but in Linux ls also does the same thing and saves time. Not to mention, it stands for list and makes more sense than dir which stands for directory. ;)

Well, cd to /usr/src and make sure you have a sym link to the kernel you are using. To do this, become root and cd to the /usr/src folder and type the following command.


ln -s 2.6.3-4mdk linux
After doing that then try installing the nvidia drivers. Mandrake is a pretty terrible when it comes to giving kernel sources out. They are never given by them but required almost all the time. That's one of the reasons I switched to Gentoo from Mandrake. But I suppose Mandrake made for a good learning experience. ;)

liljim 03-27-2004 10:43 PM

Thanks Pwnz3r
I'll try that...

With the modem,i have the pctel-0.9.7-9 drivers that is giving me errors when i try to install.I ran across the same problem with the kernel source not being in the directory it needed to be in when i try to compile,i also got something about a modversion.h file not being there.I havent tried in a couple days so i dont remember the exact errors.Im dual booting with winxp for internet access and im obviously new to linux....The modem shows up as a sis with unknown module,my board chipset is sis735.I have a pci pctel modem that shows up the same way.I'll run the setup again and post the error.

liljim 03-28-2004 12:29 AM

Ok guys...i got mad and wiped out the drive...reinstalled mandrake 10.I had all kinds of stuff screwed up i think.Now im on a fresh install,i have kernel 2.4.25-2mdk running as default.I need to get my modem going and video drivers...where should i start?

vi0lat0r 03-28-2004 01:28 AM

First you need to get your modem working. What is the exact error you get when installing the drivers?

liljim 03-28-2004 01:57 AM

ok..beleive it or not,i got the video going with 2.6.3's where im at...

the modem drivers i have is only for 2.4.x kernel,naturally when i try to install in 2.6 i get an error that its only for 2.4

When i tried in 2.4 i got an error saying modversion.h doesnt exist.

Now this is where i seem to be screwed...Since i installed the video drivers in 2.6,
2.4 wont load a gui.I got a bunch of errors saying it couldnt load nvidia module.I assume the solution is that i need pctel drivers that will work on a 2.6 kernel,so far i havent found any. video works great,screensavers not run at top speed and i can play tux racer and other 3d games.Curious though...can i use my tv out now?I never found anything regarding it.Dont know where to look to enable it...Thank you for your help this far....i really appreciate it.

vi0lat0r 03-28-2004 02:04 AM

These should work, it says its for 2.6:

If that doesn't work take a look at the complete database:

vi0lat0r 03-28-2004 02:11 AM

I found this also, it has kernel source files for 2.6.3, PCTel modem, and Nvidia... might be worth a look:

All times are GMT -5. The time now is 05:42 PM.