-   Linux - Hardware (
-   -   Nvidia GeForce4 MX440 video issues (

dsyebert 09-15-2006 12:42 PM

Nvidia GeForce4 MX440 video issues
I just replaced my old (outdated) ATI Rage 6 card with a (less outdated) Nvidia GeForce4 MX440 that my dad gave me. I booted into Windows and it installed the correct driver and works great, so I know the card works. The problem is I try to boot linux and it gives me an Xserver error and just boots to the command propmt "Desktop Login:". How do I get my GUI back?

I'm running Suse 10.1 on an older Dell 8100.


jchance 09-15-2006 02:49 PM

Simply put you need to go to Nvidia's website and download the driver files and install them. Then use whatever utility your distro uses to configure x or manually change your xorg.conf file.

BCarey 09-15-2006 02:59 PM

The nv driver works quite well for recent versions of X. Edit your xorg.conf file, find the Graphics Device section, and change the Driver to "nv".


dsyebert 09-15-2006 05:38 PM

Sorry, maybe this is a stupid question, but how do I do this all from the "Desktop Login:" prompt?

BCarey 09-15-2006 05:47 PM

Enter your user name, then your password when you are prompted.

Then you need to open xorg.conf in a text editor. I use vi, but something like pico would be a little more newbie-friendly. Try: pico /etc/X11/xorg.conf.


dsyebert 09-15-2006 10:58 PM

Okay, but I will have to install the drivers berfore I do this, correct? Will I have to put the old card back in to install the drivers, or can I do that from the prompt as well?

BCarey 09-16-2006 12:01 AM

If you want to use the nvidia driver, you must install it. The nv driver comes with X, so you don't have to install anything.


dsyebert 09-16-2006 02:21 AM

I logged in and modified the xorg.config file to read "nv" for the driver. When I tried to save it, it said [cannot open file for writing: Permission denied]. Any Ideas? Also, do I leave the board name and vendor name alone? Will that change automatically?

BCarey 09-16-2006 12:07 PM

You need to edit the file as root user. To become root user enter the command "su" and the root password when prompted.

As to changing the descriptive information, it is not necessary but probably a good idea so you don't get confused later on. It would change automatically if you configure with your systems x configuration program, but since you are editing manually you'd need to change it yourself. All you really need is the Driver line and the Identifier line, which is then used a little further down in Screen Sections section.


dsyebert 09-16-2006 01:29 PM

Okay, that all worked great. I'm now running the GUI again. Just for kicks I decided to install the Nvidia driver from their site. I added the "" installation source to YOU as directed on their site. I go into YAST and select the packages to install and it gives me dependency conflits. It is telling me "there are no installable providers of kernels...". Why is this? I have the installation sources enabled and set to refresh.

BCarey 09-16-2006 02:03 PM

Sorry, can't help you with SUSE-specific stuff like YAST.

You could try compiling the nvidia driver yourself, though. It's simple, and you should get some more meaningful error messages if it doesn't work.


dsyebert 09-16-2006 02:20 PM

Okay. Thanks for all the help!

alpurl 09-18-2006 03:22 PM

Ok, I'm sitting here reading this and it's all Greek to me.

I had a similar problem and started another thread.

I managed to find something somewhere that I needed to type "Yast" while logged in to the command line without the GUI. I did that and managed to get my gui back. I still don't have 3d at all. And am trying to get this set up to run XGL.

I'm using SuSE 10.1 and my vid card is the nVidia FX5200.

I know nothing about compiling and such.

Nor do I understand how to actually change run levels and the like.

All times are GMT -5. The time now is 08:10 PM.